View Issue Details

IDProjectCategoryView StatusLast Update
0015831MediaMonkey for AndroidDBpublic2019-08-15 19:19
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0015831: Scanning: "preparing" notification after each reboot can last more than hour (library scan)
DescriptionAfter reboot of phone some users report that "preparing" notification after each reboot an last more than hour (library scan) and MMA forces Hight CPU/Mem Use that results in ut to 10% of battery use.

Detailed MMA log files are sent over the that time from a user in order to confirm behavior.

My tests showed normal behavior even on non MMA apps, but wonder if we can do something to improve this?

Delayed changes scan after reboot and use library only for some limited time time?
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=21&t=94146

Tests are done as of this post and report https://www.mediamonkey.com/forum/viewtopic.php?p=458322#p458322
TagsNo tags attached.
Fixed in build863

Activities

martin

2019-07-29 09:32

developer   ~0054225

Last edited: 2019-07-29 09:34

View 4 revisions

The issue is when the phone is rebooted the system initializes storages and a sd-card is mounted. Always when the sd-card is mounted (not only after reboot) and prepared an onMediaMounted action is received by MMA.
MMA wants to scan media on storage because media could be changed/deleted/added.
Scanning of all changes can take some time when library contains many thousands of tracks and can be annoying and unnecessary.
So I have added notification instead with two options:
"New storage mounted"
"Do you want to check for new/changed media?"
[Check][Postpone]


Fixed in build 1.3.5.861

peke

2019-07-30 01:14

developer   ~0054234

Verified 861

Please confirm the wording.

peke

2019-07-31 01:57

developer   ~0054250

Last edited: 2019-08-06 01:03

View 2 revisions

Small tweak.

1. Internal Storage Mounting should be ignored, as that mounting only happen on reboot.

2. If system Up time is Less than 1-2 Minutes MM should not prompt for scan but rather just ignore

3. Storage Name should be in Notification

4. There should be an option to skip on mount Scan globally per user preference, with warning that if user disable that feature MMA can't detect mew SDCards insert.

rusty

2019-08-08 19:56

administrator   ~0054292

When I rebooted my Pixel 2 (no SD card), the message appeared, but it's confusing because:
5) 'New storage...' There's nothing new on my system about the storage. The device was just rebooted. Also, '...check for...media'. Media in the context of MM usually refers to the storage media rather than the files. With that in mind, perhaps change the entire message to:
"Scan for updated media files?"

6) Most confusing: There's no text in the notification to initiate/cancel the scan. And, if the user clicks the notification, nothing happens--i.e. there's no popup asking the user to initiate/cancel the scan!

martin

2019-08-14 10:27

developer   ~0054340

1. Internal Storage Mounting - ignored
2. Added - 2minutes limit
3. Storage Name should be in Notification - added root path instead storage name (to avoid ANR)
4. I will postpone it to 2.0, I would like to have more options similar to it(e.g from deleting dialog instead countdown), but a user should have the possibility to restore it back in Options.
5) Text updated
6) If you expand the notification, you should have available two buttons "Check" "Postpone", I have added also dialog with same buttons when you click on notification content.

martin

2019-08-14 10:27

developer   ~0054341

Fixed in build 1.3.5.862

rusty

2019-08-14 19:22

administrator   ~0054350

Verified 1) that no notification appears for devices that don't contain external storage.

peke

2019-08-14 20:33

developer   ~0054353

Verified 1,2,3, 5,6 in 862

Much clear now and not intrusive, but works without problems even if SDcard is Hot Plugged.

Can you please open new bug for 4. and then close this?

rusty

2019-08-15 03:16

administrator   ~0054356

I would suggest that there isn't even a need for 4. i.e. if the notification appears and the user ignores it for x minutes, then it can just disappear. If you agree, just close this.

martin

2019-08-15 11:13

developer   ~0054360

Last edited: 2019-08-15 11:59

View 3 revisions

Re notification dismissed after 2 minutes
Fixed in build 1.3.5.863

rusty

2019-08-15 14:39

administrator   ~0054363

I just tested 863 on an S7/Android 8 that has an SD card, and no notification appeared. I'm not sure if this is a bug or if the notification is only supposed to appear on certain devices, so I'm leaving this for Peke to verify.

peke

2019-08-15 19:19

developer   ~0054364

Verified 863

Notification goes away after around 2 minutes

@Rusty
Notifications appear on all devices that uses battery saver and power optimization to unmount SDCard before turning power off for port and if you hot plug SDcard eg. Eject SDcard turn the phone on and after 10 minutes phone use plugin the SDcard while power is ON and you should see notification. All devices support SDcard HotPlug and they only can get corrupted if you eject SDcard during writing to it.