View Issue Details

IDProjectCategoryView StatusLast Update
0015828MediaMonkey (current)Synchronizationpublic2019-08-13 23:59
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.1.25Fixed in Version4.1.25 
Summary0015828: Sync: Volume leveling of tracks breaks Auto-Convert rules
DescriptionIf Volume leveling is enable in sync profile MMW can generate and sync ALAC lossless tracks instead of level tracks according to Auto-Convert rules.

Eg. Even Profile do not contain Conversion of M4A they are leveled and Convert End Results is Lossless track and instead of 4-5GB MMW Sync 13GB+ that also result not enough space on device.

Please note that This bug is discovered during Testing of 0015827 and should be handled along with it.

NOTE: User will send me file offline later, but checks of M4A files are higher than 900Kbps in MMW details (Copied file from Device and Loaded into MMW now playing to check file properties)
TagsNo tags attached.
Fixed in build1887

Relationships

child of 0015827 assignedmartin Sync: USB Sync FAIL to transfer and playlists re missing on device 

Activities

Ludek

2019-07-19 17:34

developer   ~0054169

Last edited: 2019-07-19 17:46

View 3 revisions

If the 'Level volume when synchronizing audio' is enabled (and the particular track does not match any enabled auto-convert rule) then MM finds the convert settings based on file extension.

Should I understand the issue is that for standard M4A file (that is lossy AAC) it converts to lossless ALAC ??
Based on the code it is possible, because both ALAC and AAC has the same file extension (M4A) which is probably causing the bug (seems a long-standing issue).

Ludek

2019-07-19 20:11

developer   ~0054170

Fixed in 4.1.25.1887 and merged into 5.0.0.2187

peke

2019-08-13 23:59

developer   ~0054337

Verified 1887 and 2191

Verified using settings from user DB.