View Issue Details

IDProjectCategoryView StatusLast Update
0015761MediaMonkey 5Main Panel/Toolbars/Menuspublic2019-10-29 20:31
Reporterlowlander 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015761: Improve access to Player and Panel layout config
DescriptionIt would be nice if the Customization sub-menu stays on screen after a user selects/deselects an item as some users will want to do multiple selection action here requiring 2 steps before any selection action can be made.
TagsNo tags attached.
Fixed in build2193

Relationships

related to 0014459 closedLudek A&D menu missing toggle 
related to 0015758 closedpetr Functionality of the Preview Window unclear (due to Title bar heading?) 
related to 0016066 closedpetr Name of the Preview window is unclear 

Activities

rusty

2019-08-13 13:26

administrator   ~0054324

1) Customizing the player is a real usability problem, but the suggested approach isn't standard behavior for a context menu. The root of the problem is that MM5 is overloading the context menu, so we should try to address that.

In addition there are a couple of related problems:
2)a) Although the 'Playing' list can be enabled/disabled via the Player context menu, there's no means of enabling the 'Preview' window
b) It's questionable whether there's a need to enable Playing/Preview on-the-fly since MM5 now has the 'Collapse/Expand' panel button.

3) There's no obvious means of adding 'Playing' or 'Preview' to the panels.

To solve all of the above I'd suggest:
1) Replace 'Customization' with 'Layout...' --> Open the Layout configuration panel. In the layout configuration, when the user clicks the Player options, a dialog containing the various options should open instead of a context menu:

---------------------------
Layout (Player)
---------------------------
Playback:
[x] Previous
[ ] Stop
[x] Next
Metadata:
[x] Title and artist
[x] Rating
[x] Remaining time
[x] Visualizer
Controls:
[x] Continuous
[x] Shuffle
[x] Play to...
[ ] Playing ?not needed?
[ ] Preview ?not needed?
Seek bar:
(o) Standard
( ) Waveform

2) Remove 'Playing' from the player context menu (since it's configurable via the 'Layout...' options, and can be toggled via the Panel toggle.

3) a) Add 'Layout...' to the bottom hamburger menus for 'Playing' and 'Preview' so that it's obvious how to change the layout.
b) This also implies that Layout of the Preview window should be configurable from within the 'Layout...' config panel in the same manner as the Player layout.
c) In the layout screen, change the name of the Art & Details window to 'Preview'

4) As long as we're cleaning up these context menus, remove the 'Mode' selector from the Preview window (since it's now easily/obviously configurable via the Preview window's title bar.

michal

2019-08-13 15:45

developer   ~0054325

Last edited: 2019-08-13 15:46

View 2 revisions

2) I agree, this option should not be on the player
3, 4) OK

1) I think this is not a good thing, it complicates simple tasks a lot for user. I agree with dialog in Layout -> Player instead of menu, as this should be for doing one-time more complex settings at once. But consider simple task - I want to switch seekbar to waveform. Now this is two clicks - rightclick to context menu - move to Customization - click to Waveform in submenu. After proposed changes it would be 6! Rightclick to context menu - click to Layout... - click to player layout customization icon - click to select Waveform - click OK to close player layout dialog - click OK to close options dialog. Way too much. What about leave current player customization menu as it is, and e.g. just add Layout... item there, just like it will be added to other "hamburger" menus? Player menu is not so large, and your solution would not shorten it at all too.

rusty

2019-08-13 20:02

administrator   ~0054328

1) The reason I was thinking that it's ok to impose extra clicks is because of my assumption that these settings are all 1-time configuration items (i.e. the user will configure it once and leave it). If you think that's not the case, then let's proceed as you suggested.

Note: if we proceed as you suggested, then we should probably modify the text slightly to clarify the differences between the various options:
Layout...
Layout (Player)
Options (Player)...

5) One other related item: The Playing hamburger menu should also have a link to 'Options > Auto-DJ / Now Playing'. i.e.
Options (Playing)...

michal

2019-08-23 16:46

developer   ~0054407

Fixed in build 2193. Implemented compromise, which is the best I think - setting layouts of Preview and Player moved to Options - Layout sub-pages, so that they can be accessed directly and without need of possible display of 3 modal dialogs at once (Options - Preview layout - Fields selection). This is more clear and also reduces the clicks, so there is no need for that sub-menus for quicker access I think. Please look at it and test, if this is suitable for you too.

rusty

2019-08-29 18:21

administrator   ~0054458

Tested 2193--looks good! Closing.

Ludek

2019-10-23 08:03

developer   ~0055073

Last edited: 2019-10-29 20:31

View 2 revisions

Moving layout config of Preview window to Options just adds confusion, see: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95285 and unnecessary adds another options panel.

If one wants to change layout of Preview window then he expects it to be part of the Preview context menu, isn't it?
Why one should go to Options to finally realize what the Options > Layout > Preview is for?

EDIT: Is being solved separately as 0016066