View Issue Details

IDProjectCategoryView StatusLast Update
0015680MediaMonkey 5Burning / Disc Handlingpublic2019-09-13 21:53
ReporterLudek 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015680: CD ripping: Properties edited before ripping are lost
DescriptionAs reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94392
the song properties edited before the ripping are lost during the rip process --- and the default metadata from freedb are used.
TagsNo tags attached.
Fixed in build2197

Activities

Ludek

2019-07-08 14:45

developer   ~0054099

Last edited: 2019-07-08 16:50

View 3 revisions

When the CD isn't in library then it stores just the basic metadata like title/album/artist/genre into the CDPlayer.ini file.

Workaround is (as Peke suggested) to add the files into the library before ripping (to keep all the metadata).

EDIT: Note that in MM4 also the custom fields were preserved when the tracks were edited immediately before ripping (because the same memory instances of the tracks were used for ripping).
We should fix this in MM5 (at least to to the same level as in MM4).

Ludek

2019-07-08 17:27

developer   ~0054101

Fixed in 2186

peke

2019-07-10 22:21

developer   ~0054129

Verified 2186

Edited properties prior to RIP now works as in MM4.

My workaround always worked like that eg. I always suggest users to firstly add 10+ CDs into Library and While ripping one he can edit/correct metadata fro others. it saves time considerably especially on larger ripping operations.

Ludek

2019-09-13 07:27

developer   ~0054622

Last edited: 2019-09-13 08:26

View 2 revisions

Re-opened:
There is still one situation when some pre-edited data might be lost, specifically when the rip audio CD is selected via the Tools menu, details at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94392#p461491

=> Fixed in 2197

peke

2019-09-13 21:53

developer   ~0054641

Verified 2197

Edits are persistent in all cases