View Issue Details

IDProjectCategoryView StatusLast Update
0015676MediaMonkey 5Synchronizationpublic2019-05-17 08:43
ReporterLudek 
PriorityurgentSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015676: Sync to GPM is broken until MM5 is restarted (in some environments)
DescriptionIn some environments (like Barry's)
when MM5 is freshly installed and GPM account subscribed then loading the dictionary (like [Devices&Services > Google Play Music > All tracks]) silently fails and returns no tracks.
By remote debugging with Barry we found that GPM server returns: {"success":false, "reloadXsrf": true}
Workaround is to restart MM5.
Steps To Reproduce* deleted MM5 & re-installed
* started debug
* allow MM5 to restart & import tracks from MM4
* added, authenticated, approved MM access to GPM
* ended up waiting 10 minutes ... D&S>GPM Alltracks show as empty ... left D&S via the Media Tree ... returned to D&S>GPM AllTracks .. still empty
* close MM5 and restarted it
* returned to D&S>GPM ... clicked AllTracks and it started loading track links from GPM library
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94383
TagsNo tags attached.
Fixed in build2176

Relationships

related to 0015492 closedpetr Performance: dialog opening is slow 

Activities

Ludek

2019-05-16 11:50

developer   ~0053538

Last edited: 2019-05-16 11:50

View 2 revisions

Probably another regression caused by the shared dialog windows. GPM 'sign in' window remains opened in the background and the GPM server thinks that it is a kind of XSRF attack.

Ludek

2019-05-17 08:23

developer   ~0053546

Barry indicated that it happens also with build 2164 -- so it is not a regression caused by the shared dialog windows: 0015492

What helped is to open the 'Sign in' in the default browser (instead of in MM dialog).
So I used this approach for build 2176.

--------------------------------------------------------------------
Also Barry's feedback re opening in the default browser's :
"I think that this way is much better ... I very much disliked the previous mechanism .... the security of a person's Google password is big deal because it the access to much private and identity info ... I feel protected when entering the pwd into a browser window that is presented by Google .... I don't feel protected when entering this into a Window that is generated by some other vendor (eg. you) .... as there is the possibility of skimming.

When I saw a non-Google window was wanting my Google pwd, I was reluctant to do so, but in the end did so due to my long association with MM. ... I think that it would be an obstacle for some people ... and you are exposed to someone getting hacked in some other way, thinking and publishing that the exposure may have been due to MM s/w, which could cause a lot of reputational damage."