View Issue Details

IDProjectCategoryView StatusLast Update
0015635MediaMonkey for AndroidSynchronizationpublic2019-06-07 22:51
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version 
Target Version1.3.5Fixed in Version1.3.5 
Summary0015635: Sync: repeated re-downloading on wifi sync when hash is missing and remote_size was set to -1
DescriptionResyncing to MMA over WiFi trigger re-downloading of files even Library is in sync. Instead of just updating MMW library with playcounts.
Steps To Reproduce1. Do a sync to make both libraries in sync LOG B4JQMYJUEL
2. Start Sync Again after playing about 40 songs synced in step 1. Log ID: PB51FJ1E4Z
3. Approx 75% of played songs are re downloaded on this sync. Log ID: 7C42Q8AYMS
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=458049&sid=7c0501869afab476b1bcbca308a96eb8#p458049
TagsNo tags attached.
Fixed in build857

Relationships

related to 0013305 closedmarek MediaMonkey (current) WiFi sync: Auto-converted tracks are needlessly re-downloaded (after adding the ALAC plugin) 
related to 0014208 assignedpeke MediaMonkey (current) Sync: Conversion Break Mixed sync Rule 

Activities

martin

2019-05-03 22:21

developer   ~0053419

Last edited: 2019-05-03 22:21

View 2 revisions

I don't know how it occurred to the user, but I can replicate it these steps:

1)Sync some playlists with flac tracks with autoconversion rule to mp3 via wifi sync
2)Uninstall MMA and delete MediaMonkey folder
3)Install MMA and run MediaStore sync
4)Needs to be set up again autoconversion rules in MMW (new hash value generated)
5)Sync 1. playlist previously included to sync, all tracks from the playlist have updated "ac_media_hash" field, and HashVersionUpdated flag set as processed
6)Add 2. playlist to sync, and run wifi sync -> wifi_item_id updated, but not "ac_media_hash", the tracks have no modification and HashVersion is not updated
7)When a modification is made for some tracks from playlist 2, then the track is re-downloaded because MMA has "null" value in "ac_media_hash" for this track.

The issue is how we can detect these tracks and how we can decide that these tracks are already converted, if possible.

I will continue on Monday.

martin

2019-05-29 06:28

developer   ~0053655

Fixed in build 1.3.5.857

peke

2019-06-05 22:10

developer   ~0053739

Last edited: 2019-06-06 18:50

View 2 revisions

Verified 857

I tested using your steps and tracks were not uploaded again, so original issue is fixed.

Can you please Explain a fix in more details so that I can better test cases?

Like when you sync tracks to SDCard and then move that SDcard to another device that will have same conversion rules (eg. same tracks will be in sync list just device is changed) and converted tracks already on device (hashtag should not change) so WiFi Sync should not redownload them again and use that hash to quicker pair existing tracks to those in MM5.

It is not clear what exact sync case this fix cover even based on your description of bug in 0015635:0053419 cover test case for this fix.
Example cases:
Case 1: I would expect that converted tracks have hashtag based on Audio fingerprint of original track in MM5 so that in process of pairing track is paired quickly and flagged "already synced"

Case 2: I would expect that even MM5 library is recreated tracks on the phone/SDcard that were converted originally using old DB are not re-downloaded, but recognized as "already synced"

I hope this makes sense and it should be added as new feature/bug in future MMA versions.

peke

2019-06-07 22:51

developer   ~0053784

Confirmed verification in 858