View Issue Details

IDProjectCategoryView StatusLast Update
0015583MediaMonkey (current)Main Panel/Toolbars/Menuspublic2019-05-17 11:17
Reporterpeke 
PriorityhighSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version4.1.24 
Target VersionFixed in Version4.1.25 
Summary0015583: Navigation with keyboard can trigger crash
DescriptionWhen user quickly navigating Now Playing List to edit look files using TAB/SHIFT+TAB and F2 with Arrows can trigger Crash.

In rare cases Crash Dialog shows in most cases only AV shows.

It is not reproducible when using mouse.

Video of crash on user PC is uploaded, LOGs from previous session are in Ticket.

I can't reproduce in MM5 at all, also can't be sure of exact steps as sometimes crashes after 15 minutes and sometimes after 30 seconds, so no exact steps as keys for navigation needs to be normally without exact key press order.
Additional InformationYKD-756-67655
https://www.mediamonkey.com/forum/viewtopic.php?f=7&t=94161
TagsNo tags attached.
Fixed in build1885

Activities

Ludek

2019-04-10 07:58

developer   ~0053171

Fixed in 4.1.25.1884

peke

2019-05-14 21:04

developer   ~0053517

Verified 1884

Unable to crash it, closed and Forum updated to note user about new version.

peke

2019-05-15 19:22

developer   ~0053531

Reopen user and I can still crash it when using Keyboard to inline edit Now Playing.

Few ELF Sent and one from attached picture uploaded to FTP.

peke

2019-05-15 19:23

developer  

bug15583.jpg (208,230 bytes)
bug15583.jpg (208,230 bytes)

Ludek

2019-05-17 08:13

developer   ~0053545

Fixed in 1885

peke

2019-05-17 11:17

developer   ~0053549

Verified 1885

Can't replicate anymore TAB positions are changed correctly even for Now Playing view.

Only thing is that there is no indication what column is focused when navigating with arrows in Now playing, like in other nodes. But that was always like that.