View Issue Details

IDProjectCategoryView StatusLast Update
0015576MediaMonkey 5Generalpublic2019-04-16 19:36
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015576: Renaming title of artist/album after selecting it from Wrong artist/album menu should be optional
DescriptionCurrently MM5 automatically renames artist/album, when user selects different from Wrong artist/album menu. It is not always desirable. We should add possibility to switch off this renaming, e.g. by "'Also rename Library Artist/Album" option in Wrong artist/album popup menu. This setting should persist.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=456453#p456453
TagsNo tags attached.
Fixed in build2169

Relationships

related to 0013745 closedmichal Add possibility to rename artist 
related to 0015590 closedmichal Wikipedia Artist Metadata doesn't appear for some artists (caused by 'another artist' function) 

Activities

michal

2019-04-01 17:41

developer   ~0053134

Fixed in build 2168.

rusty

2019-04-09 20:25

administrator   ~0053168

Tested 2168. I would just suggest a change in strings to a single generic string (hopefully one that we already use elsewhere). e.g.:

Also rename Library Artist --> Update tracks
Also rename Library Album --> Update tracks

rusty

2019-04-10 17:54

administrator   ~0053176

Note: Michal indicated:
I think, "Update tracks" could be misleading. Tracks (files) are updated only in case "Update tags when editing properties" is switched on in Options - Tags & Playlists. This issue was about automatic renaming artist/album in library.
E.g. you have artist "Kylie", open artist page, select wrong artists - "Kylie Minogue". And there are 3 possibilities:
1) only assign MusicBrainz ID from selected Kylie Minogue to your artist Kylie
2) do 1) and rename Kylie to Kylie Minogue in MM DB.
3) do 2) and tag all relevant files by new artist
Setting in this issue affect, whether the artist in MM DB should be renamed, but not, whether the change should be also written to files, it is determined by the other option. Only if both are on,

I think it's a valid point, but by the same token, MM uses terminology throughout that implies DB and tracks are updated when changes are made. e.g. 'Auto-tag', 'File Properties', 'Rename', etc.
Additionally, I think that 'Update tracks' is clearer since 'Also rename Library Artist' doesn't clearly communicate that the metadata for associated tracks will be updated.

An alternative could be 'Update database', but I think that 'Update tracks' is more consistent with the rest of the UI.

michal

2019-04-11 11:18

developer   ~0053180

Fixed in build 2169.

rusty

2019-04-16 19:35

administrator   ~0053257

Verified 2170.