View Issue Details

IDProjectCategoryView StatusLast Update
0015456MediaMonkey 5Tagging / organizing (properties / auto-tools)public2020-11-25 10:39
Reporterpeke Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0015456: Properties: Artwork. Support for cached images and other tweaks
DescriptionWhen Multiple Tracks are Edited there are some inconsistency.

2. As Album properties are open Artwork Tab should contained suggested(found) Album Art but it doesn't

3. If Suggested Album art is available Apply To all Selected files should be selected by default
Steps To ReproduceSteps To reproduce:
1. Open Album View and make sure that Album art is found but Not saved (Save Icon is shown)
2. Using ? -> Properties open Album Properties
TagsNo tags attached.
Fixed in build2189

Relationships

related to 0013681 closedpetr It's difficult to view artwork details of multiple tracks in MM5 
related to 0015502 closedmichal YouTube: Properties Dialog do not work and not consistent with properties for normal tracks 
related to 0016481 closedmichal Album art save: Saving Album art for a single track replaces all Album arts in a multi-artist album by default 
related to 0017130 closedmichal Properties: Artwork is tagged even when unchanged 

Activities

peke

2019-02-12 02:44

developer  

bug15456.jpg (162,184 bytes)   
bug15456.jpg (162,184 bytes)   

rusty

2019-02-12 03:50

administrator   ~0052596

fyi: these issues occur whether a single track or multiple tracks are edited. Also, the decision had been taken early in MM5 that cached metadata would not be displayed in the Properties dialog. We may want to revisit that, though I wouldn't consider it a high priority.

Note: I've moved the item below to a separate bug:
1. Properties Dialog Do not Have Title. (Expected to show either Parent Source name that is used to open properties eg. "Album: <ALBUM NAME>" or like in MM4 "Edit Properties for multiple files"

rusty

2019-02-15 21:03

administrator   ~0052647

2) I suppose that we could support cached artwork relatively easily by adding the 'Save' icon to any AA image that is cached and not saved. Clicking it would cause the image to be saved to the tag _immediately_ i.e. it would be saved even if the user 'Cancel's out of the Properties dialog. Any downsides?

3) Re. 'apply to all': I wouldn't enable this at this point because to do so for mass edits would result in album art for multiple albums being applied to all tracks. i.e. i'd leave it as is--the current logic is designed to prevent this.

While we're making changes in this area, a couple of other suggestions:
4) How about getting rid of the 'show details' option, and just show the details in the same manner as in the image search dialog (i.e. superimposed on the corner of the artwork).
note: once implemented, 'Apply to all selected files' can be moved lower (it currently looks a bit out of place

5) If there's an existing artwork image, clicking on it should work the same way that the auto-tag dialog does (i.e. allows the user to replace it with an alternate).

Lastly cosmetic issues:
6) How about getting rid of the 'lookup image..' button, and instead have a '+' where new artwork would be added?

7) Similarly, how about getting rid of the 'remove' button and instead just show an 'x' in the upper right corner for each image allowing the user to delete it.

Please triage as you see fit.

michal

2019-03-07 17:33

developer   ~0052899

2) I would not save it to tag immediately, that would be inconsistent, it could better work the same as adding found image from searching, i.e. add image to cover list (visually remove save icon from it) and save it to tag after pressing OK of the whole dialog, like always. And this cached and not saved AA image would be displayed only if editing tracks from one album.
3) agree with Rusty
4) details in search dialog contain only image size, here we could have also file size and path, which could be quite long, no chance to fit it above thumbnail.

michal

2019-03-18 13:19

developer   ~0053007

1) already fixed in separate issue
3) won't fix
2), 4), 7) fixed in build 2167.

michal

2019-03-18 13:34

developer   ~0053008

Last edited: 2019-03-18 13:38

View 2 revisions

5) double-click is opening artwork detail now, it would collide. We currently do two different things when (double)clicking artwork:
  a) open artwork in full size - in art window, view header, properties dialog
  b) open alternate image selection - auto-tag dialog (full size is only in context menu)
It could be quite confusing I think. Do you really want to move properties dialog from version a) to b)? Just to be sure...

6) it would be not practical in case of more images already present, user will have to scroll to the end to find the button. Maybe we can just replace current button with smaller "+" button? Or look at how it looks now, in 2167.

peke

2019-03-18 13:49

developer   ~0053009

Revising 3) we all missed fact that as seen in my attached picture Album is Same for all tracks so enabling 'apply to all' default would be reasonable in such case? in all other cases I agree with rusty that is should be disabled, also if user checks/uncheck Album Tick Box it should also enable/disable 'apply to all' as user is tagging multiple tracks as Album so Album Art changes should apply for all tracks.

rusty

2019-07-23 01:18

administrator   ~0054192

Verifed everything in 2186 except the following:
3) If all selected tracks are from the same album then yes, it would make sense to apply the change to all of the selected tracks.
3b) I just noticed that in this build MM isn't offering the option to [x] Apply to other tracks on the album (when the user selects a single track or multiple tracks from the same album). Is this a regression?
5) I think that b) probably makes more sense in the context of a properties editor
6) let's leave as is

rusty

2019-07-30 19:32

administrator   ~0054245

Re. 3b) Note that this issue already existed in MM4. See https://www.screencast.com/t/UUonfLSbSqI

michal

2019-08-01 08:09

developer   ~0054256

3b) fixed in build 2189, now it is possible to apply artwork changes to all selected or to whole album even for multiedit
5b) after offline discussion left as is

peke

2019-08-05 17:12

developer   ~0054259

Verified 2190

As noted in 0015456:0054256 it is now available in multi edit.