View Issue Details

IDProjectCategoryView StatusLast Update
0015396MediaMonkey 5Synchronizationpublic2020-07-22 16:38
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015396: Playlists synced to GPM are duplicated when synced back to local library
Description1) create a playlist 'Test1' and put a track into it
2) check the playlist on the [Devices & Services > Google Play Music > Library Content] page
3) click [Sync now]
=> playlist is synced to GPM as expected
4) check the option '[x] Scan Google Play Music content to the local database' on the 'Remote Content' page
5) click [Sync now]
=> playlist 'Test1' is now duplicated in MM library
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93741
TagsNo tags attached.
Fixed in build2153

Activities

Ludek

2019-01-28 15:39

developer   ~0052303

Last edited: 2019-01-28 15:43

View 2 revisions

Further issue is that GPM playlists has only 1000 tracks, this seems to be GPM's limitation: https://productforums.google.com/forum/#!msg/play/aEYeLSQqWng/XinPPJXyBQAJ

Ludek

2019-01-28 19:35

developer   ~0052307

Last edited: 2019-01-28 19:37

View 4 revisions

GPM playlist(s) are synced back to MM as another copy because they have different GUID than the original MM library playlist(s).
This doesn't happen in case of other cloud based sync profiles (MMS, OneDrive, Google Drive, DropBox), because there the playlist (and its GUID) is always created in MM5, so the instances are always the same.

GPM is special also with relation to the limitation to 1000 tracks per playlist. Because of this I guess that it is all right to track the GPM playlists as another instance of original MM playlist (i.e. duplicate), but we should group them under the 'Google Play Music' parent playlist in MM library, so that the origin of such a playlists is clear.

Ludek

2019-01-28 21:09

developer   ~0052310

Fixed in 2153

peke

2020-07-22 16:38

developer   ~0059070

Verified 2261

Unable to replicate, tested on 10 Playlist even renaming playlist on both MM5 and GPM once paired changes are propagated to MM5.