View Issue Details

IDProjectCategoryView StatusLast Update
0015226MediaMonkey 5Synchronizationpublic2019-09-20 20:56
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015226: Synchronize tags feature is confusing with regard to cloud tracks in MM library
DescriptionThe old 'Synchronize tags' appears in context menu for library tracks (be it local, cloud or cloud+local).
This is confusing as users expect that using the feature on cloud tracks rather synchronizes track metadata between MM database and cloud database.

I would suggest to either remove it from MM5 or make it available only for local tracks (not paired with cloud copy) and make it available only when
Options > Library > Tags & Playlists > [x] Update tags when editing properties
is unchecked.
And it that case the terminology needs to be changed to understand what the feature is doing.

Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&e=1&view=unread#p452822
TagsNo tags attached.
Fixed in build2199

Relationships

related to 0015955 feedbackLudek Files to edit: out-of-date tags / mismatched tags: usability issues 
related to 0015972 closedLudek Nodes in the tracklist don't display Tooltips 

Activities

rusty

2018-12-11 20:37

administrator   ~0051739

I think that the most confusing aspect of this feature is the word 'synchronize'. But if we change that word, we also need to change the 'Unsynchronized tags' node.

Perhaps we can change it to 'Update tags' and the node name to 'Out-of-date tags'.

As to hiding the functionality when it isn't relevant, I agree. i.e. show it only for Local/Networked tracks (not for UPnP, cloud, MMS).

Ludek

2018-12-14 15:52

developer   ~0051782

OK, I changed the terminology (+showing it only for local tracks) in 2140.

But I think that the menu "Update tags" is still confusing for the library+cloud tracks (local tracks linked with a cloud location).
So question is: shouldn't we remove this item from right-click menu entirely when
Options > Library > Tags & Playlists > [x] Update tags when editing properties
is checked?

Or maybe better -- we could leave the item only for the tracks in the 'Out-of-date tags' node (where user can also see which tags are out-of-date), don't you think?

rusty

2018-12-14 18:16

administrator   ~0051784

Wouldn't removing the menu option in cases where it applies be even more confusing? i.e. if the user wants to update the tags for a track (whether that track has a copy in the cloud or not) it would be confusing if the menu option was unavailable.

We might want to update the Tooltip to indicate 'Update tags of selected local or network-based tracks...'

btw, the problem that you're describing is similar to the one we'd discussed regarding deletion of tracks at 0015209 (namely which track is the operation is intended to apply to). I suppose that in this case, the operation should apply to whichever tracks it's relevant for. i.e. any tracks that are local or network-based.

Ludek

2018-12-14 18:30

developer   ~0051785

I think that in case of the default choice:
Options > Library > Tags & Playlists > [x] Update tags when editing properties
there is no need for the "Update tags" menu item as the tags are _always_ automatically updated when editing properties, so the item does nothing (from the user perspective).

So I guess that the only place where the item is really needed is in the 'Out-of-date tags' node, in that case the item should be the very first item (which isn't currently) ?

BTW: I am testing MM4 and in MM4 the item "Synchronize tags" is only available in the "Unsynchronized tags" node, so what is the point of doing this differently in MM5 ?

Ludek

2018-12-14 20:13

developer   ~0051787

Unified with MM4 in the build 2140.

Ludek

2019-09-16 09:15

developer   ~0054655

Last edited: 2019-09-16 09:16

View 2 revisions

Re-opened:

Users have no idea what the "Out-of-date tags" node means, see: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95091
We should review the wording and/or add a tooltip describing that the node actually shows differences between metadata in the database (versus metadata in file tags).

rusty

2019-09-19 14:05

administrator   ~0054708

How about:
Out-of-date tags --> DB / Tag mismatches
Tooltip: This finds all tracks with tags that don't match the database, highlighting the mismatched values. If tracks don't show highlighted fields, try enabling additional columns.

Ludek

2019-09-19 14:33

developer   ~0054710

Sounds good, added in 2199

rusty

2019-09-20 20:49

administrator   ~0054756

Verified 2200.