View Issue Details

IDProjectCategoryView StatusLast Update
0015215MediaMonkey 5Framework: Taggingpublic2018-11-29 01:34
Reporterpeke 
PrioritynoneSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0 
Summary0015215: ID3v2.x Genre TAG: Numeric Genre Tags in TCON frame could be Translated according to Genre Table
DescriptionWriting only ID3v1.x Genre Numeric Tags in TCON frame could be Translated according to Genre Table latest known https://en.wikipedia.org/wiki/ID3#Genre_list_in_ID3v1[12]

but upholding rules per ID3v2.x TCON frame standard:
v2.3.0 - http://id3.org/id3v2.3.0#Text_information_frames_-_details
v2.4.0 - http://id3.org/id3v2.4.0-frames Section 4.2.3

Sample files sent to me by user Containe TCON = "52" and TCON = "88" breaking standard description especially as ID3v1.x TAG didn't contained Genre ID from above list.

Merge into MMW only if it is low risk with other compatibility and Extended genre standard for adding custom Genres.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=4&t=92409
TagsNo tags attached.
Fixed in build2135

Relationships

duplicate of 0015216 closedmichal MediaMonkey (current) ID3v2.x Genre TAG: Numeric Genre Tags in TCON frame could be Translated according to Genre Table 

Activities

michal

2018-11-21 09:55

developer   ~0051602

Fixed in build 2135. Merged to MM4.

peke

2018-11-29 01:34

developer   ~0051641

Verified 2135