View Issue Details

IDProjectCategoryView StatusLast Update
0015147MediaMonkey 5Framework: Taggingpublic2018-10-19 02:22
Reportermichal 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015147: ID3 v1 tags containing international characters are read as Chinese
DescriptionID3 tag v1 does not support unicode/international characters. In case MP3 file contains some tag only in ID3 v1 and not in ID3 v2, MM displays international characters (e.g. ?/ž/š) like Chinese. Although there is no standard for character encoding in ID3 tag v1, we should consider if we can read this better (probably as Ansi/local coding?). It seems, other applications like Winamp read this from files from the forum post (below) better.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=1&t=91469#p450513
TagsNo tags attached.
Fixed in build2129

Activities

michal

2018-10-14 16:09

developer   ~0051331

The main problem is, that the files have mismatched ID3 v1 and ID3 v2 tags. They contain empty title tag v2, but with encoding set to UTF16, and title is saved to v1 tag, but saved as Windows-1250 ASCII. MM should not leave encoding from v2, if the tag content is read from v1 (because v2 is empty). It reads ID3v1 as UTF16 then and it creates that Chinese text.

michal

2018-10-14 17:50

developer   ~0051332

Fixed in build 2129. Not merged to MM4, as it is very rare situation and we use different pre-build version of id3lib there, where we cannot do changes.

peke

2018-10-19 02:22

developer   ~0051390

Verified 2129