View Issue Details

IDProjectCategoryView StatusLast Update
0014982MediaMonkey 5Synchronizationpublic2018-11-29 01:43
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformWindowsOS-OS Version10
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014982: Issues with syncing to external HDDs
DescriptionWhen user wants to sync to external HDD (not a removable device) then:

1) In Windows 7 the disc is not presented as syncable device, user need to download and use the USB mass addon:
http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-plug-in/
to be able to sync it

2) In Windows 10 the disc is presented as removable device, but
a) without drive letter
b) is auto disabled due to 0013191, 0009913
c) has issues (freezes for some users - #NUM-655-86530 ), duplicate profile creation - HVG-383-44902 - 0014931

The solution would be to present the disc with drive letter and access it using drive letter whenever possible (like in case of portable devices / USB sticks)
Additional Information#HVG-383-44902, #NUM-655-86530 + https://www.mediamonkey.com/forum/viewtopic.php?f=7&t=89658
TagsNo tags attached.
Fixed in build2135

Relationships

related to 0013191 closedLudek MediaMonkey (current) Scanned external HDDs in MMW should be excluded from Portable devices list 
related to 0009913 closedLudek MediaMonkey (current) Win 8: CPU utilization goes to 70-80% when external USB drive connected 
related to 0014931 closedLudek MediaMonkey (current) "Media transfer process appears to be frozen" message while scanning large USB drive 

Activities

peke

2018-07-23 21:54

developer   ~0050807

Lowering priority to be worked on details offline.

Facts:
- Raid controller with Hot Swap is not external drive
- There is no RAID controller that support Hot Swap, 99% of every SATA2+ controllers support hot swap and Refresh of Hot Swap drives is motherboard/controller function.

Re 2a: Auto Refresh is disabled/Not Available in motherboard BIOS, usually fixed with Driver update or with apps like Zentimo to Hard Fix drive letter for device. Note this is not win 10 only issue but I see it in Win 7 also

2b: I find that behavior desirable, I would only change that if Drive is scanned in library profile should be Disabled/Grayed not allowing on/off and in case of clicking to open properties Dialog would be shown that device is in Library and can't be used as Portable/Sync device

2c: FYI SATA Hot Swap is done disconnecting DATA CABLE and then Disconnect Power Cable.

I think this is more for MM5 than MMW due the non normal user setup.

Ludek

2018-07-24 12:34

developer   ~0050808

OK, note that I just wanted to fix 2a/2c for MM4 and plan to leave 2b as is, i.e. the external discs will be auto-disabled, but when enabling they will get drive letter in order to access the content by Windows file system whenever possible (as it is faster and more reliable than MTP/WMDM)

Ludek

2018-07-25 15:06

developer   ~0050830

2a/2c implemented in 4.1.22.1876 (and merged to 5.0.0.2117)

Posted testing stuff (MM.exe and d_WMDM.dll) to the user to confirm.

michal

2018-07-30 12:56

developer   ~0050843

Commit 31627 is causing app freeze in MM5 (logs 0833B361_5.0.0.2050, 3CD6B361_5.0.0.2050, happens always when opening scan dialog).

Ludek

2018-08-02 12:22

developer   ~0050853

Last edited: 2018-08-02 12:22

View 2 revisions

Fixed

Ludek

2018-08-07 13:22

developer   ~0050878

Last edited: 2018-08-07 22:06

View 3 revisions

2b) we should probably change the original defaults in 0009913 and leave external HDDs visible just with disabled scanning ([ ] Scan as soon... checkbox), especially when 2a/2c is implemented now (that should speed the scanning and make it less CPU consuming and more reliable). BUT, we should ensure that they are still auto-disabled whenever user scans some tracks into library via Add/Rescan (i.e. 0013191 case)
Alernatively we could add the prompts suggested by Rusty in the past here 0009913:0032884 , but this would be better to implement for MM5 (due to a need for new string translations)

peke

2018-10-01 21:11

developer   ~0051226

2b) I would leave as is, but would consider making new device wizard similar to MMA that would better allow non iterate users to quickly setup devices something like 0014101 and/or make unified variation of 0014606 to make quick predefined settings which would be easily expandable by MMDC profiles.

Ludek

2018-11-26 09:08

developer   ~0051617

Last edited: 2018-11-26 11:34

View 2 revisions

2c isn't properly fixed, for the storageInfo.xml the MTP is still used (not the access via drive letter), details at http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=91709&start=15#p452646
EDIT: I found that 2c (profile mismatch) was actually a regression in MM5 only (works fine in MM4).

Ludek

2018-11-26 11:30

developer   ~0051618

Last edited: 2018-11-27 13:09

View 2 revisions

Fixed in 2135 and sent testing stuff to user for confirming the fix...

Re-opened, based on the log it is still not working for the user...

Ludek

2018-11-28 10:16

developer   ~0051636

Last edited: 2018-11-28 10:19

View 2 revisions

Fixed in 2135.

Test note: This time it was rather for flash drives which name is like 'N:\'. MM5 (unlike MM4) uses the name in cache path when caching the storageInfo.xml to the temporary directory. And because chars like ':' are not allowed in filename then the MTP error 8007007B appeared while trying to transfer storageInfo.xml to the temporary directory.

peke

2018-11-29 01:43

developer   ~0051645

Verified 2135