View Issue Details

IDProjectCategoryView StatusLast Update
0014934MediaMonkey 5Syncpublic2020-07-22 00:01
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014934: Track pairing/matching tweaks
DescriptionWhen MM pairs track based on metadata (e.g. when scanning unknown remote library into local library or during sync with unknown remote library) then the matching process fails in following cases:

1) Where the track title contains a parenthesis, e.g. "The Fish (Schindleria Praematurus)" or "Honey in Your Hips [Alternate Studio Take]"
2) Where the track title has an apostrophe or a question mark or a period, ie. "Hard Travelin'", or "Who Are Parents?", or "Bess St."s
3) Where the remote version of the album has a suffix such as "[Expanded]"
4) Where the remote and MM5 report a track length difference exceeding 2.n seconds ... a latitude of 3.n seconds would get most ... a latitude of 5.n would get all of the ones that I have noticed so far
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90338&p=447071#p447066
TagsNo tags attached.
Fixed in build2142

Relationships

related to 0015026 closedrusty Syncing Google Drive fails to add tracks to the library 

Activities

Ludek

2018-07-04 19:02

developer   ~0050702

Last edited: 2018-07-04 19:09

View 4 revisions

1&2&3) Fixed
4) Expanded the latitude to 3 seconds, I wouldn't go over this limit (as there is a high probability that it isn't the same song then). But if there is only one track in the database with same artist+title then the duration isn't compared.

Fixed in 5.0.0.2115 and merged also to 4.1.22.1874 where the pairing is used on the first sync with MMA (when tracks pre-exist on the device)

peke

2018-07-14 01:35

developer   ~0050763

Verified 2115

4) I also agree on latitude to 3 seconds as it is very rare <0.1% where difference can be >3s

Ludek

2018-07-23 12:34

developer   ~0050801

Last edited: 2018-07-23 14:43

View 4 revisions

User found some further mismatches: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486#p447586

4) user is still seeing issues (even with latitude 3 seconds)
5) titles containing '<', '>' fails to match
6) multi-value fields, i.e. if there is only one of the multiple artists then the tracks aren't matched (once the title or artist contain some special chars)

Ludek

2018-07-23 14:43

developer   ~0050805

Fixed in 2116

Ludek

2018-08-02 14:31

developer   ~0050855

Last edited: 2018-08-02 20:35

View 3 revisions

Re-opened, further improvements discussed here: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=448018#p447780

7) As the latitude for many tracks can be even more than 5 seconds (according to the Barry's GPM library: https://www.dropbox.com/s/uzhi1r552f03swx/MM%20sync%20dups.png?dl=0 )
then we should compare the latitude only when there isn't an exact match of album+artist and album+artist aren't empty values. This prevent from false matches for tracks like 'Track 12' -- as they mostly have no album+artist fields filled.

Ludek

2018-08-02 20:42

developer   ~0050861

Fixed in 2117

Ludek

2018-08-07 13:01

developer   ~0050877

Last edited: 2018-08-07 15:09

View 4 revisions

Further improvements suggested here: http://www.mediamonkey.com/forum/viewtopic.php?p=448153#p448153

8) Failure to match classical music tracks when track duration latitude is out of tolerance and multiple artist tags differs (extra Conductor, and Soloist, and sometimes Orchestra)
9) Titles containing $ and / fails to match
10) Titles with leading / trailing spaces fails to match in some cases + tracks with special appendixes

Ludek

2018-08-07 15:36

developer   ~0050880

Fixed in 2118

peke

2018-08-15 13:27

developer   ~0050925

Verified 2120

Ludek

2018-10-31 13:35

developer   ~0051514

Re-opened, there are still issues with matching GPM tracks, details at http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=451361#p451338

Ludek

2018-10-31 17:04

developer   ~0051515

Last edited: 2018-10-31 17:06

View 2 revisions

Fixed in 2131

It is now able to pair also titles with additional spaces,
e.g. strings 'Vague / E La Nave Va' and 'Vague/E la Nave Va' are considered as same.

peke

2018-11-15 01:57

developer   ~0051554

Verified 2132

Ludek

2018-11-19 09:30

developer   ~0051566

Last edited: 2018-11-19 09:36

View 3 revisions

Re-opened:
To be revised again due to http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&e=1&view=unread#p452181
where user supplied his DB.
It seems to fail for titles for which the last character is a special char.

Ludek

2018-11-19 15:48

developer   ~0051571

Last edited: 2018-11-19 17:55

View 2 revisions

Fixed in 2133 and covered by unit tests

peke

2018-11-20 18:14

developer   ~0051584

Verified 2133

Ludek

2018-12-03 11:26

developer   ~0051652

Last edited: 2018-12-03 13:14

View 4 revisions

User confirmed that it is much better now : http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90486&p=453043#p453039
He has only 165 unmatched from 43,000+ tracks uploaded by the Google Music Manager

But there seems to be still issue with trailing spaces when comparing ('str' <> 'str ')
To be fixed and covered by unit tests...

=> Fixed in 2136

Ludek

2018-12-17 12:26

developer   ~0051803

Last edited: 2018-12-17 14:09

View 4 revisions

It is much improved in 2138 (user has only 40 unmatched from 43,000+ tracks uploaded by the Google Music Manager)
But there are still some improvements/mismatches TBD (details being solved via PM with Barry), namely:

a) track length latitude tolerance does not work for long tracks (e.g. 18 mins)
suggestion: keep 3s latitude tolerance for tracks under 5 minutes, otherwise use 1% tolerance for tracks above 5 minutes
b) track 'La Scala, Part I' was matched with 'La Scala, Part II' due to a bug in matching

=> Fixed in 2142

peke

2020-07-22 00:01

developer   ~0059052

Last edited: 2020-07-22 00:01

View 2 revisions

Verified 2261

Tested on 100 Random tracks uploaded to GPM no issues.