View Issue Details

IDProjectCategoryView StatusLast Update
0014898MediaMonkey (current)Framework: Scripts/Extensionspublic2018-06-28 15:56
ReporterLudek 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.1.21 
Target Version4.1.21Fixed in Version4.1.21 
Summary0014898: Startup issues with some specific scripts/addons (regression 4.1.21)
DescriptionUser is reporting startup issues with some specific scripts:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=89945#p446720

His set of scripts is:
-Add-Remove PlayStat 1.3.1.116 by Bex
-Advanced Report 6.4 by trixmoto
-Album Art Tagger 5.2 by trixmoto
-Backup 6.0 by trixmoto
-Last.fm Scrobbler 1.0.2.29
-Lyrics and Comment Viewer 2.2 by Gege
-MonkeyRok 6.2 by trixmoto

The one on the lower left is Lyrics and Comment Viewer
The one on the right is MonkeyRok.
TagsNo tags attached.
Fixed in build1872

Relationships

related to 0014820 closedLudek Loading time is 60 seconds when Real time protection is active (Windows Defender) 
related to 0014897 closedLudek "Art browser with Details" visibility isn't restored after restart (sometimes) 

Activities

Ludek

2018-06-25 10:43

developer   ~0050615

Last edited: 2018-06-25 10:59

View 4 revisions

I've tried to install the same set of scripts as the user and based on my testing the startup time of 1864 and 1871 is nearly the same, BUT:

with 1864:
- splash screen is shown (2 seconds)
- nothing is shown (from 2 seconds) - scripts are loading silently
- main window is shown with loaded scripts and panels
Overall time: 4 - 5 seconds

with 1871:
- splash screen is shown (2 seconds)
- main window is shown immediately and scripts are loading for 2 seconds with progress like this:
https://www.dropbox.com/s/7equefkm2u4rmw1/Screenshot%202018-06-25%2012.33.38.png?dl=0
i.e. the panels for "Lyrics and Comment" and "Monkey Rok" are blank until scripts are loaded (2 seconds)
Overall time: 4 - 5 seconds

i.e. the only change is that loading of the scripts is visible which was intention because of issue 0014820 where some scripts (like RegExp Find & Replace) took 60 seconds to load after recent Windows 10 update (and users were not aware what is happening).

Asked further info here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=89945&p=446788#p446788

Ludek

2018-06-25 20:25

developer   ~0050624

Optimized in 1872.

1) there were some actions (related to system tray) that could take some time and were performed before scripts loading, previously (in 4.1.20) they were performed after the scripts loading
2) I've made UI loading more fluent whenever there is a lot of scripts with long loading times

Ludek

2018-06-28 11:21

developer   ~0050651

Confirmed by user here http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=89945&e=1&view=unread#p446916 (I've suplied testing EXE to him)

peke

2018-06-28 15:56

developer   ~0050656

Verified 1872