View Issue Details

IDProjectCategoryView StatusLast Update
0014870MediaMonkey (current)DLNA/UPnPpublic2018-06-28 12:27
Reporterzvezdan 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0014870: "Error: UPnP.dll is not compatible with this version of MediMonkey! Reinstall MediaMonkey."
DescriptionHere is the thing that is something specific to me. I have MediaMonkey folder with a bunch of MediaMonkey-xxxx.exe files, where xxxx is a build number of that file. Whenever I want to install the new version of the program, I append the build number of the current one to the MediaMonkey.exe file. In that way, if I find something strange with the latest version of the program, most specifically in combination with my scripts, I could always try starting some older exe file to see if it had the same strange thing, without a need to reinstall that old version again as Portable. I could have each complete build in separate folder as portable installation, but that would be wasting of hard disk space, especially because I keep MM inside the virtual machine, so it is much efficient to me to keep only old exe files. In fact, I have the another MM folder with multiple exe files with different builds of MM3 which didn't have the portable mode.

Now, the problem is that I get the message mentioned in the Subject whenever I start the exe file of some old build, and also periodically every 10 seconds when the window is refreshing, e.g. after switching program or when the mouse is hovering above the main filelist. For example, I have installed 1868 and I get the mentioned error when I start MediaMonkey-1737.exe.

I cannot remember when that started, with which build, but it didn't happen before. I think it worked fine until 1737 which is the latest exe that I have before 1867. The MediaMonkey-1867.exe starts fine without error with installed 1868.

You know, I am not using UPnP.dll at all, I have turned off Media Sharing.
TagsNo tags attached.
Fixed in build

Activities

Ludek

2018-06-28 12:27

developer   ~0050652

What's strange about the fact that the interface between UPnP.dll and MM.exe was updated? If you don't want to see the message at all then just remove UPnP.dll entirelly or copy the UPnP.dll corresponding to the given MediaMonkey.exe (i.e. UPnP.dll from the same build as MediaMonkey.exe)