View Issue Details

IDProjectCategoryView StatusLast Update
0014823MediaMonkey 5Playbackpublic2018-10-19 02:06
Reporterrusty 
PriorityimmediateSeveritycrashReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014823: Crash on rating playing tracks
DescriptionI'm not sure of the exact cause of this crash since the dialog seemed to indicate it was related to the visualizer, but it happened as follows:
1 Played tracklist
2 Rated playing track
3 Double-Clicked the next track in the tracklist
--> Crash

Debug log: F5EE579D
TagsNo tags attached.
Fixed in build2129

Relationships

related to 0014751 closedmichal Switching from Chromecast playback to Internal player --> crash 
related to 0015158 closedmichal Rating (tagging) the currently playing track while podcasts are downloading --> audio playbock repeats 

Activities

Ludek

2018-05-14 18:27

developer   ~0050295

I am still not getting ELFs after the server updates.
Petr, please attach the ELF to this issue.

Thx.

petr

2018-05-14 18:47

developer  

BugReport_F5EE579D_5.0.0.2104.elp (79,174 bytes)

Ludek

2018-05-14 19:09

developer   ~0050296

Last edited: 2018-05-14 19:13

View 2 revisions

This is again freeze on InPlugLock critical section.

Freeze is in in_mfaudio.dll when stopping (same symptoms as in 0014751).

512.797s - PID:10532 - MM5 [5992](R) Going to stop playback in dll:_D:\PortableApps\MediaMonkey 5\Plugins\in_mfaudio.dll
...
514.812s - PID:10532 - in_mfaudio:_Failed to stop decode thread, killing it
and at 522 seconds the ELF was raised with assertion "We haven't got Lock for 3 seconds"

Assigned to Michal (author of in_mfaudio.dll)

michal

2018-05-24 12:46

developer   ~0050353

Last edited: 2018-05-24 12:46

View 2 revisions

I've made some code adjustments and added debug messages to build 2106. Please retest it, I cannot reproduce it at all.

peke

2018-05-25 12:22

developer   ~0050363

Verified 2106 I can't reproduce either

rusty

2018-10-12 16:03

administrator   ~0051323

I've replicated this issue in build 1227 by:
- rating a track in NP
- double-clicking an earlier track in NP
- double-clicking a second track in NP
--> MediaMonkey freezes (must be force-terminated)

Debug log attached.

rusty

2018-10-12 16:03

administrator  

bug_14823.7z (62,397 bytes)

michal

2018-10-18 18:07

developer   ~0051374

Fixed in build 2129.

peke

2018-10-19 02:06

developer   ~0051380

Verified 2129