View Issue Details

IDProjectCategoryView StatusLast Update
0014761MediaMonkey 5Syncpublic2020-10-25 13:29
ReporterLudek Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014761: Cloud tracks (not downloaded) cannot be Wi-Fi synced to MMA
DescriptionCloud tracks (that are not downloaded) cannot be directly synced to another device/target. One needs download them at first to be able to sync them.
TagsNo tags attached.
Fixed in build2243

Relationships

related to 0016471 feedbackrusty MediaMonkey for Android Wi-Fi Sync: Playlists fail to update correctly when select by 'Random (refresh all)' is used 

Activities

Ludek

2018-04-24 12:28

developer   ~0050086

Fixed in 2102

Ludek

2020-04-06 09:06

developer   ~0057492

Last edited: 2020-04-06 09:16

View 6 revisions

Re-opened, while it works for USB sync, could sync and MMS sync (already implemented in 2102).

It does not work for Wi-Fi sync.
On the other hand Wi-Fi sync is used only with MMA -- and in MMA one would expect that he can connect to the cloud location directly (and thus stream the tracks directly from cloud) instead of getting the cached version from MM5.
But for consistency with USB sync (and because MMA does not support cloud access natively yet) it should be probably implemented.

Ludek

2020-04-16 21:53

developer   ~0057610

Last edited: 2020-04-16 21:54

View 2 revisions

Implemented in 2241 for Wi-Fi sync too

TODO: Downloaded tracks are not auto-converted before copying to the device

rusty

2020-04-19 03:20

administrator   ~0057644

Raised the priority of this issue since it breaks synchronization with an endless 'waiting for file to convert' message for tracks stored to the network if auto-conversion is enabled (tested in build 2242).

Ludek

2020-04-19 11:36

developer   ~0057646

Last edited: 2020-04-19 11:36

View 2 revisions

I cannot replicate, please geneate debug log.

rusty

2020-04-19 18:38

administrator  

Ludek

2020-04-20 10:22

developer   ~0057656

Last edited: 2020-04-20 10:42

View 4 revisions

In the log I see that the downloading of the cloud track was initiated:
TSyncProcess.PrepareCloudTrack: 50 Ways to Leave Your lover, {"id":"1zC4NxijUmfNz5bCeCtILszCjx_dYQHa2","path":"/Music/Paul Simon/Still Crazy After All These Years/04 Paul Simon - 50 Ways to Leave Your lover.mp3","sourceType":"cloud","service_id":"googleDrive","device_id":662}

... but the actual downloading of the track never finished and thus MMA was still waiting for the file.
Note that MMA is saying "Waiting for file to convert.... 50 Ways to Leave Your lover (downloading)"
I cannot change the MMA's text "Waiting for file to convert.... " so I added at least the "(downloading)" appendix after the track title.

To be found why the download has stucked and not failed (or succeeded) gracefully, but reviewing the code it looks that it was a Google Drive "deadlink".
Seeing that for Google Drive "deadlink" it could really stuck, I am going to fix and add more debug info for the future.
EDIT: Reviewing the log more carefully and seeing that the corresponding cloud sync target profile for "Google Drive" actually no longer exists.
To be handled properly...

Ludek

2020-04-20 13:07

developer   ~0057658

Last edited: 2020-04-21 10:25

View 3 revisions

Fixed the possible stuck when cloud track is not accessible to download in build 2243.

TODO: Downloaded tracks are not auto-converted before copying to the device

EDIT: Reverted for Wi-Fi sync entirelly -- as I have found further issues that I am solving...

Ludek

2020-04-21 14:56

developer   ~0057667

Fixed in 2243.

Files are properly converted (when needed) after the downloading for all kinds of sync (USB, Wi-Fi, cloud).
The download stuck observed by Rusty is also fixed.

peke

2020-04-30 20:28

developer   ~0057805

Verified 2245

Unable to reproduce, tested with USB, Wi-Fi, cloud.

peke

2020-08-29 23:43

developer   ~0059544

Reminder sent to: rusty

Re verified 2265

Can you please confirm file downloading not stuck like you describe and close the bug?

peke

2020-10-25 13:29

developer   ~0059980

Revised in 2271

Closing, have not found any additional reports.

When/If YTM is implemented we can open new bug, as current cloud services works.