View Issue Details

IDProjectCategoryView StatusLast Update
0014683MediaMonkey 5Generalpublic2020-10-25 13:38
Reporterjiri Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version5.0 
Summary0014683: Performance problems of A+T view
Description1. this.itemHeightReset in groupsRecompute() is called way too often, not only e.g. during splitter resize of NP sidebar, but also even during mouse move events!

2. renderGroupHeader is very slow, mainly because of hotlinkHandler, which is called repeatedly e.g. during splitter resize of the views.

3. Haven't studied in details, but there seems to be listeners lost (they increase in the Performance monitoring and never really return back).
TagsNo tags attached.
Fixed in build2094

Activities

petr

2018-03-20 20:00

developer   ~0049771

Fixed

peke

2018-03-21 02:55

developer   ~0049774

Verified 2093

jiri

2018-03-21 14:52

administrator   ~0049784

Last edited: 2018-03-21 15:18

View 2 revisions

3. This still seems to be an issue - while scrolling in A+T view, the listeners counts goes continuously up (app.debug.getListenersCount()).

4. There's now a refresh problem after resizing A+T view -- only the content of the first two columns is properly updated.

petr

2018-03-21 21:49

developer   ~0049787

Items 3&4 fixed

peke

2020-08-18 03:25

developer   ~0059435

Reminder sent to: jiri, petr

Verified Performance in 2264

I do not see any issues or any new regressions

Can you please do a brief check in code and close?

peke

2020-10-25 13:38

developer   ~0059984

Revised 2271

No additional issues reported. Considered this fully fixed and new bugs should be opened as they would not be related to original fix.