View Issue Details

IDProjectCategoryView StatusLast Update
0014497MediaMonkey 5Generalpublic2021-02-25 22:06
Reporterjiri Assigned To 
PriorityurgentSeverityminorReproducibilityN/A
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014497: Dialogs open in incorrect positions
DescriptionDialogs are currently often shown in the top left screen corner. I think that it'd be preferable to:

1. Save position and size of the main window (already works fine).
2. Save size of resizable dialogs.
3. Do _not_ save position of other dialogs and instead show them centered within the parent dialog (i.e. that dialog that initiated their appearance on screen).
TagsNo tags attached.
Fixed in build2242

Relationships

related to 0005442 closedjiri MediaMonkey (current) Better Multi-Monitor handling engine. 
related to 0016910 feedbackpetr MediaMonkey 5 File menu opened on wrong monitor 
related to 0017606 feedbackpetr MediaMonkey 5 Auto Tag dialog: Auto Tag dialog do not remember Screen position on reopen (Regression) 

Activities

petr

2017-11-16 22:45

developer   ~0049197

Fixed

peke

2017-11-23 00:48

developer   ~0049228

Verified 2083

rusty

2019-10-25 20:41

administrator   ~0055120

Last edited: 2019-10-25 20:41

View 3 revisions

Re-opening re. point 3 (based on a report by Lowlander):
1 Open MM to fill the entire screen 2560x1080 (configured as 2 virtual monitors)
2 Press INS
-->Scan dialog appears in upper left corner
3 Move scan dialog to the center of the screen and initiate scan
4 Press INS
--> Scan dialog opens in center of the screen
5 Resize MM to fit in the left virtual monitor 1280x1080
6 Press INS
--> Scan dialog opens in the right side of the dialog (i.e. in the center of the screen)!!

In other words, it seems as if MM is saving the absolute position of the dialog, rather than the relative position of the dialog (or rather than just showing it in the center of the application window).

peke

2019-10-25 23:30

developer   ~0055123

relative position can be easily read with sources I uploaded on FTP for a bug 0005442 at that time it was rarely used, while today Multi Monitor Environment is more common and those sources can handle/Control dialogs on any monitor.

rusty

2020-01-22 15:25

administrator   ~0056109

The problem occurs even when virtual monitors aren't used. The issue isn't that the window isn't opening up in the wrong monitor--it's that any MM Window doesn't open in a position relative to the MM Window. e.g.
1 Open MM on the left side of the screen
2 Open settings dialog --> it opens on the left side of the screen
3 Move MM to the right side of the screen
4 Open settings dialog --> it opens on the _left_ side of the screen!!

jiri

2020-01-23 07:55

administrator   ~0056156

Per IM with Petr, we'll only store dialog sizes and show them centered in the main window.

petr

2020-01-23 14:31

developer   ~0056170

Fixed

peke

2020-01-26 01:50

developer   ~0056228

Verified 2223

Dialog I tested show centered and sizes are persistent

rusty

2020-01-31 14:21

administrator   ~0056424

Last edited: 2020-01-31 14:33

View 4 revisions

Re-opening since the current implementation results in another problem: dialogs sometimes open with the Title bar offscreen! This makes it difficult to be able to reposition it or to see the top portion of the dialog (the only workaround I've found is to pull the dialog further open to the bottom of the screen to cause the dialog to 'snap' to the screen size).

I'm able to replicate this by:
1 Open MM in top half of the screen
2 Move MM window to bottom-half of screen
3 Select a track and Auto-tag
--> Auto-tag dialog appears (centered roughly over MM)
4 Expand the auto-tag dialog so that all tracks are viewable (i.e. pull up the Title-bar so that it fills the entire screen)
5 Close auto-tag
6 Move MM window to the top-half of the screen
7 Select and track and Auto-tag
--> Auto-tag dialog appears with the title-bar and header bar offscreen

This might make it easier to understand:
https://www.screencast.com/t/U96ZBhqtqz

petr

2020-01-31 19:52

developer   ~0056452

Fixed

rusty

2020-01-31 20:50

administrator   ~0056457

Verified 2225.

rusty

2020-03-29 23:19

administrator   ~0057406

I just noticed in build 2237, that dialogs will often open off-center and then be redrawn at center. e.g.

0 Open MM in the upper left quadrant (not full screen)
1 Go to Music > Files to Edit > Duplicate Titles [List]
2 Select a duplicate track and press Delete
--> the delete dialog appears to the lower right of the Window and then is redrawn in the center of the window

petr

2020-04-15 10:36

developer   ~0057603

Fixed

rusty

2020-04-17 18:15

administrator   ~0057620

Tested 2241. The issue raised at 0014497:0057406 is resolved, however, I just noticed another problem: some dialogs appear partially offscreen:
1 Move MM to the right half of the screen
2 Right click in the Preview Window and 'Lookup image..'
3 Resize the dialog so that it takes up more of the vertical space (in order to see more images). Choose an image and accept it.
4 Move MM to the upper left quadrant
5 Right click in the Preview Window and 'Lookup image..'
-->the dialog appears with the top half offscreen (and it's impossible to drag it down since the title bar is offscreen)! (this is the same issue as previously raised at 0014497:0056424 )

petr

2020-04-17 20:41

developer   ~0057629

Fixed

rusty

2020-04-19 01:22

administrator   ~0057640

Verified 2242.