View Issue Details

IDProjectCategoryView StatusLast Update
0014240MediaMonkey 5Hotkeyspublic2019-06-19 13:13
ReporterLudek 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0014240: Win 10' MediaTransferControls interface is supplying hotkeys (media keys)
DescriptionUser is reporting double execution of media key actions.
It is caused by introducing the MediaTransferControls interface message processing.

Workaround is to remove MediaMonkeyMT.dll
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=87712&p=436124#p436111
TagsNo tags attached.
Fixed in build2066

Relationships

related to 0015707 closedLudek Hotkeys: HID Hotkeys usually Sends two values 

Activities

petr

2017-05-23 19:29

developer   ~0048017

Windows is sending click event even when user use media keys on keyboard.

Ludek

2017-05-23 20:57

developer   ~0048020

Last edited: 2017-05-23 20:57

View 2 revisions

As discussed offline, solution should be to supress media hotkeys once MT is installed (to prevent from double-execution).

i.e. MT would be preferred also for the reasons described by user at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=87712&p=436124#p436125 where e.g. some games seems to steal standard hotkey messages.

petr

2017-05-23 21:16

developer   ~0048021

Fixed

peke

2017-06-21 01:45

developer   ~0048193

Verified 2068