View Issue Details

IDProjectCategoryView StatusLast Update
0014218MediaMonkey 4DLNA/UPnPpublic2022-11-29 16:43
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1.16Fixed in Version4.1.16 
Summary0014218: Some users cannot install/start MM as service until they edit Local Policy settings
DescriptionPer feedback here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74920&start=15#p416949

Some users gets "The service did not start due to a logon failure"

Solution for them is to add user to group "Log on as service" via local policies per https://support.microsoft.com/en-gb/kb/327545

We should try to either to this automatically (if possible) and/or add [Help] button link on the log-on failure dialog to point users how to solve this.
TagsNo tags attached.
Fixed in build1835

Relationships

related to 0011368 closedLudek MediaMonkey 4 Service Log on failures are not reported when installing service 
related to 0014219 closedLudek MediaMonkey 5 [Install as service] not possible in MM5 
related to 0019590 feedbacklowlander MediaMonkey 5 Service install fail with "error 1069: service fail to start due to login failure" 

Activities

Ludek

2017-05-09 12:11

developer   ~0047934

Last edited: 2017-05-09 12:21

Seems that changing the group policies automatically (e.g. using a command line tool) is a little bit hack and would require a third party utility like PowerShell ( https://technet.microsoft.com/en-us/library/dd759177.aspx?f=255&MSPPError=-2147217396 ) or LGPO ( https://blogs.technet.microsoft.com/secguide/2016/01/21/lgpo-exe-local-group-policy-object-utility-v1-0/ )

Another way would be to edit the corresponding values directly in registry which is also quite tricky and wouldn't work in all cases anyway.
e.g. I suppose that in "Home" edition of Windows it would behave differently as there is no gpedit (Group Policy Editor), although there are some workarounds how to enable it: http://www.askvg.com/how-to-enable-group-policy-editor-gpedit-msc-in-windows-7-home-premium-home-basic-and-starter-editions/

---------
So for now (with above in mind) I would just add the [Help] button linking to https://support.microsoft.com/kb/327545

Ludek

2017-05-09 12:54

developer   ~0047935

Fixed in 4.1.16.1835

peke

2017-05-12 15:04

developer   ~0047970

Verified 1835