View Issue Details

IDProjectCategoryView StatusLast Update
0013864MediaMonkey 4Synchronizationpublic2020-05-19 08:16
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1.15Fixed in Version4.1.15 
Summary0013864: Users often don't realize that iTunes needs to be installed for the iOS device sync to work
DescriptionCurrently if user plug-in iPhone or iPad and iTunes isn't installed then MediaMonkey cannot sync such a device, but user won't realize it.

There should be a prompt to install iTunes upon device connection.

Additional Informationhttp://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/139/0/ios--iphone--ipod-compatibility-with-mediamonkey

IGB-283-46258
TagsNo tags attached.
Fixed in build1824

Relationships

related to 0011490 feedbackrusty MediaMonkey 4 Documentation for MMW 4.1 and MMA 
related to 0014145 closedLudek MediaMonkey 4 Non iOS iPod detected as requiring iTunes to be installed 
related to 0016609 newLudek MediaMonkey 5 Sync: Ability to detect what version of iTunes is installed and if it is started 

Activities

Ludek

2017-01-04 13:01

developer   ~0046831

Last edited: 2017-01-04 13:02

View 3 revisions

To be found how to detect Apple devices when "Apple Device Support" is uninstalled.

IWMDeviceManager2::EnumDevices2 doesn't enumerate it as MTP portable device although apparently for the user from IGB-283-46258 it enumerated it (on the same Windows 7 OS).
But the device is visible in Windows Explorer as "Apple iPod" portable device (unsyncable) so there probably should be a way.

Ludek

2017-01-07 16:20

developer   ~0046874

Last edited: 2017-01-12 18:54

View 5 revisions

Resolved in 4.1.15.1824 / 5.0.0.2058 this way:
If iPhone/iPod is connected once MediaMonkey is already running (and 'Apple Mobile Device Support' was not detected) then this message is shown:

'The iPhone/iPod device connection was detected. Please install iTunes to be able to sync this device using MediaMonkey.'

[OK][Help]

The help link goes to http://www.mediamonkey.com/devicesync

Assigned to Rusty to:
a) review wording of the message
b) Update the KB article to include iOS 10 support (from version 4.1.15).

rusty

2017-01-12 19:51

administrator   ~0046923

Suggestion for updated text:

"An iPhone/iPod/iPad connection was detected. Please install iTunes in order to sync this device with MediaMonkey.
[OK] [Help]".

Also, the KB article has been updated.

Ludek

2017-01-12 20:03

developer   ~0046925

The text updated in 1824.

peke

2017-01-15 05:41

developer   ~0046937

Verified 1824