View Issue Details

IDProjectCategoryView StatusLast Update
0013682MediaMonkey 4Framework: Taggingpublic2016-12-16 23:16
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.1.15 
Target Version4.1.15Fixed in Version4.1.15 
Summary0013682: Crash during FLAC tagging
DescriptionI see many crash reports from LL related to FLAC tagging (one attached).

TagsNo tags attached.
Fixed in build1818

Activities

Ludek

2016-11-25 11:17

developer  

MediaMonkey.elf (300,276 bytes)

Ludek

2016-11-25 11:18

developer   ~0046255

Last edited: 2016-11-25 11:22

View 2 revisions

Based on the log the
\\lowlander03\Multimedia\Temp\Music\Rip\Heart\Beautiful Broren\06. Heart - Track06.flac
was writing tag while
\\lowlander03\Multimedia\Temp\Music\Rip\Various Artists\The Magic Of Christmas\16. Luciano Pavarotti - Mille Cherubini In Coro.flac
was reading tag at the same time.

LL, is it always reproducible on the file
\\lowlander03\Multimedia\Temp\Music\Rip\Heart\Beautiful Broren\06. Heart - Track06.flac
?

If yes, please upload the file on FTP and assign to Michal then.

peke

2016-11-25 15:43

developer   ~0046262

I'm unable to reproduce.

lowlander

2016-11-26 02:25

developer   ~0046270

No, the track tags just fine.

I think the trigger is that somehow MediaMonkey hangs and an AV is triggered. From then on in the same session there will be regular AVs on tagging.

The problem may be that too many things are happening at the same time like Lyrics lookup (seems to regularly hang MM a bit) and tagging. Other things that may be happening are Podcast updates/downloads, volume analyzing and auto-organizing files (manual triggered).

I don't think AutoPlaylists come into play here (no sync, nor using them myself) so it seems to boil down to long locks/too many simultaneous DB operation on the DB causing an AV at which point MediaMonkey becomes unstable (generally also failing to save Now Playing on exit and not closing from Task Manager).

Ludek

2016-11-28 10:13

developer   ~0046280

But based on the other ELFs in a row the crash seems to be rather when closing song properties dialog.

In TFSongProperties.Destroy on row
ThreadsManager.InvalidateCallBack( PreviewThreadNotify);

Ludek

2016-11-28 11:08

developer   ~0046281

I fixed the crash on closing Song Properties, but it was just a consequence of something else underneath.

Assigned to Michal to review the FLAC tagging code.
If he isn't going to see something bad then we can probably resolve (until we have more info).

michal

2016-11-28 14:12

developer   ~0046289

Resolving. It does not seem to be issue in FLAC plugin. Added more debug messages during tagging, in case the problem occurs again.

peke

2016-12-16 23:16

developer   ~0046584

Verified 1819