View Issue Details

IDProjectCategoryView StatusLast Update
0013578MediaMonkey 4Virtual CD cache / Previewpublic2017-03-16 14:55
Reporterlowlander Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.14 
Target Version4.1.15Fixed in Version4.1.15 
Summary0013578: Previews are not created (regression)
DescriptionUsing either Tools > Previews or Edit > Properties > Virtual CD doesn't create the actual Preview file. The folder structure is created though and MM show progress for creating the Virtual CD.

No error message or AV.
Additional InformationMJO-303-79841
TagsNo tags attached.
Fixed in build1830

Activities

rusty

2016-10-06 22:07

administrator   ~0045850

Last edited: 2016-10-06 22:08

View 2 revisions

I'd be tempted to remove the functionality altogether if it's easier than fixing it. I don't think that it's a very commonly used feature.

Ludek

2016-11-15 16:51

developer   ~0046170

Last edited: 2016-11-15 16:52

View 2 revisions

The functionality has been already removed from MM5

Re MM4 status:
Previews can be WMA only and because of the recent WMA encoding issues (after Win10 Anniversary update) it would probably makes sense to remove it from MM4 too.

Currently it fails (also on Win7) in EncodeWMAFile, last lines in debug log:
[1576] EncodeWMAFile - calling WMAWriteStreamInit
[1576] Calling iWMAWriteStreamInit

michal

2016-11-15 16:58

developer   ~0046171

Really also in Win7 with old WMCore libraries? This error in WMAWriteStreamInit (exactly in calling WMCreateWriter) was introduced in Win10 Anniversary update.

Ludek

2016-11-15 17:34

developer   ~0046172

Last edited: 2016-11-15 17:35

View 2 revisions

It was caused by some parameters in MediaMonkey.ini.

Once I modified the preview WMA format then it started to work and works also in the default config. I do not have backup of the old MediaMonkey.ini so I cannot replicate anymore (to see which params were bad for the encoder).