View Issue Details

IDProjectCategoryView StatusLast Update
0012721MediaMonkey for Android[All Projects] Generalpublic2020-04-06 17:22
Reporterrusty 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version1.3.1 
Summary0012721: Failed conversion error appears when it shouldn't
DescriptionIf the user attempts to sync tracks that exist in the DB but as 'dead links' (i.e. the file has been removed), then syncing the tracks normally fails silently.

But if the tracks match an auto-conversion rule, then an error appears that auto-conversion failed!

I'm not sure if this is an MMA or MMW bug.
TagsNo tags attached.
Fixed in build744

Relationships

related to 0014594 closedLudek MediaMonkey (current) Wi-Fi sync fails in some cases (related to temporal network dead links) 
related to 0015247 closedmichal MediaMonkey 5 'Failed conversion' for some tracks during sync 
related to 0016471 feedbackrusty MediaMonkey for Android Wi-Fi Sync: Playlists fail to update correctly when select by 'Random (refresh all)' is used 

Activities

Ludek

2015-05-17 14:45

developer   ~0042545

Last edited: 2015-05-17 14:48

View 3 revisions

It is not true that for 'dead links' it fails silently, MMA reports "unable to download" for such a tracks.

Fixed in 4.1.8.1745, it reports the same for 'dead links' matching an auto-conversion rule

Ludek

2015-06-03 20:01

developer   ~0042589

Re-opened, this caused a regression:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=81086

Ludek

2015-06-03 21:51

developer   ~0042591

Fixed in 4.1.8.1746

Ludek

2015-06-05 08:28

developer   ~0042599

Confirmed: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=81086

peke

2015-06-05 12:38

developer   ~0042601

Verified 1746 and 1747

Ludek

2017-12-18 22:38

developer   ~0049431

Last edited: 2017-12-18 22:39

View 2 revisions

The fix needed to be adjusted on MMA side due to 0014594
Details here: 0014594:0049430

Fixed by Marek in 1.3.1.745

rusty

2017-12-20 07:21

administrator   ~0049446

Edited to fixed in 744 (instead of 745).

peke

2017-12-20 08:30

developer   ~0049447

Verified 744 using both 4.1.19 and 4.1.20.1860