View Issue Details

IDProjectCategoryView StatusLast Update
0012200MediaMonkey for AndroidTrack Browserpublic2020-02-25 12:09
Reportermarek 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.7 
Target Version2.0.0Fixed in Version2.0.0 
Summary0012200: Visibility of classical music tracks
DescriptionI do not know how exactly classical music type should be implemented now but I see there some inconsistence. I thought that classical music should be visible in all views and classical music view is special because only classical music is there.

There is one user that pointed out that he is not able to play classical music by genres http://www.mediamonkey.com/support/staff/index.php?/Tickets/Ticket/View/25577

Now classical music is visible only in composer view and it is not visible in artists, albums, tracks and genres. This is probably not correct.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=79002
TagsNo tags attached.
Fixed in build1005

Relationships

related to 0009580 feedbackrusty Main menu: improved navigation 
related to 0012002 resolvedrusty Classical Music views are overly limited 
related to 0012899 closedmartin Album Grid view: scroll bar doesn't work when Unknown album exists 
related to 0011339 resolvedmartin Support for other content to appear in 'Classical' / Post playlists to home screen 

Activities

martin

2014-09-28 11:45

developer   ~0040631

So, what is correct solution, should be classical music tracks visible from other views or should be visible only from Classical music node?

rusty

2014-10-01 22:30

administrator   ~0040671

So the rationale for the Classical Music view is that unlike other genres, users prefer to view Classical music by Composer rather than by Artist. In other words, if we didn't have a 'Classical' view, then there wouldn't be a means of viewing classical music by composer.

Unfortunately, the current view has the limitation that:
- Genres other than 'Classical' cannot appear within it ( 0011339 )
- There no means of browsing by Artist/Album Artist (or other attributes)

A short term workaround would be to allow 'Classical' music to appear within regular Music nodes (Albums, Artists, Tracks, Composers, Genres). But that's really a recognition that the current approach is too limited.

This workaround could be made into a long term fix if we figure out a means of filtering _any_ genre by either Artist or Composer (i.e. negate the original reason for creating the 'Classical' node.

Another long term fix would be to treat classical music as a top level node in 0009580 . i.e.
Music
- Genres
- Albums
- Artists
- Composers
- etc....

Classical Music
- Genres
- Albums
- Artists
- Composers
- Ratings
- etc...

However, it's not clear that this second approach is ideal either, because there needs to be a means of adding Genres such as 'Symphony' to the Classical view (which Jiri suggested at 0011339 as not ideal in a CPU/memory constrained device).

Ideas?

marek

2014-10-03 14:55

developer   ~0040693

Hi, first of all, I have added new UI as #12215

In this design I count with Classical music as separate node. Excatly the same way how in MMW.

I don't think that there will be any issues with genres as "Symphony" because there will be genres of Classical music.

In the meanwhile, I think that we can add the approach when classical music is shown in music nodes too. But it will be probably better to implement to 1.1 because whole these library fragments were reworked and when we implement it to 1.0.7, we have to do it twice.

rusty

2014-10-03 15:27

administrator   ~0040696

OK. So let's defer and resolve this as part of #12215

rusty

2015-03-12 22:18

administrator   ~0042287

Last edited: 2015-03-12 23:11

View 3 revisions

Note: Part of the problem is that the Classical node in MMA doesn't contain all content of Type=Classical. The way it seems to work is that if in MMW, genre contains 'classical' then the track appears within the Classical node in MMA. e.g. for tracks Wi-Fi Synced from MMW with:
Type=Classical, Genre=Symphony: not in classical
Type=Classical, Genre=Classical Jazz: in classical
Type=Classical, Genre=Classical;Instrumental: in classical

So whatever solution we eventually implement should probably account for this.

Note: an alternative approach would be to have a browser that facilitates browsing by multiple genres. e.g. if the user chooses classical, then allow them to subsequently browse by any other attribute. Can be discussed in the future...

e.g. log: #6Q1FPYE4SU
Crouching Tiger Hidden Dragon Type=Classical, Genre=Symphony doesn't appear in Classical node.

marek

2015-03-13 13:59

developer   ~0042289

Are you sure that the type is Classical? Probably MMW sets incorrect type. In following XML upnp:MM_TrackType is 0 and should be 3 for Classical type

<item id="0DeviceID=0499a310.0.d6a0e1af-3506-476f-9fc5-df65d717cfa5_ItemID=3058.mp3" parentID="0" restricted="1">
    <dc:title>Crouching Tiger, Hidden Dragon
    </dc:title>
    <dc:creator>Coco Lee & Yo-Yo Ma
    </dc:creator>
    <dc:date>2000
    </dc:date>
    <upnp:artist role="Performer">Coco Lee & Yo-Yo Ma
    </upnp:artist>
    <upnp:artist role="AlbumArtist">Coco Lee & Yo-Yo Ma
    </upnp:artist>
    <upnp:album>Crouching Tiger, Hidden Dragon Soundtrack
    </upnp:album>
    <upnp:genre>Symphony
    </upnp:genre>
    <upnp:albumArtURI dlna:profileID="JPEG_TN">http://192.168.0.211:62514/666.jpg
    </upnp:albumArtURI>
    <upnp:originalTrackNumber>2
    </upnp:originalTrackNumber>
    <upnp:rating>60
    </upnp:rating>
    <upnp:MM_TargetPath>\Music\Coco Lee & Yo-Yo Ma\Crouching Tiger, Hidden Dragon Soundtrack\02 Coco Lee & Yo-Yo Ma - Crouching Tiger, Hidden Dragon.mp3
    </upnp:MM_TargetPath>
    <upnp:MM_LastModified>2014-01-03 06:28:35
    </upnp:MM_LastModified>
    <upnp:MM_LastTimePlayed>1899-12-30 00:00:00
    </upnp:MM_LastTimePlayed>
    <upnp:MM_VolumeLeveling>0.0199999995529652
    </upnp:MM_VolumeLeveling>
    <upnp:MM_TrackGain>0.419999986886978
    </upnp:MM_TrackGain>
    <upnp:MM_AlbumGain>0.0199999995529652
    </upnp:MM_AlbumGain>
    <upnp:MM_ItemID>3058
    </upnp:MM_ItemID>
    <upnp:MM_TrackType>0
    </upnp:MM_TrackType>
    <res duration="0:03:24.000" size="3291136" bitrate="128000" sampleFrequency="44100" nrAudioChannels="2" protocolInfo="http-get:*:audio/mpeg:DLNA.ORG_PN=MP3;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000">http://192.168.0.211:62514/DeviceID=0499a310.0.d6a0e1af-3506-476f-9fc5-df65d717cfa5_ItemID=3058.mp3
    </res>
    <upnp:class>object.item.audioItem.musicTrack
    </upnp:class>
  </item>

rusty

2015-09-22 18:33

administrator   ~0042965

Last edited: 2015-09-22 18:34

View 2 revisions

This can be replicated as described at 0012200:0042287 . Tracks in MMW as Type=Classical but Genre=anything besides Classical do not appear in the 'Classical' node in MMA.

Nonetheless, this will probably have to be deferred.

marek

2015-09-23 10:11

developer   ~0042971

I am not able to replicate it. But as I said, according logs the issue was in MMW because the type was incorrect.

Ludek

2016-01-12 16:46

developer   ~0043837

Last edited: 2016-01-12 16:47

View 3 revisions

I am also unable to replicate, classified a test file genre = 'Symphony', type = 'Classical Music' in MMW, added to a playlist and WiFi synced to MMA
=> track appears correctly in 'Classical music' node in MMA

Rusty, can you re-test whether you are still able to replicate this with latest builds ?

martin

2020-02-25 12:07

developer   ~0056871

Last edited: 2020-02-25 12:09

View 2 revisions

Classical music implemented as a top-level node with own subnodes (tracks, albums, composers, artists, etc.)
WifiSync tested, It's working as expected.
Fixed in build 2.0.0.1005