View Issue Details

IDProjectCategoryView StatusLast Update
0012102MediaMonkey for AndroidGeneralpublic2017-11-29 19:29
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.6 
Target Version1.3.0Fixed in Version1.2.0 
Summary0012102: Compatibility with 'OK Google' Voice Music commands
DescriptionIf the user attempts to play music content via 'OK Google, Play The Beatles', Google Search allows the user to play the content using a choice of Google Music or various installed 3rd Party music apps, but MediaMonkey is not listed among them.

This should be fixed asap considering that OK Google is, as of Android 4.4, a feature that is accessible Globally. See:
http://www.cnet.com/how-to/quick-tip-get-ok-google-everywhere-right-now/
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=69688
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=77348
Tagstodoc
Fixed in build591

Relationships

related to 0012500 closedmartin 'OK Google' doesn't work for tracks that are in Google Music 
related to 0013643 resolvedmartin Provide more nodes via MediaBrowserServiceCompat (re. Android Auto) 
related to 0014570 feedbackrusty Voice commands no longer work for MediaMonkey as a default Music Service Provider 

Activities

rusty

2014-09-24 06:23

administrator   ~0040547

Last edited: 2014-09-24 06:25

View 3 revisions

Apparently this involves supporting intents triggered by the voice recognition service:
http://android-developers.blogspot.ca/2010/09/supporting-new-music-voice-action.html

Wouldn't this be relatively easy to implement?

marek

2014-12-01 12:27

developer   ~0041239

Yes, I will add it asap.

martin

2015-01-13 15:13

developer   ~0041672

Fixed in build 1.1.0.365

martin

2015-01-14 11:00

developer   ~0041684

It responds on commands
"ok google" "listen to" or "ok google" "play" and then you can say:
"artist" "song title"
or just "artist"
or just "song title"

rusty

2015-01-14 20:05

administrator   ~0041694

This is partially working. Issues in build 365 are that:

1) For some Artists, it always opens in Google Play even though MMA has been set as the player. e.g. 'I want to play the lemonheads' --> Google Music opens and a music playback error occurs (since it's a phantom track). It seems that all phantom tracks result in this behavior.

2) Upon opening a playlist (e.g. I want to listen to the Playlist 'Good stuff') --> it is always opened in Google Music, even after setting MediaMonkey as the player for these playlists.

martin

2015-01-14 23:33

developer   ~0041709

Last edited: 2015-01-14 23:34

View 2 revisions

re 1) It seems like android bug, that it always starts in Google Music, or you have some cases that it opens directly in MMA? (I have try to change for some other player like PowerAmp, but next start is again in Google Music)
Does the error occur in Google Music app?

re 2) I don't understand, how you set opening for playlist? Btw. we don't search in playlist names. If you think searching for query "Good stuff" then if MMA launched, it search in artist names and media titles only.

rusty

2015-01-16 05:09

administrator   ~0041734

1) Let's track this at 0012500.

2) 'I want to listen to playlist Good Stuff'
--> Google Music opens the playlist 'Good Stuff' but MMA doesn't open anything (because, as you pointed out, MMA doesn't search for playlist names even when 'Play playlist X' is used.

martin

2015-01-16 12:24

developer   ~0041738

Last edited: 2015-01-16 13:27

View 2 revisions

Added support for playlists.
Fixed in build 1.1.0.369

rusty

2015-01-16 20:07

administrator   ~0041746

2) Tested OK Google with playlists in 369 and can't get it to work correctly:

a) On a Nexus 5 (Kitkat): opening a playlist always opens the playlist in Google Music (expected since kitkat has the same bug for tracks--as described in 0012500 )

b) On a Nexus 7 (Lollipop): opening a playlist always opens the playlist in Google Music! Although Google Voice control is fixed in Lollipop wrt playing audio Tracks in the associated application, the fix doesn't extend to playlists :-( There's probably not much we can do about this.

c) On a Galaxy device (kitkat) in which all content is stored to external storage: opening a playlist fails because playlists (empty ones) are stored to internal storage, and so attempts to play a playlist open the empty playlist in Google Music! This issue may be resolved when 0011630 is fixed.

Leaving this issue as resolved, to test further at a later date (once 0011630 and/or Lollipop voice control is fixed).

rusty

2015-10-07 02:08

administrator   ~0043065

This never worked correctly, but apparently, Google has improved the implementation in android 5.2, so we should fix deficiencies for MMA 1.2
http://arstechnica.com/gadgets/2015/10/android-6-0-marshmallow-thoroughly-reviewed/4/

martin

2016-04-13 17:14

developer   ~0044444

I have improved search processing, according to
https://developer.android.com/intl/ru/guide/components/intents-common.html#PlaySearch

so now you can also search by artist, album, title, artist+title, album+title.

On OS side are still several issues.
I)List of available media players is not provided, Play Music is displayed only in the list for processing voice command.
Found solution:
1)Used "force stop" of this app and then
2)Write command like "play Coldplay", then list of all supported players is available and I can choose "MediaMonkey"

II)
When I tested voice actions
https://developers.google.com/voice-actions/system/#media_actions
(btw you can also just write command, you don't have to speak command)
some of actions doesn't work:
1)play genre e.g play rock -> always just "Play Music" is listed only
2)play xxx on MediaMonkey -> I was thinking that when we also say the name MediaMonkey, then the command will be played in our app always, but normal search is executed instead.
  
III)
I was trying possibilities about VoiceIntegration (on no search result), but it doesn't work for MEDIA_PLAY_FROM_SEARCH yet.
https://code.google.com/p/android/issues/detail?id=191794
  

I think that we can't do more about this currently.
Fixed in build 1.2.0.591

peke

2016-04-28 22:52

developer   ~0044525

verified 593