View Issue Details

IDProjectCategoryView StatusLast Update
0011183MediaMonkey 4Playerpublic2021-04-28 16:30
Reporterrusty Assigned To 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0011183: Video isn't tagged as played if the last 2 minutes aren't watched
DescriptionBased on http://www.ventismedia.com/mantis/view.php?id=2680 , it appears that movies aren't tagged as played (and the last played date isn't saved) unless the entire video has been watched.

As reported at http://www.mediamonkey.com/forum/viewtopic.php?p=372635#p372656 , this causes a problem that when the user doesn't watch the credits, the video is still listed as unplayed.

The proposed solution is to increase the counter and store the last played date/time when 90% of the video has been watched (but not reset the bookmark).
TagsNo tags attached.
Fixed in build1659

Relationships

related to 0010710 closedLudek MediaMonkey 4 OnPlay event is not triggered when 'Back' button returns to the beginning of the currently playing track 
parent of 0004961 closedpetr MediaMonkey 4 'Back' button should return to the beginning of the currently playing track 
parent of 0011286 closedLudek MediaMonkey 4 Advanced search for Played# works only for integer values 
parent of 0014162 closedLudek MediaMonkey 4 Pause still updates Last Played 
related to 0016977 closedLudek MediaMonkey 5 Play status improvements 

Activities

Ludek

2013-08-27 09:46

developer   ~0037292

Fixed in build 1655.

peke

2013-08-28 00:16

developer   ~0037312

I have tested majority using our email talk in 1655, but can you please update exact implementation details.

Also I have found one flaw where for example movie have Two files (Movie cut in two) and I stop watching First one two minutes before end it is flagged as played even I didn't finished it.

Ludek

2013-08-28 10:03

developer   ~0037318

Last edited: 2013-08-28 10:07

View 5 revisions

OK, this issue is still being discussed via emails, the last suggested change was:
Update the 'Last Time Played' for a track/movie after 5 minutes of playing and then once the track/movie is considered as Played, it can make sense for last played to exist, even if playcount < 1.

The reasons discussed (example by Jiri):
I play a long movie, but due to its length stop it in the half and finish it only few days later - when should the timestamp be updated? I'd prefer it being updated _both_ days, since I've seen a significant portion of the movie and it helps resuming the playback later, since I'll see the movie e.g. in 'recently played' playlist.

Examples how it should work once implemented:
a) 4 minutes long track is played => both LTP and Played# are updated at 90% of playback
b) 90 minutes long track/movie is played => LTP is updated after 5 minutes of playback, both LTP and Played# are updated at 90% of playback


Re: your objection when movie have two files (Movie cut in two)
I would say that we cannot do much about this and in fact it is not necessarilly an issue, because we are updating played# per file (not per movie/series).

Ludek

2013-08-29 14:01

developer   ~0037345

Last edited: 2013-08-29 14:02

View 2 revisions

Added updating of LTP after 5 minutes of playback in build 1656.

peke

2013-08-29 21:56

developer   ~0037384

Verified 1656

Ludek

2013-09-16 11:56

developer   ~0037551

Last edited: 2013-09-16 12:33

View 4 revisions

Re-opened to evaluate it again based on feedback here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=73687

We were thinking about improving it slightly to change the condition to
if Bookmark + Current played time in session = 90% , then increase Played#

e.g.
if Bookmark is 0.85 , user skips to 0.92 and let it play => Played# is increased at 0.97

But it still would not solve the case when
Bookmark is 0.65 , user skips to 0.95 and let it finish => Played# is not increased


Therefore the best solution could be to revert it to be consistent with MM 4.0 (increasing on file end), but when user press previous button [<<] to restart bookmark then Played# would be increased if seek bar was > 90% (this would solve the issue when user skips film credits)

jiri

2013-09-16 15:16

administrator   ~0037558

Last edited: 2013-11-11 10:39

View 2 revisions

Sounds good, we probably can't do much more about it. Note that it means, that e.g. if user plays 95% of a video a presses Next or Stop, only a bookmark is saved, but playcount isn't increased. Nevertheless, it's probably the best we can do.

Ludek

2013-09-17 10:49

developer   ~0037573

Last edited: 2013-09-17 15:10

View 3 revisions

Yes, we could probably enhance the advance Played# rule so that user could specify new rule as Played# >= 0.95 , this way it would be up to user how to clasify played tracks (entered as 0011286), but generally Played# = 0.95 is correct when the last 5% hasn't been watched.

Note that we should retain the updating of Last Time Played whenever a movie/track/podcast is watched at least 5 minutes, this still seems to make sense to update LTP even if Played# < 1.

Ludek

2013-09-17 11:49

developer   ~0037574

Last edited: 2013-09-17 11:50

View 2 revisions

Fixed in build 1659.

i.e. the behaviour is very similar to that in MM 4.0 except that

a) Last Time Played is updated after 5 minutes of playback (even if file isn't played fully)
b) Played# is also increased when user pressed [<<] previous button while seek bar was > 90% and the file has been played at least for one minute

peke

2013-09-18 22:19

developer   ~0037600

Last edited: 2013-09-18 22:20

View 2 revisions

@Ludek
I wonder if it would be more consistent to keep b) at 5 min mark like a)?

Verified 1659

Ludek

2013-09-23 10:20

developer   ~0037642

It is consistent with the general condition for increasing Play Counter as has been in MM 4.0
(Time played in session + Bookmark > 1 min.) or (Track Length < 3 min.)