View Issue Details

IDProjectCategoryView StatusLast Update
0006984MediaMonkey (current)Playerpublic2019-11-07 20:19
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.1Fixed in Version4.0 
Summary0006984: Support for Video subtitles
DescriptionSupport for subtitles should be included in the video player.

Types of subtitles: to be specced

UI: need for source selector? language selector?
TagsNo tags attached.
Fixed in build1344

Relationships

related to 0005697 closedmichal MediaMonkey (current) Tagging AVI files 
related to 0006993 resolvedjiri MediaMonkey (current) Support for external video players 
related to 0006998 new MediaMonkey (current) Subtitles: Ability to search/download Subtitles from internet 
related to 0008327 closedmichal MediaMonkey (current) User isn't prompted to install codec pack to display subtitles 

Activities

peke

2010-12-15 01:05

developer   ~0021828

More info in these comments.
http://www.ventismedia.com/mantis/view.php?id=5697#c18691
http://www.ventismedia.com/mantis/view.php?id=5697#c18694
http://www.ventismedia.com/mantis/view.php?id=5697#c18696

Additionally, Like with Auto-Tag from Web MediaMonkey should e capable to download/search subtitles like supported in SPlayer (Shooter Player - http://splayer.org/history.html#introcontainer)** and we can try/contact several sites for that like http://www.addic7ed.com/ , http://www.prijevodi-online.org/serije (Serbian/Croatian only subtitles) or others.

Note: Sample API/SDK (MM MMIP and PHP/MYSQL example) should can be easily made for possible partner sites that wish to support such feature.

** = In case that player starts in Chinese here is help http://www.prijevodi-online.org/smf/index.php?action=dlattach;topic=4538.0;attach=2821;image

jiri

2010-12-15 09:16

administrator   ~0021830

Setting target to 4.1. There's no question that it would be a nice feature, but its proper implementation will take some time and I don't think that it's a good idea to try to include some quick and dirty solution to 4.0.

peke

2010-12-15 14:39

developer   ~0021840

I agree that it deserve time to implement. I'm just worried that users would not be happy.

michal

2010-12-15 19:14

developer   ~0021850

I've tried, and for now, we can use subtitles from ffdshow (for videos decoded by it, it is the majority). Subtitles switching (on/off, choosing subtitle file) will work using ffdshow context menu in systray.

jiri

2010-12-16 14:32

administrator   ~0021865

Last edited: 2010-12-16 15:01

View 2 revisions

Based on discussion with Michal, it could work like this:

1. We will install DirectVobSub (GPL) as a part of our Video Codec Pack.
2. In case our Video Codec Pack isn't installed and DirectVobSub is installed in system, it will be used.
3. In case neither 1&2 works, any attempt to enable subtitles in MM will cause showing of a dialog suggesting user to download our codec pack (any maybe also the alternative of installing DVS only).

4. MM will provide the best matching filename for subtitles, preferably the same filename (just different extension), in case it doesn't exist, it will try to find very similar one (probably having the same letters, just different non-letter characters).
4b. We should find out whether it's possible to get embedded subtitles from MKV files.

UI:
5. Global [x] Play|Subtitles menu item would probably be useful.
6. Right-clicking on Video window should show Subtitles menu item, having subitems:
 [x] Enable
     Size > {shows submenu of Small, Normal, Large, Extra Large}
     Language > {shows submenu items as below}
       Lord Of The Rings-en // Here all similar subtitle filenames are shown
       Lord Of The Rings-se
       Lord Of The Rings-cz
       --------------------
       Select filename // Here user can open _any_ filename using Open File dialog

rusty

2010-12-16 15:06

administrator   ~0021866

Last edited: 2010-12-16 15:19

View 4 revisions

Re. 5, we can probably do without the global pref, and just persist the enable subtitles setting.

Re. 6, so if I understand correctly, on right-click of any video, the following would appear in the context menu:

Subtitles> Open file...
Subtitles> x Enable
Subtitles> x Track 1
Subtitles> . Track 2
Subtitles> Size > (Small, [[x Normal]], Large, Extra Large)

Note: the Size setting should be persisted.

This UI could work for both Subtitle files and embedded subtitle streams in mkv files.

[edited by Rusty]

jiri

2010-12-16 15:10

administrator   ~0021867

Increasing priority, since this implementation is quite simple.

peke

2010-12-16 21:34

developer   ~0021873

Last edited: 2010-12-17 02:43

View 2 revisions

Useful Link for showing subtitles:
http://www.kmplayer.com/forums/showthread.php?t=60

Suggestions
1. I would rather go with FFDShow settings like Michal, than with DirectVobSub as DirectVobSub Have issues on x64 Systems and some apps And from latest versions of K-Lite I think it is off by default

2. Same as above I also think that FFDShow controls of Subtitles can be controlled using FFDShow API calls.

3. Not sure that I understand need for that. Knowledge Base should be enough.

4. I would suggest that we add INI option that in case all fail MM can load all subtitles from folder (*.SRT, *.SUB). Very very useful and often users are complaining why it is not possible to load all from folder and list them in subtitles menu. based on most DivX hardware players and software players accepted filenames are <Movie filename>.<lng code>.SRT or <Movie filename>.<lng code>.SUB

4b. Also DivX6+ support embed subtitles.


Small corrections to comply with standards set by most other apps regarding UI:
5. I would rather have option Player Sheet "[x] Auto-Load Subtitles with video playback" and [Settings] that will open Subtitles Settings Dialog from either FFDShow or our own (Balsamiq Mockups and PNG image uploaded).

6. I would rather have context menu look like this as it is more descriptive
Subtitles> x Enable
Subtitles> Configure (As suggested in 5)
-------------------
Subtitles> . <Language> or <Filename> if loaded manually
Subtitles> . <Language> or <Filename> if loaded manually
Subtitles> Open file...

7. While Video is playing D&D of Subtitle file should load it to current Video

peke

2010-12-17 02:42

developer  

Subtitles Display.zip (46,211 bytes)

michal

2010-12-17 05:54

developer   ~0021891

Last edited: 2010-12-17 06:26

View 2 revisions

peke:
- 1. do you know the issues on x64? I've found only some problems with installation and autoloading, and it has nothing to do with us (we will use it locally and load it manually)
FFDShow subtitles are inspired by VobSub sources.

peke

2010-12-17 12:11

developer   ~0021902

If we will use it locally than I think it is OK. Will subtitles be in Video Frame even on displays there is space below video frame (16:9 shown on 16:10 Monitors). I wonder why we can't use http://ffdshow-tryout.svn.sourceforge.net/viewvc/ffdshow-tryout/trunk/src/ffdshowRemoteAPI.cpp?view=markup

michal

2010-12-17 19:02

developer   ~0021905

peke: because independent filter is more general and thin, can be used even if ffdshow decoder will not be used. But thanks for the hint, the API could be useful in the future.

michal

2011-01-13 08:52

developer   ~0022343

Last edited: 2011-01-13 09:20

View 2 revisions

Working with subtitle files implemented in build 1344 and codec pack 1.07.
Embedded subtitle streams are not supported yet.

Other version of DirectVobSub from system could be used, but it has some issues - it does not support font change during playback, sometimes it could have problems with selecting some subtitle files, we can do nothing about it.

michal

2011-01-15 18:10

developer   ~0022366

Fixed in build 1344, requires codec pack 1.07.

peke

2011-01-20 05:29

developer   ~0022477

Verified 1344 and Codec 1.07