View Issue Details

IDProjectCategoryView StatusLast Update
0005697MediaMonkey (current)Framework: Taggingpublic2011-05-26 13:52
Reporterjiri 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0 
Summary0005697: Tagging AVI files
DescriptionReading and writing AVI files will be needed for video support in MM.
TagsNo tags attached.
Fixed in build1324

Relationships

related to 0006984 closedmichal Support for Video subtitles 

Activities

michal

2009-06-01 15:08

developer   ~0018088

Last edited: 2009-06-02 14:41

Prepared support for the following tags:

Standard RIFF INFO tags:
INAM - Name, title
IART - Artist, Director
ICOP - Copyright
IPRD - Product
ICRD - Creation Date
IGNR - Genre
ISBJ - Subject
IKEY - Keywords
ICMT - Comments
ISFT - Software
ITCH - Technician, Encoded by
IENG - Engineer, Digitized by
IDIT - Digitizing Date
ISMP - SMPTE time code
ISRF - Source Form
IMED - Medium
ISRC - Source
IARL - Archival Location
ICMS - Commissioned by
ICRP - Cropped
ISHP - Sharpness
IDIM - Dimensions
ILGT - Lightness
IDPI - Dots Per Inch
IPLT - Palette Setting

Extended RIFF INFO tags:
ISGN - Secondary Genre
IWRI - Written by
IPRO - Produced by
ICNM - Cinematographer
IPDS - Production Designer
IEDT - Edited by
ICDS - Costume Designer
IMUS - Music by
ISTD - Production Studio
IDST - Distributed by
ICNT - Country
ILNG - Language
IRTD - Rating
ISTR - Starring
IWEB - Internet Address
IPRT - Part
IFRM - Total Number of Parts
IAS1 - First language
IAS2 - Second language
IAS3 - Third language
IAS4 - Fourth language
IAS5 - Fifth language
IAS6 - Sixth language
IAS7 - Seventh language
IAS8 - Eighth language
IAS9 - Ninth language
ICAS - Default audio stream
IBSU - Base URL
ILGU - Logo URL
ILIU - Logo Icon URL
IWMU - Watermark URL
IMIU - More Info URL
IMBI - More Info Banner Image
IMBU - More Info Banner URL
IMIT - More Info Text

Other supported RIFF INFO tags (only reading, saved as standard tags):
IENC - Encoded by (=ITCH), used by GSpot
IRIP - Ripped by (=IENG), used by GSpot

IDivX tag (reading and updating):
Movie Name - 32 bytes
Author (director) - 28 bytes
Year - 4 bytes
Comment - 48 bytes;
Genre - 3 bytes;
Rating - 1 byte;

Sad to say, standard for RIFF INFO tags counts only with zero terminated strings. We can use UTF8 for unicode support (it's prepared for it), but other programs don't support UTF8 and will show special characters incorrectly in these tags (and vice versa, tags written in these programs will be shown in MM incorrectly due to UTF8 conversion).

peke

2009-08-26 00:58

developer   ~0018691

Last edited: 2009-08-26 01:07

RE UTF-8: Use workaround I used in WAV tagging (It is simple fix apron read see WAV plugin FORMAT_GetString how Res is checked prior to return). Add same workaround to write in ASCII like in WAV

Add support for Unicode.

Note: Please Check how DivX and some other formats embed Subtitles in files, also see if there is easy way to Embed Subtitles into RIFF CONTAINER (CUE Point chunk?)

michal

2009-08-26 11:30

developer   ~0018694

Subtitles should be in the subtitle stream (chunk "txts", containing SRT or SSA file). But I've never met such a movie file...

peke

2009-08-26 15:06

developer   ~0018696

You are right, what about multi language and if we support only one subtitle should we show IAS1 - First language in info?

DivX 6+ AVI contain Embed Subtitles even menus.

Same thing goes fro MKV Container that is not question here.

michal

2009-12-09 17:50

developer   ~0019822

Delphi2010 has IsUTF8String routine, it seems to work much better than peke's workaround in WAV plugin, I try to use it to detect non-UTF8 string, so we can read both - UTF8 encoded and raw ASCII strings from tags. Of course, the other programs with no support for UTF8 tags (e.g. WMP, MPC) will still show UTF8 encoded tags incorrectly.

jiri

2010-11-03 00:00

administrator   ~0021133

Raising priority to finish tagging of some unfinished fields, please resolve then.

jiri

2010-11-03 17:22

administrator   ~0021154

As discussed over IM, the necessary changes include:
 - Use all of the standard tags that we can support.
 - Use ITRK for Episode #
 - Tag Director as Artist
 - Use Album for TV Show name
 - Tag Season # into a new field, possibly tvsn - as in mp4?

peke

2010-11-04 19:06

developer   ~0021180

Another possible approach would be to Tag Season # into a Disk # and/or tvsn in Case of mp4?

michal

2010-11-09 12:57

developer   ~0021269

peke: Disk# could be used for movies too, e.g. for movies/series on more than one disk.

michal

2010-11-09 19:46

developer   ~0021279

Fixed in build 1324.
Episode # - ITRK
Director - IART
TV Show name - IPRD (Product field, used for Album in WAV)
Season # - TVSN (non-standard)
Rating - RATE (non-standard, but already used by some application)
IRTD prepared for parental rating
Actors - ISTR

peke

2010-11-10 01:40

developer   ~0021283

michal, you are right about Disk#

peke

2010-12-03 04:01

developer   ~0021578

Verified 1330