View Issue Details

IDProjectCategoryView StatusLast Update
0006255MediaMonkey (current)Synchronizationpublic2011-08-07 02:41
Reporterstephen_platt 
PriorityurgentSeverityfeatureReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.2.1 
Target Version4.0Fixed in Version4.0 
Summary0006255: Ability to change m3u format for portable devices
DescriptionSome portable devices require different formats for m3u playlists. For example, some devices can only read playlists with relative paths, while others can use playlists with absolute paths.

Other devices cannot read standard format m3u playlists, but only support "extended format" m3u (and vice versa).

We should add some more options in the device profile so that playlist format can be customized based on the requirements of the device.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=35181&st=0&sk=t&sd=a&hilit=playlists+relative
http://www.mediamonkey.com/forum/viewtopic.php?f=2&t=44380
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=7731
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=6836&departmentid=2&ticketstatusid=1
TagsNo tags attached.
Fixed in build1407

Relationships

related to 0004242 closedLudek Add support for .m3u8 (UTF-8 encoded playlists) 
related to 0005933 closedLudek Playlist Sync: Linux Folder separator 
related to 0008205 closedLudek M3U playlists for albums and artists aren't generated during sync (regression) 
related to 0008539 new Playlist sync option: Use 8.3 DOS-style filenames 
child of 0006285 closedjiri Blackberry sync 
child of 0007705 closedjiri Playlists: Handling UTF8 Playlists 

Activities

peke

2010-01-18 15:53

developer   ~0019957

Additionally as I already pointed in several other bugs some devices uses "/" instead of "\" and in other case need to have full relative path according how device see Additional memory path (Noted only on devices with mem. cards) where Root Path of device is seen like "/SD/..." or "\SD\.." or even in some cases "\Music\SD\".

peke

2010-01-18 15:56

developer   ~0019958

Also it should be noted that there is .M3U8 playlists that are same as M3U but with BOM character representing that files are UTF-8 encoded (Code Page should be confirmed yet).

rusty

2010-01-18 20:37

administrator   ~0019959

Last edited: 2010-01-18 20:39

Peke, can you include links to the issues you raise?

As far as UI goes, these options can be added to Device Configuration > Copy Playlists > Options for the MTP (when operating in MSC mode) and MSC plugins:

[ ] Force relative paths {tt: This causes the playlist to use a relative path to the files)
[ ] Use 8.3 DOS-style filenames {tt: This is needed for some older devices}
[ ] Use extended .m3u {tt: This format is used by some newer devices.}

Ludek

2010-01-21 00:06

developer   ~0019965

And from 0005933 :

[ ] Use Linux folder separator ('/' instead of '\') {tt: This format is used by some devices.}

Ludek

2010-01-21 15:08

developer   ~0019967

Implemented in build 1301.

stephen_platt

2010-10-25 16:11

developer   ~0020973

verified 1318

stephen_platt

2011-07-06 02:59

developer   ~0026574

[ ] Use 8.3 DOS-style filenames {tt: This is needed for some older devices}

This option seems to be missing in the latest build, but it was there previously. Was it removed for any particular reason?

Ludek

2011-07-06 15:14

developer   ~0026579

Last edited: 2011-07-06 15:15

View 2 revisions

The answer seems to be here: http://www.ventismedia.com/mantis/view.php?id=7705#c25897

Do we know any device that requires this format?

stephen_platt

2011-07-06 17:16

developer   ~0026583

Last edited: 2011-07-06 17:18

View 2 revisions

Seems the Creative Zen MX needs this format.
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=44192

jiri

2011-07-11 08:33

administrator   ~0026708

As I explained in http://www.ventismedia.com/mantis/view.php?id=7705#c25897 , this option actually hasn't ever been present in MM. Leaving as a lower priority issue for 4.1 and beyond.

jiri

2011-07-13 14:34

administrator   ~0026762

User suggested here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59168 that we should write LF line ending character only (and not CR) in case Linux-style separators are configured. It seems to make sense, Ludek please try to get this part into MM 4.0, if possible.

Ludek

2011-07-13 21:50

developer   ~0026779

Fixed in build 1407.

peke

2011-08-07 02:41

developer   ~0027079

Verified 1415