View Issue Details

IDProjectCategoryView StatusLast Update
0006042MediaMonkey (current)Install/Configpublic2010-10-10 02:18
Reporterpeke 
PriorityurgentSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006042: Improved options for OS integration: file types / AutoPlay / Context Menus
DescriptionMediaMonkey 3.x allows the user to configure File Associations, but doesn't give the user any control over:
-what AutoPlay options MediaMonkey adds (high priority)
-what Context-menu options MediaMonkey adds (urgent priority) (as described in 0005854)
-what the default actions are when clicking a file (urgent priority)

Note: Peke originally specced this issue and it included specs for what plugins are used for different file types. I've removed this from the spec because that is more an issue of Player configuration.

Updated mockups of this are posted to bug 0005953
Additional InformationPeke's mockups are uploaded to the ftp server.

http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=8946&departmentid=1&ticketstatusid=1#
TagsNo tags attached.
Fixed in build1312

Relationships

parent of 0005854 closedpetr 'Play in MediaMonkey...' explorer menus should be optional 
related to 0000459 new Associated file types should be reflected in the 'scan folders' dialog 
related to 0005953 closedLudek Combine Add/Rescan and File Monitor functionality 
related to 0006465 closedrusty File Associations configuration at install should be simpler / comprehensive 
related to 0006466 feedbackrusty Ability to choose input plugin per Filetype 
related to 0006549 closedLudek Video Files should be associated by default 
related to 0007614 closedLudek Explorer context menus don't function as expected (regression) 

Activities

peke

2010-02-20 19:23

developer   ~0020030

Can you please triage UI mockup

peke

2010-02-20 19:33

developer   ~0020031

NOTE: This approach considerably improve MediaMonkey Start of Playback response time.

peke

2010-07-05 23:22

developer   ~0020320

Reminder sent to: jiri, Ludek, michal, petr, rusty

It could be nice if we can add this or at least part of it in MM 4.0

Ludek

2010-09-07 14:29

developer   ~0020488

Fixed in build 1312 according to the UI proposal here:
http://www.ventismedia.com/mantis/file_download.php?file_id=492&type=bug

peke

2010-10-10 02:18

developer   ~0020709

Verified 1315