View Issue Details

IDProjectCategoryView StatusLast Update
0005953MediaMonkey (current)DB/FileMonitorpublic2010-12-22 00:18
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version3.1.2 
Target Version4.0Fixed in Version4.0 
Summary0005953: Combine Add/Rescan and File Monitor functionality
DescriptionSince file monitor is included in the free version, we should combine the UI of the two dialogs in some manner, so that when the user initiates a scan for the first time, they can also configure whether the selected folder should be monitored.
TagsNo tags attached.
Fixed in build1317

Relationships

related to 0005951 closedpetr Include File Monitor functionality in standard version 
related to 0006042 closedLudek Improved options for OS integration: file types / AutoPlay / Context Menus 
related to 0006530 closedLudek Navigation of Samba/CIFS networks is very slow 
related to 0006544 closedLudek Pressing 'Insert' while on a Location > Samba node doesn't transfer correct path to Add/Scan Folders dialog 
related to 0006615 closedLudek Add/Rescan dialog UI scans files even when configured not to 
parent of 0006656 closedLudek Add/Scan dialog: enabling/disabling checkbox doesn't change selection 
related to 0000459 new Associated file types should be reflected in the 'scan folders' dialog 
related to 0005952 closedrusty Update strings re. the fact that file monitor is included in free version 
related to 0006465 closedrusty File Associations configuration at install should be simpler / comprehensive 
related to 0007064 closedLudek Improve usability of Add/Scan dialog 

Activities

rusty

2010-09-03 20:18

administrator  

file_handling_40.png (423,047 bytes)

rusty

2010-09-03 20:20

administrator   ~0020482

I've uploaded a spec for this, per discussion with Jiri.

Ludek

2010-09-09 00:27

developer   ~0020512

Fixed in build 1312.

rusty

2010-10-14 18:12

administrator   ~0020770

Last edited: 2010-10-15 17:05

View 2 revisions

Tested 1316 and it seems to work well, aside from the following issues:

1) Usability issue overlooked in the design: The removal of the text bar that displays/allows the user to manually enter a network path means that:
 a) there's no workaround to get to a samba network (see 0006530)
 b) there's no way to enter a network path that isn't browsable (e.g. //192.168.1.128/movies/

We need a solution that would allow users to scan/continuously scan (& at startup) such paths.
Possible approaches:
i) add back the text bar, but treat it as a standalone node in the tree (rather than as a summary of all selected paths), and allow the user to configure the scan method for this path, and add it to the tree if it's a continuous scan method.
ii) allow the user to manually enter a path via the Navigation bar (exactly as in Windows explorer). Then if the user presses 'insert', that path would be added to the tree in the Add Folders dialog, and the user could select the appropriate scan method.
Ideally, both methods would be supported.

2) On several occasions, selecting the UPnP node in the add/scan folders dialog resulted in an AV. Reports were automatically submitted on 10/14.

3) When a network node is checked, the scan mode is not displayed (it is only displayed when the network node is also _selected_.

4) The tree moves when the user checks a node (if the parent node is above the viewable area). This causes the user to inadvertently select incorrect nodes in cases where they are selecting a couple of adjacent nodes.

5) I'm not sure if this is a bug, but I was wondering: Why is there an option to scan UPnP servers? i.e. what's the advantage of including such tracks in the library?

Ludek

2010-10-18 16:40

developer   ~0020835

Last edited: 2010-10-18 16:41

View 2 revisions

Fixed in build 1317:

1) Fixed by using solution i), solution ii) accomplished by 0006544
2) Reproduced and fixed
3) Not sure I understand here, you can (un)check a node while another node is selected, the scan options are shown always just for the selected node. This is the expected behaviour, don't you think?
4) Fixed
5) It is not a bug, it is a feature I've done based on Jiri's request. Personally I also don't see much advantage to have UPnP files scanned in the library, because they result in dead-links whenever the server is not available, this feature is similar to the ability to scan network files into library, it is very same, but the metadata are not read from tags (like in case of network files), but from the UPnP XML feed exposed by the host server.

rusty

2010-11-02 21:10

administrator   ~0021129

1) Verified 'Add bar' in 1320
2) The AV is fixed in 1320
3) The issue is that checking a node doesn't select the node, but this is covered in greater detail in 0006615.
4) Verified in 1320
5) UPnP scanning isn't working well. I'll enter this into a new bug.

peke

2010-12-22 00:18

developer   ~0022027

Closing Re verified 1337