View Issue Details

IDProjectCategoryView StatusLast Update
0006005MediaMonkey (current)Burning / Disc Handlingpublic2010-12-20 22:17
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006005: AccurateRip for verification of disc rips
Descriptionhttp://www.accuraterip.com/

Implementation examples at: http://www.hydrogenaudio.org/forums/index.php?showtopic=60440
and
http://www.hydrogenaudio.org/forums/index.php?showtopic=59423
TagsNo tags attached.
Fixed in build1337

Relationships

related to 0000243 closedLudek 'Secure' Ripping and New CD/DVD Playback engine 
parent of 0006218 assignedLudek Scripting: Add support of non-standard frames in tags 
parent of 0006972 closedLudek CD Configuration inacessible from the Rip CD dialog 
parent of 0009125 closedLudek AccurateRip 2 support 
related to 0007134 closedLudek Ripping can cause AV when 'Verify ripped tracks' is selected 
Not all the children of this issue are yet resolved or closed.

Activities

Ludek

2009-10-14 19:14

developer   ~0019146

Last edited: 2009-10-14 19:17

I completely implemented and tested the functionality, just UI to add.

I would suggest a simple UI, probably just a new checkbox:

[ ] Verify Ripped Tracks

The question is whether to add this checkbox
a) Directly to the rip dialog
b) To the Tools|Options|CD/DVD/BD Devices panel

I guess that a) is preferable?

After ripping I would just show a dialog similar to the error handler dialog suggested in 0004412 that would say whether all tracks were successfuly verified (or not) and some other details (e.g. verify confidence number, drive offset), also the [x] Retry column would be there in the case when a track failed to verification (same thing we have already implemented in 0004412).

Rusty, do you agree?

rusty

2009-11-26 15:39

administrator   ~0019778

Yes--sounds good.

Note: it might be worth putting all options in this dialog in the right-hand column, below the rip settings.

Ludek

2009-11-26 20:13

developer   ~0019782

Last edited: 2009-11-26 20:16

I am not sure I fully understand your note.

Do you mean that all the settings from Tools->Options->CD/DVD Devices like
Read type, Read Frames, Overlap Frames, Check Frames, Read CD-Text, On the fly encoding
should be moved to the rip dialog below the Format Settings?
And thus not to be configured per CD/DVD drive (as currently is), but according to last ripping session? Or according to combination of last ripping session and drive?

I am afraid that moving all these options would be confusing for users. I believe that you created the option sheet, because the options (like read frames) are quite technical and therefore it is rather kept for experts on the options panel and thus it is not bothering on the rip dialog for common users, isn't it?

rusty

2009-11-26 21:35

administrator   ~0019784

No, I just meant that 'Level Track Volume' and 'Eject CD after ripping' can be moved because it would appear strange to have some options at the bottom of the dialog and others at the side.

Ludek

2009-11-26 22:00

developer   ~0019786

Last edited: 2009-11-26 22:10

Ok, then I would suggest to add new [Rip Settings] button (to the Rip CD wizard) that would go to
Options->CD/DVD Devices

The button would be situated at the place where 'Level Track Volume' and 'Eject CD after ripping' are now and the checkboxes will be moved to Options->CD/DVD Devices pane as you suggested.

The pane will include (on the right side) controls in the following order:
Read type:[Secure read/standard read/corrected read]
Read Frames:[]
Overlap Frames:[]
Check Frames:[]
[x] Read CD-Text
[x] On the fly encoding,
[ ] Level Track Volume
[x] Eject CD after ripping
[ ] Verify ripped tracks

This way all rip settings will be stored per drive letter and configured in Options.

Agreed?


Note: Please correct me re letter capitalization, I am not sure how it is supposed to be in the English grammar.

Ludek

2009-11-26 23:58

developer   ~0019789

Last edited: 2009-11-27 10:07

Rusty, I suppose you wanted to put is as note and not additional information, so I am moving your text:

-----------------------------

I think that (verify ripped tracks, eject cd) are functions that users would normally want to configure on a per-rip basis, and that we shouldn't force the user to click extra buttons to access them.

Level track volume, is probably a one-time configuration item, though, that could be on the CD options panel (next to the rip-on-the-fly option), or could just as easily be on the rip dialog.

I don't think that there's a need to make any of these config items device-specific (i.e. a single setting should suffice).

Ludek

2009-12-06 16:19

developer   ~0019816

Last edited: 2009-12-06 16:26

Added UI in build 1301 by using the suggested approach and moving controls from the bottom of the rip (and convert) dialog to the right hand side (column).

Following strings are new:

Hint for '[ ] Verify ripped tracks' checkbox:
'Verifies ripped tracks against AccurateRip.com database'

New string on the log appearing after the rip:
'Track(s) have been verified against AccurateRip.com database with the following results:'
'Track %s failed to verify (track isn't present in database)'
'Track %s failed to verify (ripped inaccurately)'
'Track %s failed to verify (error parsing verification file)'
'Track %s failed to verify, this CD doesn't exist in the database or there is a problem with your internet connection'
'Track %s verified with confidence number %d (number of people matched your rip)'



And the log looks like:

-------------------------------------------
Ripping results
------------------------------------------------------
Track(s) have been verified against AccurateRip.com database with the following results:
 |----------------------------------------------------
 | [ ] Retry | Problem______________________ | Errors
 | [ ] ____ | Track D:\Track01.cda verified with confidence number 200 (number of people matched your rip) | 0
 | [ ] ____ | Track D:\Track02.cda verified with confidence number 200 (number of people matched your rip) | 0
 |
 |
 |
 |-----------------------------------------------------
 ___________________________________[[Ok]]
--------------------------------------------

Teknojunky

2009-12-11 23:12

updater   ~0019835

Last edited: 2009-12-11 23:21

I would like to see also support for accuraterip tags, both reading and writing.

There is an excellent open source tool which can analyze and verify existing lossless files against the accuraterip database and add tags called CUE TOOLS.

http://www.hydrogenaudio.org/forums/index.php?showtopic=66233&hl=cue+tools

This tool can embed a number of ACCURATERIP* tags during processing. If Mediamonkey could at least read these tags and add them to the library, it would be a huge boon in usability in conjunction with existing MM scripts and tools (especially with auto-playlists/filters).

The exact tags and data used can easily be checked by using the cue tools against a known accurate rip with the 'verify' function and 'write accuraterip tags' option enabled.

Going even further, should these accuraterip tags be supported, it would be even more awesome for the 'confidence' to be a column that could be enabled for view in the track list along with the little accuraterip icon.

Ludek

2009-12-14 17:05

developer   ~0019839

Last edited: 2009-12-14 18:29

I checked out the Cue Tools 2.0.4 and true is that in addition to the standard FLAC tags like

TITLE=Karmacoma
ARTIST=Massive Attack
ALBUM=Karmacoma
TRACKNUMBER=1
DATE=1995
ALBUM ARTIST=Massive Attack

it also writes following tags

ACCURATERIPID=000380b7-000e1148-2a04e304
ACCURATERIPCRC=20292d5a3
ACCURATERIPDISCID=004-000380b7-000e1148-2a04e304-01
ACCURATERIPCOUNT=2
ACCURATERIPCOUNTALLOFFSETS=2
ACCURATERIPTOTAL=2
TRACKTOTAL=4

as AccurateRip verification results data.

Maybe we could write this info to the FLAC tags after ripping, but I am not sure how important it is, because it doesn't seem to be a commonly used standard. In addition I would expect problems with writing this info to lossy tracks like MP3. Maybe I would rather deffer this in order to prevent from messing up MediaMonkey UI and track tags.

Another possibility would be to add some new scripting methods to accomplish this functionality via a script (MMIP addon).
e.g. add a new scripting property
OnRippedTrackVerified( AccuRipInfo)
where AccuRipInfo would include DiskID, Confidence Number, CRC, etc. and the script itself could write this info to e.g. Custom5 field and user could create Filter Custom5 contains "AccurateRip" in order to list all Accuratelly Ripped tracks.

What do you think, Jiri?

jiri

2009-12-14 19:32

administrator   ~0019841

I'd rather leave this for a script. We might add necessary support for such a script, particularly some kind of support of non-standard frames in tags.

Ludek

2009-12-15 10:14

developer   ~0019843

Ok, moved to 0006218.

Teknojunky

2009-12-15 14:35

updater   ~0019845

I appreciate the consideration, and support for non-standard frames has been on the wish list for a long time. But that isn't quite what was I was looking for, it does not seem to help for auto-playlists/filters.

peke

2010-12-12 04:06

developer   ~0021753

I wonder would it be useful to add Read Method into Rip Dialog?

So that user do not need to go to Tools -> Options -> CD/DVD/BD and will clearly state that Mm support Secure RIP users request so much.

For Example I switched to Secure Read to get more accurate Rips.

rusty

2010-12-12 05:34

administrator   ~0021763

Re-resolving--this issue is fixed.

Ludek

2010-12-15 11:32

developer   ~0021834

Last edited: 2010-12-17 13:34

View 2 revisions

1) is fixed in build 1336
2) is part of 0006972

rusty

2010-12-19 06:46

administrator   ~0021921

Tested 1336. It works fine, but the upgrade message can be cleaned up slightly. The following can be removed: "For upgrade information, click the link below", since similar text is already included as a standard snippet in all upgrade dialogs.

Ludek

2010-12-20 10:22

developer   ~0021953

Fixed in 1337

rusty

2010-12-20 22:17

administrator   ~0021984

Verified 1337.