View Issue Details

IDProjectCategoryView StatusLast Update
0004970MediaMonkey (current)Otherpublic2009-09-19 03:15
Reporterpeke 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0004970: Component Updated: New TIEHTTP Release
DescriptionNew TIEHTTP Has been Released http://www.myfxboard.com/tiehttp/README.html

Much Better Unicode, Vista, IE7 Support.
TagsNo tags attached.
Fixed in build1201

Relationships

related to 0003844 closedpeke Last.fm plugin Last.FM Native Support 
related to 0003360 closedLudek MediaMonkey (current) Use single internet access library instead of TIE + Indy 
parent of 0004976 closedLudek MediaMonkey (current) Extensions: Support for Additional browser header info 
related to 0005001 closedLudek MediaMonkey (current) Regression: Some podcast feeds no longer work 

Activities

peke

2008-11-27 08:45

developer   ~0015177

Assign to Ludek for investigation as talked on IM.

peke

2008-11-27 09:32

developer   ~0015178

Last edited: 2008-11-27 09:41

Updated Descriptions to Original Developer page.

Ludek

2008-11-27 11:28

developer   ~0015182

I don't think it is so important to update TIE now.
1. It involves some time to update, because we customized TIE (it was not thread safe, were not optimized etc. and was quite buggy).
2. There doesn't seem to be anything so valuable in the changelog.

Therefore I'm decreasing priority to urgent (until more important issues related to MM 3.1 will be done).

rusty

2008-11-27 22:28

administrator   ~0015207

Ludek, fyi re. 4970: peke set high priority due to the fact that the last.fm extension doesn't seem to work correctly in some environments (read: my machine) with the current version.

peke

2008-11-28 00:07

developer   ~0015214

Updating to TIE Build 066 fixed issues with some environments (read: Rustys machine) Read 0003844 for updates on temporal fix

Changes from 046 we used:
1.3.0.47 18feb2006: added gzip decompression (iis) (i had only deflate)
1.5.0.48 02jan2007: supports Custom-Content-Length for aspx files
1.5.0.60 24apr2008: using xxxW() windows wide functions e.g. InternetOpenW
1.5.0.61 24apr2008: full unicode, ditched ansi char operations, pchar operations e.g. strcopy, strcat
1.5.0.62 24apr2008: automatic conversion from charset=utf-8, charset=utf-16, charset=us-ascii
1.5.0.65 30apr2008: twidestringlist: added option for d7 users to use the default TStringList (ansi) or the TTNTStringList (->DEFINE TIE_USE_TNT)

jiri

2008-11-28 10:33

administrator   ~0015225

Settings as Urgent, so that Ludek can look into it, either for 3.1 or later.

Ludek

2008-12-03 01:03

developer   ~0015307

Update to 066 added in build 1199.

rusty

2008-12-03 05:00

administrator   ~0015313

Verified podcasting and autotag from Amazon in 1199.

Ludek

2008-12-05 10:34

developer   ~0015419

Reopened because many podcast feeds are not read properly now due to a bug in the current version of TIE (see 0005001). Reverted TIE back to 1.3.0.46.

Reverted in build 1201.

peke

2008-12-11 22:40

developer   ~0015604

Last edited: 2008-12-11 22:42

Could usage of GUNZIP part of TIEHTTP can cause that and or changes to Unicode handling in 066 version along with usage of TNT components as the example podcast in 0005001 is in Unicode?

Ludek

2008-12-11 22:57

developer   ~0015605

Last edited: 2008-12-11 22:57

No, I debugged it a little and it has nothing to do with unicode neither GUNZIP. One of the example podcasts is ASCII and one is UTF-8. It just don't work for some podcasts (returns nonsense chars for both of the example podcasts) and works for other.

peke

2009-01-03 17:09

developer   ~0015968

Can you provide some podcast URLs that I can test them in New TIEHTTP outside MM?

After that revert to resolved and Assign to me for future tests.

Ludek

2009-01-04 11:55

developer   ~0015969

Last edited: 2009-01-04 11:55

They are those from 0005001 :
http://www.npr.org/rss/podcast.php?id=1056
http://feeds.feedburner.com/EstaoIndependente

peke

2009-05-22 15:30

developer   ~0017968

Note: http://www.myfxboard.com/tiehttp/ Released Specific Delphi 2009 Version

peke

2009-09-19 03:15

developer   ~0018927

Closing as we moved to other approach described in 0003360