View Issue Details

IDProjectCategoryView StatusLast Update
0002364MediaMonkey (current)Main Panel/Toolbars/Menuspublic2009-05-31 10:45
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.1 
Summary0002364: 'My Computer' node infers properties even when 'infer properties' is completely disabled
DescriptionThis was reported by a user and I subsequently verified it. It's similar to a couple of other 'infer properties' bugs, but a bit worse because it occurs even when infer properties is disabled!!

User report:

Part of my collection is videogame music, a genre for which I don't really know the artists, and don't often care. I like to leave the artist and track tags empty, because they rarely apply to videogames.

Directory structure for the game Homeworld 2 is like so: I:\_Music\Game\Homeworld 2\songs.ogg

I open it up and as soon as I click the Homeworld 1 folder while using the my computer dropdown in the left pane, MM fills the artist tags with Game, and fills the track tags with numbers it pulls from the filenames.
I have unchecked infer track properties, and told it to get track numbers from tag only, yet it seems to be inferring quite a bit.

If I select all the songs and delete the inferred tags manually, therefore writing these tags to disk, the next time I click on that folder with MM the tags will be filled again.

I know that the inferred tags are not written to disc until I edit the songs and click ok, but even so, when I edit the tracks all of the incorrect and useless information is in the resulting edit box (artist name and album artist both set to "Game")

I just want it to never ever ever automatically set tags from foldername, filename, playlists, anything! I thought that unclicking the infer tags checkbox would do that.
TagsNo tags attached.
Fixed in build1185

Relationships

related to 0002165 closedpetr 'My Computer' node infers properties of tracks that are already in the DB 
related to 0001412 feedbackjiri Changed capitalization not recognized in some cases and is inconsistent with MMA 
related to 0001502 closedjiri File Monitor/Manual Rescans fail to detect tag property deletions 
related to 0001327 closedLudek Properties are inferred erroneously on rescan of tracks already in the library 
related to 0002606 feedbackpetr Track metadata disappears from view on playback 
related to 0008503 closedjiri 'My Computer' & Device nodes change properties on selection if tag doesn't match Library (regression) 

Activities

petr

2008-07-24 22:07

developer   ~0014411

Fixed in 1185

user_chrisjj

2009-05-31 10:45

updater   ~0018081

Last edited: 2009-06-03 16:38

Re Rusty's

> a bit worse because it occurs even when infer properties is disabled!!

note that the only "infer properties is disabled" Option is defined to apply only to the library, whereas this issue is in My Computer. EDIT: and hence this Summary

"'My Computer' node infers properties even when 'infer properties' is completely disabled"

is inaccurate.