View Issue Details

IDProjectCategoryView StatusLast Update
0002165MediaMonkey (current)Properties/Auto-Toolspublic2010-12-20 20:17
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1.2Fixed in Version4.0 
Summary0002165: 'My Computer' node infers properties of tracks that are already in the DB
DescriptionThis is a rather serious bug in which updating a field by deleting its contents fails to update the tag correctly.
I've replicated the problem by going to the MM\My Computer\<Any Directory> node and deleting field X for a particular file. In many cases, if I refresh the directory, it appears that the field has NOT been deleted!

Listed below are the fields that consistently failed to delete for various formats (I only tested Artist, Album, Title, Year, Genre fields):
MP3: Artist, Title
FLAC: Title, Artist, Album, Genre
OGG: Title, Artist (Deleting the Artist changed it to '01' in one case), Album (failed in 1/2 tests)
WMA: Title, Artist, Year, Genre
MPC: Title, Artist, Album, Genre
APE: Title, Artist, Album, Genre
Additional InformationOriginally reported at: http://fileforum.betanews.com/detail/MediaMonkey/1004522272/1

I'm guessing that this is another instance of this problem
TagsNo tags attached.
Fixed in build1185

Relationships

related to 0001412 feedbackjiri Changed capitalization not recognized in some cases and is inconsistent with MMA 
related to 0001502 closedjiri File Monitor/Manual Rescans fail to detect tag property deletions 
related to 0001327 closedLudek Properties are inferred erroneously on rescan of tracks already in the library 
related to 0002606 feedbackpetr Track metadata disappears from view on playback 
related to 0002364 resolvedpetr 'My Computer' node infers properties even when 'infer properties' is completely disabled 
related to 0008503 closedjiri 'My Computer' & Device nodes change properties on selection if tag doesn't match Library (regression) 

Activities

jiri

2005-12-06 11:08

administrator   ~0006521

I tested (with mp3) and understand what's going on. Tags are properly updated, or, to be correct, respective fields in tags are deleted. However then, when a screen in MM is refreshed, MM newly reads everything from files and part of this process is also 'guessing' of empty values from filenames.

So this explains why after deleting some values they appear back. Question is whether anything should be done about this, and what then. We can continue over IM...

rusty

2005-12-06 14:02

administrator   ~0006524

What I don't understand, though, is that I _didn't_ rescan the files in question. All I did was refresh the screen!

Are you saying that MM infers properties on each view (i.e. even when files aren't being rescanned)?

Possible solution:
Tracks that are part of the library already should not be updated based on 'inferences' (inferences should only be used for tracks that are newly added to the library).

rusty

2005-12-06 14:44

administrator   ~0006526

As discussed, best approach would be to put in an 'empty field' via each of the plugins. However, this is risky at this stage and should be deferred beyond 2.5.

jiri

2006-12-18 10:52

administrator   ~0008308

As I think about details of the proposed solution, I find that it isn't good. First of all, although it can be implemented for most formats, it isn't specifications conformant, empty fields shouldn't be written to tags. However, even bigger problem is in the fact that it wouldn't work for WMA at all, because we don't directly write fields there, WM layer does it and so empty fields aren't written.

I'd rather say, that the problem lies in the fact that both scanning of new tracks and browsing My Computer node uses the same settings for properties inferring from filename. While automatic inferring of properties on scanning of new tracks seems to make a good sense, it would possibly be better to not infer track properties in My Computer node and only show real content of tags there. There should be a specific settings for this somewhere (Tags options sheet?).

rusty

2007-01-09 21:22

administrator   ~0008401

I would suggest that we simply disable this functionality for now (if we were ever to include it, it should be accessible without going into the options menu but rather via the main panel).

jiri

2007-01-15 12:48

administrator   ~0008437

Assigning to Petr to resolve as discussed, i.e. MM won't infer any track properties when browsing in My Computer node, i.e. the real tag content will be shown there. On the other hand, on scanning track properties will be inferred as they currently are - based on settings on Library sheet in Options.

petr

2007-01-26 19:23

developer   ~0008500

solved

rusty

2008-07-07 17:32

administrator   ~0014323

Tested in 3.0.3.1183 and there's still a problem:

When the user is browsing the My Computer node, inferred metadata doesn't display; but when the user starts playing a track in the My Computer Node, inferred metadata magically appears!

You can easily reproduce this by playing a track that has a full filename (e.g. of the form <Artist> - <Album> - <Track>.mp3) but no metadata.

petr

2008-07-07 21:16

developer   ~0014326

Fixed in 1185

user_chrisjj

2009-06-17 15:26

updater   ~0018421

"(0014323) rusty (administrator) 2008-07-07 13:32" found unfixed in 1256. See http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=40592

Perhaps this should be Mantised as a separate issue?

petr

2009-10-01 21:45

developer   ~0019020

Fixed in 1300

peke

2010-12-20 20:17

developer   ~0021965

Verified 1336