View Issue Details

IDProjectCategoryView StatusLast Update
0014358MediaMonkey for AndroidSynchronizationpublic2017-09-19 06:34
Reporterrusty 
PriorityurgentSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version1.3.1 
Target Version1.3.1Fixed in Version1.3.1 
Summary0014358: USB Sync doesn't seem to be working correctly (several issues)
DescriptionWhen I do a USB sync using MMW 4.1.18.1845 / MMA 1.3.1.723 (Samsung S5 mini/Android 6), various anomalies are observed:

1 Uninstall MMA & Delete MediaMonkey directory
2 Delete device sync profiles in MMW
3 Plug in device, add 4 playlists to auto-sync list (New Downloads, Test S5 mini, Party Playlists > Back to school 2017, Test Playlists > Bronski test 111), and initiate USB sync (MMW Debug log line 0-14556)

-->
 
(Bug 1) upon initiating the sync, MMW was 'Removing old content' but the deletion confirmation dialog never appeared!

After removal of content, sync appears to proceed correctly for all tracks and playlists, though at the end, there was an error that Billy Joel - Glass Houses failed to sync.
--
(Bug 2) Upon running MMA, only 2 tracks (instead of 118) appeared!
Debug log 5AHNRX3HIR

Examining the device storage with the samsung File Explorer confirmed that the tracks weren't copied, even though they appeared to copy!
--

4 Attempt to USB Sync a second time (MMW log line 15095-26548)
-->
(Bug 3) Content appears to sync successfully to the device, although the audio files are visible in MMA, playlists are empty!

MMA Debug log: 9TM3EU7PBN (similar log from another sync CITJKGS8RB)
--
5 Initiate another sync to try to get the playlists to sync (MMW log line 0008180:0027000 - 28555)
-->
(Bug 4) One track (by Jane Bordeux) is deleted and recopied for no apparent reason (again without a confirmation dialog)

Upon running MMA, the playlists are still empty
--
6 Attempt to configure Wi-Fi sync in MMA in order to see if that resolves the problems (MMW debug log line 0008622:0028621)
-->
(bug 5) The sync profile for the SD card is empty and doesn't contain any of the USB sync settings! Configuring it (SM-G800H SD Card) results in the creation of a duplicate profile in MMW!

7 Wi-Fi sync with the new profile
--> All content is successfuly synced (MMA log ID: XCJB7PBJPC )
The problem now, though is that 2 different sync profiles remain: Rusty's Samsung S5 Mini (for USB sync) and SM-G800 SD card for Wi-Fi sync!! In fact there doesn't seem to be a way to get out of this situation (and use a single profile for both USB and Wi-Fi sync)!!!!

MMW log posted to the FTP server.
TagsNo tags attached.
Fixed in build730

Activities

rusty

2017-08-25 16:29

administrator   ~0048576

Tested with an honor 5x / android 7, and although bugs 1 (deletion without prompt) / 2 (partial sync) occur, bugs 3 (empty playlists) / 4 (unnecessary copying during sync) / 5 (distinct profiles for USB/Wi-Fi sync) don't.

Ludek

2017-08-28 12:52

developer   ~0048583

Last edited: 2017-08-28 15:44

View 8 revisions

I have reviewed the MMW log (MM5\bugs\bug\14358\bug14358_S5-mini.log) and I see that:

- MMW read the content from \MediaMonkey\files\mmstore.db
but all the tracks had timestamp '1970-01-01 00:00:00' (read from media.date_sync in mmstore.db) thus MMW saw that "file modified" timestamp in PC is newer and thus re-copied all the files (deleted old and copied new) therefore there wasn't any delete confirmation.
=> Fixed the needless re-uploading in 4.1.18.1846 , Marek indicated that those tracks were synced from media store (therefore media.date_sync == NULL)

As for the actual file copying, the only MTP error (80042009) I see for file
\Music\Billy Joel\Glass Houses\04 Billy Joel - It's Still Rock & Roll to Me.mp3
for all the other files there wasn't any MTP error so files look like copied without issues therefore MMW reported only 1 file as "failed to sync".

Couldn't MMA delete the files copied by MMW? I remember issue like this in the past.

EDIT: The tracks were really deleted by MMA, but because of incorrect info added to sync_operations table by MMW.
=> Fixed in 4.1.18.1876

The key to reproduce was to delete the device profiles in MMW, and let MMA to scan the tracks from media store before the first USB sync with MMW.

Ludek

2017-08-28 13:26

developer   ~0048584

Last edited: 2017-08-28 13:31

View 5 revisions

Re the profile duplication, the problem seems to be in storageInfo.xml version 1.4 :

<storages version="1.4" storageGuid="db5e7257.1.52db4bc7-b9ba-4dbf-b2cf-b610cb976b94">

while the <guid> element below in the XML includes an extra trailing ':' at the end:

<guid>db5e7257.0.d6e96874-cf96-48ba-b0b2-7f57e87bd338:</guid>

i.e. MMW taken 'db5e7257.0.d6e96874-cf96-48ba-b0b2-7f57e87bd338:' instead of just 'db5e7257.0.d6e96874-cf96-48ba-b0b2-7f57e87bd338'

Assigned to Marek for a fix. Example of the invalid storageInfo.xml (from my GS3) is attached.

Ludek

2017-08-28 13:32

developer  

storageInfo.xml (791 bytes)

marek

2017-08-28 13:49

developer   ~0048585

The regression in storageInfo.xml version 1.4 was fixed in build 724

Ludek

2017-08-28 15:45

developer   ~0048590

Last edited: 2017-08-28 15:48

View 3 revisions

Resolving, all issues should be fixed in MMA 724 / MMW 1846 (updated 0014358:0048583)

rusty

2017-08-31 06:08

administrator   ~0048629

Tested a variety of scenarios and almost everything seems to work correctly. The only problems I was able to consistently replicate is in cases where tracks pre-exist on the device.

1 Uninstall MMA, delete MMA/MMW sync profiles, /MediaMonkey directory, and contents of /Playlists. But leave tracks on the device so as to simulate situations in which tracks are copied to the device prior to install of MMA, and therefore lacking artwork in MMA.
2 Initiate USB Sync that includes the tracks on the device (Playlist:New Downloads, Back to School 2017, S5 mini sync test) and one playlist with new tracks (Bronski test) (MMW Debug log lines: 1008-5243)
-->
(Bug 6) Sync appears successful except that some of the tracks (e.g. in the New Downloads playlist: "Or Ka'ze" and "Halomot shel Aherim" are missing artwork. I couldn't find any pattern re. why some have artwork and some are missing.
MMA debug log: 4F14LJTPU5

3 Initiate Wi-Fi sync to try to update the artwork (MMW debug lines 0001886:0005500-9130)
-->
(Bug 7) MMA downloads 25 tracks that had already been downloaded!!
--> Resyncing via Wi-Fi doesn't update the artwork.
MMA debug log: LL6S9U34NB

4 In MMA delete 2 tracks that were missing the artwork (that were on the autosync list) and resync via USB (MMW debug lines 9697-12074)
-->
(bug 8) MMW syncs the tracks with the correct artwork, but, MMA Doesn't update the playlists (ie. the playlist is missing the 2 tracks that were deleted)!
MMA debug log: JAZZSY38F5

MMW log posted to the ftp server.

Ludek

2017-08-31 10:09

developer   ~0048630

Last edited: 2017-08-31 13:08

View 3 revisions

re (Bug 6): I see the reason. The tracks were unknown for MMW/MMA (by deleting the profiles and db) and starting from 1846 it just updates the track metadata (but without artwork) and doesn't re-upload actual files (MP3, JPG). But I guess I should adjust it and force re-upload of the files (once file size differs), because artwork files could be deleted together with the profiles/MM dirs and MMW/MMA cannot know it.

=> Fixed in 4.1.18.1847

Ludek

2017-08-31 13:40

developer   ~0048632

Last edited: 2017-08-31 14:51

View 12 revisions

I can also reproduce (bug 8), deleting the tracks in MMA deletes them also from MMA playlist, but because the PC playlist "last modified" timestamp is same as the "last modified" of the MMA playlist version then the playlist isn't updated in mmstore.db (although M3U is updated). Workaround is to re-order or somehow change the playlist in MMW.

Nevertheless I guess that it has always worked like this (in case of USB sync) -- that the version of playlist in MMA isn't replaced by the MMW version until the MMW version is manually updated.

=> Fixed in 4.1.18.1847 -- fixed same way as for the Wi-Fi sync, i.e. when the timestamps are same (but MMA playlist has less tracks) then the playlist is updated

rusty

2017-09-01 05:05

administrator   ~0048636

To summarize, bugs 6 and 8 no longer occur with MMA 725 / MMW 1847, however, bugs 7, 7b, 9 do occur (they are all variants of files copying unnecessarily during sync). Details follow (MMW log is on the ftp server).

1 Uninstall MMA, delete MMA/MMW sync profiles, /MediaMonkey directory, and contents of /Playlists. But leave tracks on the device so as to simulate situations in which tracks are copied to the device prior to install of MMA, and therefore lacking artwork in MMA.
2 Initiate USB Sync that includes the tracks on the device (Playlist:New Downloads, Back to School 2017, S5 mini sync test) and one playlist with new tracks (Bronski test) (MMW Debug log lines: 1101-8338)
-->
(bug 9) MMW recopies all 122 tracks even though they already exist on the device!
The good news, though, is that (bug 6) is fixed.

3 Initiate Wi-Fi sync (without making any changes to the sync list). MMW debug lines 8676-14029
-->
(bug 7) still occurs. 'Matching new files' message apppears, and then MMA proceeds to Wi-Fi sync 34 tracks even though all tracks had already been synced!
MMA Debug log: JBEPQ2E6TH

4 In MMA delete 4 tracks by 'Sam Roberts Band' (3 of which were on the New Downloads playlist that is on the autosync list) and resync via USB (MMW debug lines 14534-20002)
-->
(bug 7b) 89 tracks recopy (whereas only 4 should have recopied)! Note: the only difference between 7 and 7b is that bug 7 occurs with Wi-Fi sync, whereas 7b is with USB sync. Also, it's possible that 7b is the same as bug 9--in both cases, large numbers of tracks are copied unnecessarily, the only difference being that in case 9 no sync profile had been created.

5 Add a playlist (Mexican night containing 41 files) to the sync list and initiate USB sync.
--> 36 files are synced (presumably there were a few files duplicated already on the device)
This seems to imply that bug 7b (and possibly 9) only occur when a USB sync isn't done prior to a subsequent USB sync. i.e. if the user switches between Wi-Fi and USB sync, files will be copied unnecessarily.

Ludek

2017-09-01 10:28

developer   ~0048639

Rusty, where is the new MMW log?
I see only:
MM5/bugs/bug14358/bug14358_S5-mini.zip from 08/25/2017
MMA/bugs/bug14358/bug_14358_comment_48629_log.LOG.zip re comment 0014358:0048629

rusty

2017-09-01 11:30

administrator   ~0048641

Sorry--it's now posted.

Ludek

2017-09-01 13:25

developer   ~0048642

Re (bug9): the tracks weren't re-copied, just the artwork files (based on the log)

Re (bug7): It looks like MMA hasn't processed the metadata uploaded by MMW via USB (mmstore.db.synced.0003) before the Wi-Fi sync for some reason, to find more...

rusty

2017-09-01 14:27

administrator   ~0048645

Note: fyi I tested out these issues (7/7b/9) on another device (Honor 5x / Android 7.1.2) that doesn't have an encrypted SD card, and they occur as well.

Re. (bug 9): I guess that this can be split into 2 bugs:
9a) MMW indicates 'Copying x of y: <TrackTitle>', making the user think that the tracks are being unnecessarily recopied. I suppose that this can be easily fixed by displaying a more appropriate message (e.g. using existing phrases such as "Copying to xxx:" "Artwork" ).
9b) Recopying of artwork occurs on any USB sync performed subsequent to a wi-fi sync

(bug 10):
Also, in further testing I noticed that auto-conversion rules aren't always being applied. i.e. if TrackX pre-exists on the device at 320kbs, and the user then attempts to sync TrackX with an auto-conversion rule (Wi-Fi or USB) --> MM syncs but doesn't replace TrackX with an auto-converted version of the track.

Ludek

2017-09-01 17:01

developer   ~0048648

Last edited: 2017-09-01 17:56

View 9 revisions

(bug 9a) -- OK, I will try to adjust the message based on existing strings
=> Fixed in 1848

(bug 10) -- OK, but with all the info (MMW profiles/MMA files) deleted and pre-existing tracks it is impossible to effectivelly decide whether the pre-existing version is in the desired auto-convert format. I guess I will need to re-upload all pre-existing tracks that have different size than the PC version. i.e. all tracks that were or need to be auto-converted will be converted and re-uploaded again.
=> Fixed in 1848

(bug 7b) and (bug 9b) are consequences of (bug7) where MMA wanted to pair the track despite the fact that MMW uploaded the pair status via USB before (mmstore.db.synced.0003). And immediately after the new pairing process (via Wi-Fi where 23 tracks were paired) MMA sends "SyncedContentUpload" message with no tracks! It should contain IDs of all tracks that are already on the device. But because MMA sends "no tracks" then MMW deletes sync status for all the already synced tracks which results in (bug 7b) -- MMW thinks that the tracks just pre-exist and re-copy the artwork.

Assigned to Marek to analyze the MMA logs to see what is wrong on the MMA side.

marek

2017-09-02 15:06

developer   ~0048653

Last edited: 2017-09-02 15:06

View 2 revisions

(bug 7b) and (bug 9b) - I actually do not see that mmstore.db.synced.0003 is processed (I have checked all subsequent logs too). I see USB sync with mmstore.db.synced.0002 where only two tracks are inserted. That is why IDs are not synced to MMA. Could you please verify that the DB was really created?

(bug 7) I have found the cause why artworks are not resynced during pairing phase. When tracks are obtained from MediaStore, the artwork can be obtained from tag and it is stored in Android's media readonly location. In this situation size of artworks always differs and it should be updated from MMW. But it fails because MMA tries to download it to this Android's readonly location. I will fix this so the artworks will be updated during pairing phase.

marek

2017-09-03 21:27

developer   ~0048654

(bug 7) Fixed updating of artworks in MMA build 726

marek

2017-09-05 07:41

developer   ~0048658

(bug 7b) and (bug 9b) - MMA sends partial list of synced ids because MMA sometimes needs to sync album artwork. When ID is not listed, MMW puts this track on synclist so MMA can sync the artwork. I have added attribute to build 727 to indicate whether the list is complete or partial

Btw. this message is sent 3 times:
1. complete list - before query for tracks for deletion
2. partial list - before query for synclist
3. complete list - at the end of wifi sync - so MMW knows exactly what content is in MMA

Ludek

2017-09-05 08:20

developer   ~0048659

(bug 7b) and (bug 9b) - OK, adjusted also on MMW side in 1848, i.e. 7b/9b is fixed in MMW 1848 / MMA 727

rusty

2017-09-06 06:08

administrator   ~0048665

Last edited: 2017-09-06 07:19

View 2 revisions

Tested MMW 1848 vs MMA 727, and it's much improved. I did notice, though that there are still some instances of content syncing unnecessarily (see bugs 7b and 10 below, along with Questions 1-3). MMW debug log posted to ftp.


1 Uninstall MMA, delete MMA/MMW sync profiles, /MediaMonkey directory, and contents of /Playlists. But leave tracks on the device so as to simulate situations in which tracks are copied to the device prior to install of MMA, and therefore lacking artwork in MMA.
2 Initiate USB Sync that includes the tracks on the device (Playlist:New Downloads, Back to School 2017, S5 mini sync test) and one playlist with new tracks (Bronski test) (MMW Debug log lines: 1147-13312)
-->
MMW copies artwork/tags all tracks that aren't auto-converted (with appropriate messaging), and then auto-converts and overwrites tracks that already exist on the device. Tracks appear correctly in MMA.
(Question 1) The only problem is that the process of copying artwork/tagging seems to be much slower than before. Is this expected?

Note that this process is by design: Auto-conversion is applied to tracks that aren't matching in size only:
a) if there is a change in auto-conversion rules since the last sync
b) if a sync operation hasn't been performed before
Otherwise, if auto-conversion is enabled, tracks will often be resynced due to change in eg. Artwork being tagged during the sync process.

3 Initiate another USB sync (debug log line 14202
--> Tags get updated again!
(bug 10) Considering that nothing changed, the tags shouldn't have been updated again at this point!?

4 Initiate another USB sync (debug log line 16270-
-->
Something seemed to copy again very quickly (though nothing should have).
(Question 2) Not sure if this is a bug--please check the logs.

5 Initiate Wi-Fi sync (without making any changes to the sync list). MMW debug lines 17340-
-->
(bug 7b) MMA proceeds to download 34 tracks via Wi-Fi sync even though all tracks had already been synced 2x!
MMA Debug log: INUDSD2IL5

6 Initiate Wi-Fi sync (without making any changes to the sync list). MMW debug lines 21734-
-->
"Everything is in sync"
MMA debug log: ZZMZT2PMCP

7 Initiate USB Sync. MMW debug lines 22715-
--> No changes

8 Initiate Wi-Fi sync. MMW debug line 23417
--> "Everything is in sync"

9 In MMA delete 5 tracks by 'Sam Roberts Band' (3 of which were on the New Downloads playlist that is on the autosync list) and resync via USB (MMW debug lines 24356)
-->
Tracks (5) copy as expected, although I briefly saw a note about a playlist copying as well despite the fact that no changes were made to the playlist!
(Question 2) Please have a look at the log and see if anything unexpected is taking place in terms of a playlist updating unnecessarily.

10 Add a playlist (Mexican night containing 41 files) to the sync list and initiate USB sync. Debug log line 0008237:0027200
--> 32 files are synced (presumably there were a few files duplicated already on the device).

Edit: I noticed two other issues re. Artwork (bug 6):
a) The artwork for Oh Oh Oh, and November was White is missing. Both tracks possess Album and Album Artist metadata, yet don't display artwork in MMA. I'm not sure why.

Note that 'Wanted' by 'Trevor Guthrie' is missing Album metadata and has the same behavior, but that can be explained by 0011919.

b) Tracks such as 'What I like about you' that are missing both Album and Album Artist and don't possess artwork, all appear with artwork from an album by DNCE, even when the tracks don't appear in the same directory as tracks by DNCE!

Ludek

2017-09-06 14:56

developer   ~0048672

Last edited: 2017-09-06 14:58

View 3 revisions

2) I see that each artwork file took about 0.5 seconds to copy, there are certainly room for optimizations, but because this use case (of pre-existing tracks) isn't usual then I wouldn't spend much time on it.
i.e. Usually user copies the tracks using MMW/MMA and thus either MMW profile or MMA db exist and the track "sync state" is known.

3) It looks like if MMA hasn't processed all songs uploded in the step 2) , but as talked via IM, the log is missing many debug lines for some reason to see why exactly some songs were re-updated (artwork+tags). New log requested (with smaller group of tracks)

4) Just database (mmstore.db.synced) was uploaded, I guess this is OK. We could certainly improve it and add some checking whether the upload/update is really needed and/or improve messaging on the progress bar, but sounds like a minor issue to me (taking the work and possible new issues into account). i.e. MMW always (after each sync) uploads mmstore.db.synced for MMA to have up-to-date data even if no new tracks updated/added. e.g. when just MMW version changed or a value in profile settings.

9) along with the tracks also the '\Playlists\Mexican Night.m3u' was copied/updated on the device, I guess this is expected as the tracks were probably part of this playlist before deletion?

10b) 'What I like about you' has no artwork in MMW, I guess that the "incorrect" artwork got there via Wi-Fi sync? Could you check the artwork in MMA after each sync + generate MMA log?

rusty

2017-09-06 16:09

administrator   ~0048673

Last edited: 2017-09-07 15:08

View 4 revisions

2) The usecase of pre-existing tracks is actually very common--it'll occur for every new MMA user, since they will presumably have content on their devices. So if there's room for quick optimization it would be worthwhile since poor performance would be a good reason for users to just give up on MMA as soon as they try it.

3)/10b) Retested with 2 shorter playlists containing only the problematic tracks: New Downloads and Test Playlists/Test S5 mini

1 Uninstall MMA, delete MMA/MMW sync profiles, /MediaMonkey directory, and contents of /Playlists. But leave tracks on the device so as to simulate situations in which tracks are copied to the device prior to install of MMA.
-->
Bug 11: Tracks appear in MMA but if Album is missing in MMW --> MMA shows Artist & Album Artists="", Album="Unknown" (this is very strange!), and Artwork from 'Truckin' by the Grateful Dead (even if Artist, Album Artist, and correct AA appear in MMW). This occurs even though the tracks are synced to different directories.
MMA Debug log: PVSSXQFVY6
  
2 Initiate USB Sync that includes the tracks on the device (Playlist:New Downloads, S5 mini sync test) (MMW Debug log lines: 0002372:0006900-10837)
-->
MMW copies artwork/tags all tracks that aren't auto-converted (with appropriate messaging), and then auto-converts and overwrites tracks that already exist on the device. Tracks appear correctly (i.e. with Artist/Album Artist metadata, and with unknown Albums as "") in MMA, except that Tracks that are missing the Album field Album Art in MMW, appear in MMA with the Artwork from 'Truckin' by the Grateful dead (the difference from Step 1 being that this time this occurs for fewer tracks since it doesn't occur if artwork exists in MMW or for tracks that are saved to unique directories).
(Question 1) The only problem is that the process of copying artwork/tagging seems a bit slow. Is this expected?
MMA debug log: 9WDYECQDPU

3 Initiate another USB sync (MMW debug log line 13232-)
--> Artwork/Tags get updated again for 4 tracks (it looked like Idan Raichel tracks)!
--> MMA doesn't show any apparent changes (MMA log H2TD9K82FX)
(bug 10) Considering that nothing changed, the tags shouldn't have been updated again at this point!?

4 Initiate another USB sync (MMW debug log line 16131-)
-->
Something seemed to copy again very quickly (though nothing should have).
(Question 2) Not sure if this is a bug--please check the logs.

5 Initiate Wi-Fi sync (without making any changes to the sync list). (MMW debug line 17647 - 20986)
-->
(bug 7b) MMA proceeds to download 9 tracks, and updated 1 playlist from server even though all had been synced via USB!
(bug 6a) MMA shows missing artwork for both 'Wanted' and 'Truckin' (despite the fact that Truckin' artwork continues to be displayed for all other tracks for which Album="" and Artwork="".
MMA Debug log: NFFJD8Y9T5

6 Initiate Wi-Fi sync (without making any changes to the sync list). (MMW debug lines 21040-22057)
-->
Bug 0014354: "Updated 1 track"
No resolution to bug 6a
MMA debug log: M7KRY67AV2

7 Initiate USB Sync. MMW debug lines 22750-
--> No changes

8 Initiate Wi-Fi sync. MMW debug line 24309-
--> "Everything is in sync"
--> No resolution to bug 6a
MMA debug log L5558IXL56


Note:
I couldn't replicate the bug in which the Album Art for tracks Oh Oh Oh... and November was White... disappeared.

Ludek

2017-09-06 19:43

developer   ~0048675

Last edited: 2017-09-08 19:50

View 12 revisions

2) Common usecases of "pre-existing" tracks are:
a) the tracks were synced using MMW and thus the MMW profile exists and the "sync state" is known and artwork already exists (no need to re-copy anything)
b) the tracks were copied using another app and thus are in different locations and needs to be paired, auto-converted tracks re-uploaded, artwork uploaded anyway (i.e. not much room for optimization)

Your test case is a "hybrid" of a&b -- which isn't common.

3) is consequence of a MMA issue - namely for the "Idan Raichel" tracks mmstore.db.media.wifi_item_id is NULL again although MMW supplied the corresponding ID in the previous USB sync, MMA failed to update it for some reason. Thus MMW re-paired the tracks and updated again.
Hopefully the reason will be seen in the MMA logs between steps 2 and 3.

marek

2017-09-08 11:45

developer   ~0048681

3) I have checked both logs H2TD9K82FX and 9WDYECQDPU - I have both mmstore.db databases and in both the wifi_item_id is 20871, i.e. it is set. I can send them to you if you need it.

Ludek

2017-09-08 14:55

developer   ~0048682

3) As discussed offline for some "Idan Raichel" tracks all data (like volume leveling, auto-convert hash) are accepted by MMA, but the pairing key (wifi_item_id) wasn't. To be found why MMA isn't accepting the id for some tracks...

rusty

2017-09-11 17:18

administrator   ~0048699

Last edited: 2017-09-11 17:20

View 2 revisions

If you tell me which particular Idan Raichel track(s) are causing the problem, I can try testing with an even smaller playlist.

btw, the only unique thing that I see about one of the Idan Raichel tracks is that 'Todas Las Palabras (all the words) feat Marta Gomez' appears in _both_ playlists that are on the auto-sync list.

rusty

2017-09-12 00:35

administrator   ~0048706

Last edited: 2017-09-12 00:36

View 2 revisions

Retested with MMA build 728 vs MMW 1848. MMW debug log on FTP.

0014358:
bug 11) In cases of MMA scanning tracks copied to the device prior to the installation of MMA --> Tracks appear in MMA but for those tracks in which the Album field is missing
--> MMA shows Artist & Album Artists="", Album="Unknown" (instead of just ""), and Artwork from 'Truckin' by the Grateful Dead (even if Artist, Album Artist, and correct AA appear in MMW).
MMA debug log: l1SLKDWM9A

Initiate a USB sync (MMW line 3422-
--> Artwork/Tags get copied for 23 tracks
MMA debug log: 1SQSGDCMSF

bug 10) Initiating a second subsequent USB sync (MMW line 9295-
--> Artwork/Tags get copied again even though they had just been synced (note: I didn't actually observe this happening this time--I wasn't focused on the screen)
MMA debug log: 2946E5C6Y3

bugs 7b)/6a Wi-Fi sync after USB sync (MMW line 11591-
--> 7 tracks downloaded / 1 playlist updated despite no changes between the sync operations!
--> MMA shows missing artwork for both 'Wanted' and 'Truckin' (despite the fact that Truckin' artwork continues to be displayed for all other tracks for which Album="" and Artwork="".
MMA Debug log: 9G1XG2PPJW

Wi-Fi sync (MMW line 15530-
-->bug 0014354 ) 1 playlist updated despite no changes between the sync operations!
MMA Debug log: Q5VAIWJ62S

rusty

2017-09-12 20:05

administrator   ~0048718

I wonder if the problems are related to Artwork:

bug 11) Tracks for which both Album Artist and Album are unknown are synced to
\Music\Unknown\Unknown and the only albumart.jpg in that directory is for DNCE - Cake by the Ocean

That would explain 6b (many tracks containing DNCE artwork) at http://www.ventismedia.com/mantis/view.php?id=14358#c48665 , but it still doesn't explain bug 11) (Artwork for Grateful Dead - Truckin' appears for tracks missing the Album field) at
http://www.ventismedia.com/mantis/view.php?id=14358#c48673
and
http://www.ventismedia.com/mantis/view.php?id=14358#c48706
_Especially_considering_the_fact_that_/Music/Grateful Dead/Unknown/_has_no_albumart.jpg file!!

bug 10) I see that the track by Idan Raichel is copied to /Music/Unknown/Within my walls/01 The Idan Raichel Pro - Todas Las Palabras (All The Words) feat Marta Gomez.mp3

and albumart.jpg was copied to that directory. But strangely the album art for that album also appears at:
/Music/Unknown artist-Within My Walls/albumart.jpg !!
so I wonder if that is a test artifact (i.e. was it saved from an earlier sync operation) OR did USB sync vs Wi-Fi sync somehow use different paths?

7b) ?
6a) The directories for
\Music\Trevor Guthrie\Unknown\00 Trevor Guthrie - Wanted.m4a
\Music\Grateful Dead\Unknown\00 Grateful Dead - Truckin'.mp3
\Yello\Ferriss Buehlers Day Off\00 Yello - Oh Yeah.m4a
are all missing albumart.jpg!! This is particularly strange since Yello still displays artwork (although in an earlier test, it also lost it)

rusty

2017-09-12 22:17

administrator   ~0048719

When I test this having first deleted pre-existing tracks from the device:

USB Sync-->
Bug 11) Not replicable. In cases of MMA scanning tracks copied to the device prior to the installation of MMA --> Tracks appear in MMA but for those tracks in which the Album Artist and Album field is missing MMA shows Artist & Album Artists="", Album="Unknown" (instead of just ""), and Artwork from 'DNCE' as would be expected (bug 0011919). I can no longer replicate the problem in which the Artwork from Truckin' is applied to those tracks.

Bug 10) Not replicable. Initiating a second subsequent USB sync
--> Artwork/Tags aren't recopied.

Wi-Fi sync after USB sync (MMW line 11591-
-->bug 7b) 1 tracks downloaded / 1 playlist updated despite no changes between the sync operations!
-->bug 6a) Not replicable. MMA shows artwork for 'Wanted' and 'Truckin'



When I attempt to do this again now having left the tracks on the device:

Bug 11) Not replicable. In cases of MMA scanning tracks copied to the device prior to the installation of MMA --> Tracks appear in MMA but for those tracks in which the Album Artist and Album field is missing MMA shows Artist & Album Artists="", Album="Unknown" (instead of just ""), and Artwork from 'DNCE' as would be expected (bug 0011919). I can no longer replicate the problem in which the Artwork from Truckin' is applied to those tracks.

Initiate a USB sync (MMW line 3422-
--> Artwork/Tags get copied for 23 tracks

Bug 10) Initiating a second subsequent USB sync (MMW line 9295-
--> Artwork/Tags get copied again for one track even though they had just been synced

Wi-Fi sync after USB sync (MMW line 11591-
-->bug 7b) 7 tracks downloaded / 1 playlist updated despite no changes between the sync operations!
-->bug 6a) MMA shows missing artwork for 'Wanted' (but 'Truckin' artwork displays normally)
---------
Summary:
bug 11) is an anomaly--not sure why it occurred (though it's really strange that artwork from Truckin' was applied to other tracks).

bug 10) always occurs
bug 7a) always occurs

bug 6a) occurs, but the severity depends on whether tracks were pre-loaded to the device

marek

2017-09-13 15:42

developer   ~0048740

Bug 11)
Why these tracks have common artwork? This is caused by MediaScanner and it is not fixable on MMA side till our parser is used. It is probably because all tracks are "Unknown" album so MediaScanner merged them.

Bug 10)
I didn't find '/Music/Unknown artist-Within My Walls/albumart.jpg' path in any MMA log. It is probably test artifact or MMW copied it here.

Bug 7b) There are two parts:
 - Tracks are paired unnecessarily because sync id was not updated during USB sync. This is bug on MMA side but I still didn't find the cause, it looks ok without any exception. I cannot replicate it. I will have a look at it.
 - Tracks are redownloaded to MMA. This is caused by different size. MMA uses special field for sync size: sync_size. This size might be sometimes different to actual track size because of attached artwork. MMW doesn't update this field during USB sync. But I can use the _size value provided by MMW. Is this _size value actual file size OR is it the same value as is exposed in wifi sync in DIDL?

6a)
Re: why these artworks were cleaned after wifi sync:
MMA uses per album artworks. So currently, it does not syncs artwork for tracks with NULL or Unknown album, it is related to 0011919

I will verify why Yello is missing the artwork too.

Ludek

2017-09-14 08:08

developer   ~0048745

Last edited: 2017-09-14 08:19

View 2 revisions

re 7b) MMW _always_ fills both media._size and media.remote_size during USB sync, but I've just found that for the remote_size field there was missing trigger so its change wasn't notified to sync_operations table and thus might not be updated by MMA from "synced" to "internal" DB.
=> Fixed in MMW 4.1.18.1849

marek

2017-09-14 08:09

developer   ~0048746

6a)
Yello's artwork does not exist and it returns 404 during wifi sync. So it is related to 0014354 3)

rusty

2017-09-15 20:22

administrator   ~0048772

Tested MMA 729/MMW 1849:
The only issue that I can still replicate is bug 7b) and even that bug is only partially replicable. i.e. for the first Wi-Fi sync after a USB sync
--> 1 playlist updated despite no changes between the sync operations!
MMA Debug log: GBFCA6JWDD

Note: the bug isn't even that bad since it only occurs on the first Wi-Fi sync, but not after subsequent wi-fi syncs.

peke

2017-09-16 01:35

developer   ~0048775

re 7b) it happened on second WiFi sync from LG Verizon where 1 playlist got updated even it was not changed Only difference is that I tested as:
1. WiFi (Initial sync)
2. USB Sync (Nothing updated)
3. WiFi Sync (1 Playlist updated) LOG ID: HTYGH4RTIF

I checked the list and only change I've see is that affected playlist was a sub playlist. I'm trying to replicate again using same steps second time without success. Will send LOG ID if successful again, but I wondered if somehow USB sync interfere/changed structure of playlists and MMA assume new playlist is synced?

marek

2017-09-18 20:51

developer   ~0048779

7b) playlist update fixed

Fixed in build 730

rusty

2017-09-19 06:33

administrator   ~0048787

Verified MMA 730 vs MMW 1849