View Issue Details

IDProjectCategoryView StatusLast Update
0014354MediaMonkey for AndroidSynchronizationpublic2018-05-15 08:28
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.1 
Target Version1.3.1Fixed in Version1.3.1 
Summary0014354: Wi-Fi Sync: Editing tracks causes them to be deleted from Playlists / Playlists updated even when not changed
DescriptionI'm able to replicate this using MMW 4.1.18.1845 / MMA 1.3.1.723 on an S5mini (Android 6) using Wi-Fi sync.

Repro steps:
1 Sync PlaylistA
2 Add 'Metal Skin' (by Sam Roberts Band, Album: Lo-Fantasy) to PlaylistA
3 Resync
-->MMA displays the track as expect as part of PlaylistA
4 Edit the Album name (for all tracks on the album) to Lo-Fantasy1
5 Resync
--> Track is removed from the playlist! (resyncing fails to get it to re-appear)

TagsNo tags attached.
Fixed in build729

Relationships

parent of 0014824 closedLudek MediaMonkey (current) Album Art: Metadata update fail on some Album Art upload 
related to 0014366 closedmartin MediaMonkey for Android Adding tracks to a playlist can cause the playlist to be deleted 

Activities

Ludek

2017-08-24 11:50

developer   ~0048572

I can't replicate with MMW 4.1.18.1845 / MMA 1.3.1.723
Wasn't the PlaylistA an auto-playlist defining album as a rule?

rusty

2017-08-24 17:39

administrator   ~0048574

Last edited: 2017-08-25 03:32

View 3 revisions

So I can't figure out how to replicate the problem--even though it was occurring consistently yesterday. :-(

The one strange thing that I'm noticing today, though, when testing on that device is that every time I sync (even without changing the playlist or editng tracks) MMA indicates 'Updated x playlist(s) from server'

The trigger seems to be to edit the contents of the playlist once--subsequently, every sync results in the 'Updated x playlist(s) from server' (where x depends on the number of playlists that have been edited).

MMA log: 685IDY8WWD, P7QDFTFMC1
MMW log posted to ftp.

rusty

2017-08-28 16:47

administrator   ~0048592

Upon retesting, I can confirm that:
- After the initial sync of New Downloads, subsequent syncs don't cause the playlist to update.
- If New Downloads is modified by adding a track to it (in MMW), subsequent Wi-Fi syncs always result in 'Updated playlists from server'.
- An examination of the playlist file (by renaming it to .txt on the device) shows that it actually _does_ get modified correctly on sync when the track is first added to the playlist (which is surprising since the fact that MMA tries to update it on subsequent syncs would imply that it isn't correctly updated).

marek

2017-08-28 19:15

developer   ~0048594

So the playlist New Donwloads is still updated on each subsequent sync ?

rusty

2017-08-28 22:27

administrator   ~0048596

I retested this and found that the although the playlist was re-downloading, it never actually updated (neither in MMA nor in the M3U file), and in fact, in some cases, was deleted entirely as originally reported above (although I could have sworn that in earlier tests, the playlist did update in MMA):

1 Deleted playlists from MMA and m3u files from device
2 Initiated sync (of New Downloads playlist)
--> 'Downloaded 1 playlist' (5:46:43)
F9GCTJAXPJ

3 Wi-Fi Sync
--> 'Everything is in sync' (5:46:43-2)
JKDP5FHSR

4 In MMW, add 'Dreadlock Holiday' to the playlist
5 Wi-Fi Sync
-->
File converts, 'Downloaded 1 track', 'Updated 1 playlist from server' (5:55:11)
BUT, the playlist didn't get updated with the new track in MMA (though the track did copy)! (afaik, this bug did not occur previously)
1UEAJ1NVUK

6 Wi-Fi Sync
-->'Updated 1 playlist from server' (5:46:43)
But the playlist still didn't get updated with the new track in MMA
UDZPFLGAYK

7 In MMW, deleted 'Dreadlock Holiday' from the playlist
8 Wi-Fi Sync
-->
'Updated 1 playlist from server'
BUT, the playlist didn't get updated with the new track in MMA (though the track did delete)!

9 USB Sync
--> No changes, except for the creation of a 0B New Downloads.pla file in /InternalMemory/Playlists

10 In MMW, add 'Shapeshifters' to the playlist
11 Wi-Fi sync
-->
File converts, 'Downloaded 1 track', 'Updated 1 playlist from server' (6:15:29)
BUT, the playlist deleted from MMA! (6:15:29)
Note: this is the bug that was _originally_ reported at 0014354
XDWYHFQRYU

12 Wi-Fi sync
--> Same as step 11!! i.e. the playlist is still missing :-(

martin

2017-09-01 14:33

developer   ~0048646

related to 0014366
Fixed in build 1.3.1.0726

rusty

2017-09-06 06:48

administrator   ~0048666

The original issues seem to be fixed. However, there are now some other problems (debug log posted to ftp):

Bug 3): See line 6246 (and at least 2 sync operations prior to that): after removing and adding a track to a playlist, every Wi-Fi sync operation --> "Updated 1 track(s)" message!

Bug 4): Playlist edits in MMA don't sync to MMW (I thought that this worked previously, but perhaps I'm mistaken ?). e.g.:
1 Remove 2 tracks (under your thumb, London is bangin...) from 'New Downloads' playlist in MMA.
2 Initiate Wi-Fi sync (MMW line 6868)
-->
New Downloads Playlist in MMA is missing the two tracks, but they're not deleted from the device (despite that 'delete unselected...' is enabled), while the same playlist in MMW has the missing 2 tracks!

Ludek

2017-09-06 11:18

developer   ~0048669

Bug 3) MMA log is needed to find why "Updated 1 track" appeared

Bug 4) based on the MMW log the bidirectional sync was disabled so the playlist wasn't synced MMA -> MMW (as expected)

rusty

2017-09-06 11:34

administrator   ~0048670

I've just replicated the problem twice and generated a log after each sync:
1Q3XEMRCZ8
8YTU5BWG98

marek

2017-09-06 12:57

developer   ~0048671

Bug 3) The artwork is missing in MMW. Each syncs, it tries to update metadata - it means it tries to download the artwork but MMW returns HTTP404. We do not have error message for this. I know that MMW DB contains deadlinks because it is not able to verify it. That is why it shows "Updated 1 track(s)"

Ludek

2017-09-08 10:19

developer   ~0048680

re bug 3) As discussed offline: Fix is needed on MMA side, MMA shouldn't try to re-download artwork deadlinks on next sync.

rusty

2017-09-15 20:59

administrator   ~0048773

As described at 0014358 I'm still occasionally seeing 'Updated 1 track' in some cases, but it is only occasionally and it seems to be related to making changes in playlists and/or the auto-sync list.

So I would consider the fix to this issue to be verified.

marek

2017-09-18 20:27

developer   ~0048777

3) it is fixed in build 729. The remaining issue in 0014358 is about playlists, not tracks. That is different. This issue with artwork failure was already fixed.

rusty

2017-09-19 06:34

administrator   ~0048788

Verified MMA 730 vs MMW 1849