View Issue Details

IDProjectCategoryView StatusLast Update
0008622MediaMonkey (current)Properties/Auto-Toolspublic2016-12-01 17:32
Reporterlowlander 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0.4Fixed in Version4.0.5 
Summary0008622: Auto-Tag from Web returns No result was found
DescriptionFor several of the Amazon sites it will show the result and then go to No Result was found. This has been seen on MediaMonkey 3 and 4 for:

Amazon (UK)
Amazon (DE)
Additional InformationA global note has been made here: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=61578 as many support tickets and forum topics are coming in on this.

http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=63146
TagsNo tags attached.
Fixed in build1481

Relationships

related to 0008440 closedmichal Necessary changes due to upcoming Amazon API changes 
related to 0009072 closedmichal Autotag from web should filter some common acronyms in the title out. 
related to 0013071 closedLudek Penny Arcade Podcast fails with SSL error 

Activities

michal

2011-11-03 17:23

developer   ~0028621

I cannot replicate this, all Amazon servers work for me. Is it really always reproducible? Or is this specific only to some search strings?

lowlander

2011-11-03 17:50

developer   ~0028627

I've tested it with Dionne Warwick - Only Trust Your Heart. There are however many users reporting this in eSupport and on the forum.

michal

2011-11-03 18:00

developer   ~0028628

Even string "Dionne Warwick - Only Trust Your Heart" works. Do you replicate this always with this string?

lowlander

2011-11-03 18:07

developer   ~0028629

Last edited: 2011-11-03 18:09

View 2 revisions

It seems the issue is when Auto-Tag from Web removes the Album part of the query, then finds a album by the Artist and then goes to no results. Testing with Toots Thielemans - One More For the Road and Skik - Skik all Amazon sites got correct results, but with this query the album remained part of the query.

lowlander

2011-11-03 18:13

developer   ~0028630

It seems to be very specific as to what can cause this. Only if the full Dionne Warwick - Only Trust Your Heart Album is selected does this occur, if a single track is selected it doesn't happen, also using this query on when actually tagging another album does cause the no results problem.

michal

2011-11-03 20:23

developer   ~0028635

Please upload me the whole album, so that I can replicate it. The problem is, that all results are discarded as non relevant. It seems, that problem could be on Amazon side. It will not be regression, if this is the same in MM3.

lowlander

2011-11-03 21:29

developer   ~0028636

Album added to same location.

The Album does exist on the 2 Amazon sites:
http://www.amazon.de/Only-Trust-Heart-Dionne-Warwick/dp/B004KZ46WY/ref=sr_1_1?s=music&ie=UTF8&qid=1320355607&sr=1-1
http://www.amazon.co.uk/Only-Trust-Heart-Dionne-Warwick/dp/B004KZ46WY/ref=sr_1_1?s=music&ie=UTF8&qid=1320355648&sr=1-1
Even using the ASIN (B004KZ46WY) on those 2 Amazon sites fails with no results.

michal

2011-11-04 10:37

developer   ~0028647

I've found the reason - new Amazon API limits the response to only 10 pages (each has 10 items). It means, that if the right result is not in the first 10 pages, it is really not found. That is why it does not work more often for the whole albums - it leads to more general queries with more results, where limit to 100 items has big influence on search results.
We probably cannot do much with it.

michal

2011-11-04 11:07

developer   ~0028648

Note, that changes in Amazon API caused, that searching in MM3 is no longer functional. We probably should fix this for MM3 (use changes from 0008440).

lowlander

2011-11-04 16:50

developer   ~0028651

But why would it also fail when the correct ASIN is used? Also on the album it fails MediaMonkey seems to remove the Album name from the query (and thus getting many more results as only Artist is searched.)

michal

2011-11-04 17:48

developer   ~0028653

For me, using this ASIN works on all Amazon sites (in MM4, always returns the same album). Yes, some optimizing of the query should be done.

lowlander

2011-11-04 21:27

developer   ~0028657

Added debug2 for ASIN failure. Note it only fails with ASIN on those Amazon sites that failed on the regular Album as well (UK & DE). For those sites that where the Album was found the ASIN also works (US).

lowlander

2011-11-08 17:38

developer   ~0028719

Get Info/Buy has Amazon (US) preselected when nothing should be preselected and none of the Amazon options works.

rusty

2011-11-15 16:30

administrator   ~0028891

LL, can you clarify what the issue is? Jiri and Michal tested and don't see any problems with build 1459 (the limit of 100 tracks is a hard limit, and there is certainly a possibility of improving the query, but generally, the functionality seems to be working as expected).

lowlander

2011-11-15 18:18

developer   ~0028892

As stated using the full Album of Dionne Warwick - Only Trust Your Heart on Amazon (UK and Germany) you'll see the following:
1) Start Auto-Tag from Web
2) Search shows both Artist and Album
3) Search removes Album leaving Artist
4) An incorrect result will be shown (drop down has many results)
5) Incorrect result disappears and No result was found... will show

The problem here would seem that once a 100 results is passed it will remove all results and show no results. Also going from a result to no result message may take a little while.

1) After repeating the above 3 times with same result
2) Open Album on Amazon.co.uk in Firefox
3) Relaunch Auto-Tag from Web still Amazon (UK)
4) Album found
5) Switch to Amazon (Germany)
6) No result was found
7) Switch to Amazon (UK)
8) No result found
9) Testing CA, and FR they also fail, JP worked
10) Testing CA, FR, UK again, correct Album found
11) DE still failed

The problem here seems inconsistency in behavior which explains why some can't reproduce maybe. Also UK/DE searches are very slow, US returns results almost immediately. The underlying problem might be that neither UK nor DE have a tracklist for this Album whereas US does. Although JP doesn't and still finds the Album.

1) Using ASIN for Album: B004KZ46WY
2) Only US seems to find Album by ASIN
3) All other Amazon sites fail with no result was found

In the file context menu under Get Info/Buy, Amazon (US) is preselected when no item should be preselected. Furthermore it seems to occasionally (rare) fail to open the Amazon site in the browser.
1) Select file (Dionne Warwick - If You Can Dream)
2) Right click Get Info/Buy
3) Works for all Amazon sites, but Canada. Amazon Canada fails to open it a few times (among them the first attempt), but it's hard to reproduce as it now opens without issue.

michal

2011-11-15 18:50

developer   ~0028894

lowlander: the inconsistency is caused by the 100 items limit, every Amazon server has different database and gives different 100 results. And, not always the same 100 results. The only solution is try to improve the query I think. As this is not safe change, it is better to postpone it to 4.0.1.

lowlander

2011-11-15 19:19

developer   ~0028895

That makes sense, query improvement is a good idea as others have been complaining about the cutting off MediaMonkey does of the query. The question that remains though is why it can't find Artist - Album outright in this particular query which it seems to be able to achieve for Amazon (US).
As I don't use Auto-Tag from Web (Amazon sites) very often I don't know how many queries are impacted by this. The advice to try a different Amazon site should suffice for 4.0.

michal

2011-11-15 20:45

developer   ~0028897

Problem with "Dionne Warwick" album seems to be on Amazon side. I hardcoded query for this album (so Amazon returned only one result, the same query for all servers), and DE Amazon did not send any tracks (just info about whole album). Only US Amazon gave them all.

michal

2012-02-02 13:03

developer   ~0030221

Fixed in build 1600. Amazon search was reworked, now it tries to start with more specific query and continues with more general. Manual searching now always searches using keywords field, so search by ASIN should work as expected.

I would recommend to test this feature and probably merge it to 4.0.4, it should give better results (and mostly faster) then the original one.

rusty

2012-02-02 21:24

administrator   ~0030228

Re-opening for inclusion in 4.0.4.

michal

2012-02-20 16:25

developer   ~0030469

Merged to 4.0.4, build 1480.

rusty

2012-04-10 17:55

administrator   ~0030843

Tested 1480, and Auto-tag from web is completely broken--it always fails with the error:
Couldn't show results.
HTTP/1.1 400 Bad Request

michal

2012-04-10 20:49

developer   ~0030846

It is regression caused by revision 14915 (fix of 0009228), Ludek, please look at it.

Ludek

2012-04-11 10:28

developer   ~0030848

Fixed in build 1481.

peke

2012-04-26 23:33

developer   ~0030938

Verified 1484