View Issue Details

IDProjectCategoryView StatusLast Update
0013071MediaMonkey (current)Podcastspublic2017-04-20 11:36
Reporterlowlander 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.10 
Target Version4.1.15Fixed in Version4.1.15 
Summary0013071: Penny Arcade Podcast fails with SSL error
Descriptionhttps://www.penny-arcade.com/feed/podcasts

Fails to subscribe (as Title isn't retrieved) and to download episodes fails with SSL error.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=1&t=83556
KSO-511-94355
TagsNo tags attached.
Fixed in build1818

Relationships

related to 0013696 closedpetr MediaMonkey (current) Podcast: Incorrect URL representation in podcasts 
related to 0013699 closedLudek MediaMonkey (current) SSL Connections: We should update to latest OpenSSL libraries 
related to 0009228 closedLudek MediaMonkey (current) getConnected Radio Podcast fails 
related to 0008898 closedLudek MediaMonkey (current) Some podcast feeds don't work (regression) 
related to 0003360 closedLudek MediaMonkey (current) Use single internet access library instead of TIE + Indy 
related to 0008622 closedLudek MediaMonkey (current) Auto-Tag from Web returns No result was found 
related to 0012944 closedLudek MediaMonkey (current) Soundcloud Podcast fails to subscribe 
related to 0011030 closedLudek MediaMonkey (current) Some radio streams doesn't play and MediaMonkey cannot be closed 
related to 0010860 closedLudek MediaMonkey (current) Pause/Resume doesn't continue downloading Podcast episode in same physical file 
related to 0010864 closedLudek MediaMonkey (current) SDBDownloader - new scripting methods 
related to 0012166 closedLudek MediaMonkey (current) Can't subscribe to Podcast (possibly long URL) 
related to 0014003 assignedLudek MediaMonkey (current) Some NPO Podcast episodes fail to download 
related to 0014191 closedLudek MediaMonkey (current) Podcast: Podcast subscription and download SSL return connection error 

Activities

Ludek

2016-01-14 20:26

developer   ~0043867

SSL error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error

Seems to be TLS1 error, maybe OpenSSL update could help.

lowlander

2016-11-29 15:10

developer   ~0046302

http://www.heise.de/ct/uplink/ctuplink.rss also fails.

peke

2016-11-29 15:49

developer   ~0046303

opened 0013696 for further analyze as based on my finding SSL is not supported for download on that site.

Ludek

2016-11-30 13:46

developer   ~0046324

Updated OpenSSL (0013699) didn't help.

We could try updating Indy, the mirror of nightly builds:
https://indy.fulgan.com/

Ludek

2016-11-30 15:05

developer   ~0046330

Tried updated Indy (with TLS 1.2 support) and it solves the issue.

Ludek

2016-12-01 18:36

developer   ~0046357

Last edited: 2016-12-01 18:36

View 2 revisions

Fixed in 4.1.15.1818

Peke please re-verify all issues that I added to "related".
These were our custom fixes in Indy during the past years.

peke

2016-12-03 00:25

developer   ~0046376

Verified 1818 and all available related fixes in 1818, opening new bugs for found issues as they are maybe related but not part of this bug.