View Issue Details

IDProjectCategoryView StatusLast Update
0008898MediaMonkey (current)Podcastspublic2016-12-01 17:32
Reporterstephen_platt 
PriorityurgentSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version4.0.1 
Target Version4.0.7Fixed in Version4.0.7 
Summary0008898: Some podcast feeds don't work (regression)
Description1. This podcast does not work anymore: http://www.theworld.org/rss/tech.xml

When I look in Firefox I can see there are new issues and I can download them. But in MediaMonkey the last one downloaded is 27.01.2011. MediaMonkey is somehow not seeing that there are new shows.

2. HTTPS feeds get error: IOHandler value is not valid.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=67855
TagsNo tags attached.
Fixed in build1503

Relationships

parent of 0008924 closedLudek Some non downloaded Podcasts can't be played directly in MM 
related to 0008876 closedLudek dafyomiyicc.org Podcast fails to download 
related to 0008916 closedLudek casualstrolltomordor.com Podcast fails to download 
related to 0013071 closedLudek Penny Arcade Podcast fails with SSL error 

Activities

Ludek

2011-12-27 18:26

developer   ~0029643

Last edited: 2011-12-27 23:20

View 6 revisions

Both 1&2 fixed in build 1600 and merged into 4.0.3.1463

There is one problem with item 2 though. It works for all https links and podcasts I tested except for the reported one :-)
In MM3 we used another internet access lib which used WinInet API and by using this API the podcast works (server returns '200 OK' and body), but by using OpenSSL in combination with Indy the server continuously returns '302 Found' and recursively redirects to the same address over and over. It looks like something between the server and OpenSSL, but on a lower level as all params in the request that I can influence are same. I don't want to return to WinInet API as it cannot be used for cross-platform version and brings some others problems.

peke

2012-01-03 23:22

developer   ~0029713

1. Non Downloaded Podcasts can't be played directly in MM. After Download they play without problems.

Ludek

2012-01-04 00:09

developer   ~0029722

Tracked as 0008924

peke

2012-01-04 01:20

developer   ~0029724

Closing as 1. was verified in 1463

peke

2012-01-10 03:32

developer   ~0029788

Last edited: 2012-01-10 03:36

View 3 revisions

Martin read 0008898:0029643 2. Should be closed due Won't Fix/not fixable

rusty

2012-01-10 19:20

administrator   ~0029800

Let's keep our eyes open. Hopefully that site is an outlier, but if there are other sites like that which martin reported, we'll have to figure out how to solve the problem.

lowlander

2012-01-13 00:13

developer   ~0029843

Last edited: 2012-01-13 00:14

View 2 revisions

Another one that fails: https://www.blogtalkradio.com/ywmv.rss
Ticket: EHI-522199

peke

2012-01-13 03:49

developer   ~0029844

For me https://www.blogtalkradio.com/ywmv.rss do not even open in Firefox.

lowlander

2012-01-13 05:24

developer   ~0029847

It seems that this works: http://www.blogtalkradio.com/ywmv.rss in Firefox, but fails in MM to subscribe, not even sure if it is a proper formatted Podcast feed.

peke

2012-01-13 11:18

developer   ~0029856

Thx Ludek, you are right http: one works. After downloading XML of RSS it really looks like it is more blog made in RSS feed where you also have subfeeds presented as keyword searches. Occasionally there is some Media Files to download.

It is designed to be presented in XML along with additional RSS links I think that only those which have Media Files are imported.

Ludek

2012-01-13 15:56

developer   ~0029865

The http://www.blogtalkradio.com/ywmv.rss is not correctly formatted as its content is all on the one single row (line) and it exceeded max line lenght limit.

=> fixed in build 1465 (fixed Indy lib to accept such a long lines)

peke

2012-01-25 23:08

developer   ~0030084

Verified 1465

Ludek

2012-02-10 12:33

developer   ~0030355

It is still the same reason as I described here in note #c29643

lowlander

2012-08-09 02:33

developer   ~0031622

Last edited: 2012-08-13 16:08

View 3 revisions

2) http://feeds.feedburner.com/TechnoLiveSets
also fails with IOHandler error (ticket FRU-247083). The files link through an https dropbox link.

lowlander

2012-08-13 16:07

developer   ~0031634

Last edited: 2012-08-13 16:09

View 2 revisions

2) http://functionalnerds.com/feed and http://feeds.feedburner.com/sfsignalpodcast also fail as they link through to https download links (Ticket: SV-833435)

Ludek

2012-09-11 09:20

developer   ~0031909

http://feeds.feedburner.com/TechnoLiveSets works fine for me even with 4.0.6.1501

http://functionalnerds.com/feed [^] and http://feeds.feedburner.com/sfsignalpodcast
are fixed in build 1601.

Ludek

2012-09-24 22:31

developer   ~0032161

Merged into 4.0.7.1503

peke

2012-09-26 23:52

developer   ~0032213

Verified 1503

peke

2012-09-27 00:13

developer   ~0032217

Verified 1503