View Issue Details

IDProjectCategoryView StatusLast Update
0013957MediaMonkey for AndroidSynchronizationpublic2017-02-07 05:17
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0 
Target Version1.3.0Fixed in Version1.3.0 
Summary0013957: Tracks don't match to the displayed track
DescriptionWith build 667, I can easily create a situation in which the user clicks taps track A to play it, but track B plays instead.

e.g. Click 'Strong world' --> 'Od Yishama' plays
Log ID: 4BTYFTHMRB

Here's how:
1 Sync 4 playlists (New Downloads, Grad Party, Party Background, Shlomo Katz) + 1 Artist (MMW build 1824):
--> they sync, display, and play correctly
2 Uninstall MMA, and delete the /MediaMonkey directory
3 Reinstall MMA and configure an identical sync profile except deselect the 'Shlomo Katz' playlist + the Artist from the sync profile
--> New sync profile is created
4 Sync
--> Files appear to match-sync/delete as expected
--> Upon playing tracks almost all are mismatched! It would appear that there's a regression in the matching algorithm.

Note:
- I suspect that this may be the same problem as I'd identified in 0013881 (though at that time, I'd misidentified the cause).
- I also tested upgrading from 1.2.624 to 1.3.667 and that worked correctly even after multiple sync. The problem only seems to occur when matching is triggered.
TagsNo tags attached.
Fixed in build671

Relationships

related to 0013881 closedrusty Anomalous behavior when installing MMA 1.2.0 and uninstalling MMA 1.3.0 
related to 0013963 closedmarek Some files/artwork are synced to primary:Music/ 

Activities

rusty

2017-01-27 15:51

administrator   ~0047100

Last edited: 2017-01-27 18:24

View 2 revisions

Note, further testing shows that I can replicate the problem with the following simpler set of steps:
1 Sync 2 playlists (New Downloads, Shlomo Katz):
--> they sync, display, and play correctly
2 Uninstall MMA, and delete the /MediaMonkey directory from the device and the device profile in MMW
3 Reinstall MMA
--> All tracks play correctly
4 Configure an identical sync profile and Wi-Fi sync
--> Sync dialog prompts to delete 'Niggun Nevo' for some reason
5 Accept deletion
--> 3 Files resync including 'Niggun Nevoh' (it look like it synced twice) and 'Ana Avda'
6 Attempt to play the files in New Downloads playlist
--> 'Or Ka'ze' displays but 'Oh Yeah' plays. Many tracks in both playlists exhibit the same problem.
--> Note that the problem also occurs when playing Tracks directly (i.e. not via a Playlist)

Debug log: JQWQSCE5P7

rusty

2017-01-30 15:41

administrator   ~0047112

Last edited: 2017-01-30 16:16

View 2 revisions

ote, further testing shows that I can replicate the problem with the following simpler set of steps:
0 Install MMA and verify that DB is empty
Debug log SKYBVHLQ65
1 Configure sync settings in MMA
Debug log: H85BLRKJ2R
1.1 Enable auto-conversion for all files > 192kbps in the sync profile in MMW
1.2 Sync 2 playlists (New Downloads, Shlomo Katz):
Debug log:
VIDVB79NAN
--> they sync, display, and play correctly (verified with about 6 tracks in 'New downloads' playlist)
2 Uninstall MMA, and delete the /MediaMonkey directory from the device and the device profile in MMW
--> After a couple of minutes, verified that the /MediaMonkey directory deleted as expected
3 Reinstall MMA and verify that tracks appear as expected
Debug log: 2R67EGHEDB
--> All tracks play correctly (though ratings are missing as expected)
4 Configure an identical sync profile in MMA then Enable auto-conversion for all files > 192kbps in the sync profile in MMW, and initiate Wi-Fi sync

--> Sync dialog prompts to delete 'Niggun Nevo' for some reason
5 Accept deletion
--> 3 Files resync ('Ana Avda', 'Hazorim', and 'Niggun Nevoh' (not sure why--they were already on the device)
Debug log: TV5WQ3XTPM
6 Attempt to play the files in New Downloads playlist
--> 'Strong World' displays but 'Petit Roi' plays.
--> 'Or Ka'ze' displays but 'Oh Yeah' plays.
--> Many tracks in both playlists exhibit the same problem.
--> Also, I didn't notice this previously, but:
- the song 'Ima Aba Vekol Hashar' is missing from the 'New downloads' playlist and from the Tracks list in MMA!
- the songs Yahrzeit Niggun and ???? appear in duplicate (one with ratings and the other without--implying a matching problem)
- the song 'Ima Aba Vekol Hashar' (along with a bunch of other tracks that aren't on the sync list) appear in another directory called primary:Music/ !!
--> Note that the problem also occurs when playing Tracks directly (i.e. not via a Playlist)
Debug log: B77HRQF3EP

marek

2017-01-30 22:09

developer   ~0047115

Fixed in build 668

There were two issues:
1. regression with document ID caused pairing issues
2. long term issue that I have found too - the pairing wasn't working correctly probably for a long time - because it was hard to find it. The sync looks correct but the audio doesn't match the metadata.

rusty

2017-01-31 00:49

administrator   ~0047120

Last edited: 2017-01-31 13:56

View 3 revisions

Verified 668. The only strange issue is that as with previous tests above:
After step 4 --> Sync dialog prompts to delete 'Niggun Nevo' for some reason
After step 5 --> 3 Files resync ('Ana Avda', 'Hazorim', and 'Niggun Nevoh' (not sure why--they were already on the device)

Is this a bug? Any idea why this happens (all of the tracks on the shlomo katz playlist are FLAC (and > 192kbps) thereby matching the autoconversion rules, so why is only 1 deleted, and why are 3 resynced? One would expect that if 1 file was deleted because it failed to match then only 1 file would be recopied OR that if 3 files needed to be recopied then 3 files should have been deleted due to failed matches.

Debug log before sync: A6IDAM5AIE
Debug log after sync: 6Q7ZCWADHG

rusty

2017-02-06 14:32

administrator   ~0047197

Last edited: 2017-02-06 14:47

View 2 revisions

Tested build 670, and in addition to the problems described at 0013957:0047120, after step 5, MMA displays both playlists in duplicate.
Log IRV3TYN8GK

EDIT: to clarify - it seems as if MMA syncs the playlist without recognizing that the original playlists (from step 1.2) are already there--as if the playlists failed to match. Subsequent sync operations update the synced playlist, but fail to delete the original .m3u playlist.

marek

2017-02-07 01:07

developer   ~0047204

Re 0013957:0047197 :
It was fixed in build 471. MMW probably process Playlist and Media paths slightly differently. So I had to fix conversion of document id to path that is processed by MMW.

Re 0013957:0047120 :
This is slightly more complicated. Rusty, the behaviour is correct and you don't have to generate MMW log
1. Niggun Nevoh - There is duplicate in MMW library with two different IDs: 15472 and 5877. The track is paired with 15472 but 5877 is on sync list.
2. Ana avda - This track is twice in synclist so I overlooked first time that the pairing failed for one of them.
3. Hazorim - pairing failed. Maybe due to apostrophe sign ?? Hazor & apos ; im

rusty

2017-02-07 05:17

administrator   ~0047206

Verified 671.