View Issue Details

IDProjectCategoryView StatusLast Update
0013881MediaMonkey for AndroidSynchronizationpublic2017-01-27 14:19
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0 
Target Version1.3.0 
Summary0013881: Anomalous behavior when installing MMA 1.2.0 and uninstalling MMA 1.3.0
DescriptionOver the course of testing build 660, I noticed some strange behavior in the following case:

1 installed MMA 1.2.0 and synced
2 uninstalled MMA 1.2.0 and installed MMA 1.3.0 and synced
3 uninstalled MMA 1.3.0 and then installed MMA 1.2.0 and synced
--> sync errors / incomplete synchronization
4 delete tracks in MMA 1.2.0
--> they appear to delete, but they remain on the device

I suppose that the DB from MMA 1.3.0, isn't backwards compatible with MMA 1.2.0 ?

If so, would it make sense to version check that a DB is compatible?
TagsNo tags attached.
Fixed in build

Relationships

related to 0013957 closedmarek Tracks don't match to the displayed track 

Activities

marek

2017-01-12 16:09

developer   ~0046917

You are right, it isn't backward compatible. We convert all paths to document id form. And we do not have any code to convert it backwards of course in 1.2.0.

What did you mean by adding version check?

rusty

2017-01-12 16:22

administrator   ~0046919

Per discussion:
How about something like: 'The MediaMonkey database on your device is from version x.x and is not compatible with the MediaMonkey y.y.

Delete the database and rescan?

[Yes] [No]

marek

2017-01-16 14:44

developer   ~0046979

I have discussed this with Martin and he said that deletion of DB when downgrading is already implemented. And it works fine for me too. There is no dialog but it should be deleted.

You have some issues after downgrading ? Could you please send log from 1.2.0?

rusty

2017-01-19 17:33

administrator   ~0047012

Waiting for build 665 to test due to 0013922

rusty

2017-01-24 03:17

administrator   ~0047053

I can't replicate this in 665. Resolving.