View Issue Details

IDProjectCategoryView StatusLast Update
0013922MediaMonkey for AndroidSynchronizationpublic2017-01-20 00:29
Reporterrusty 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0 
Target Version1.3.0Fixed in Version1.3.0 
Summary0013922: Tracks faill to sync after upgrading from 1.2 to 1.3.664 (regression)
DescriptionAs described by numerous users, upgrading to 1.3.664 and then syncing results in many tracks failing to sync.

Note that in the tests described there are 3 modes of failure:
1) MMA indicates that tracks failed to save, and the synced Playlists appear on the device but are missing some tracks (from the Playlist and from the device)
2) MMA indicates that tracks failed to save but the playlist tracks are on the device with missing artwork and ratings
3) MMA indicates that tracks failed to sync and the synced Artist appears in MMA but no tracks are contained within that Artist entry.

The fix to this should should ideally resolve the problems that testers of 664 are having--i.e. they shouldn't have to delete all content from their devices--resyncing with 665 should solve the problems.
Steps To Reproduce1 Install MMA 1.20 / MMW 4.14.1813
2 Add several tracks to the auto sync list with auto-conversion rules enabled
3 Wi-fi Sync
4 Modify rating in MMA
5 Wi-fi Sync
--> Ratings updated correctly
6 Install MMA 1.3.664
7 Add a playlist 'Grad Party'(tested with a nested playlist) to the sync list
8 Sync
--> 24 tracks fail to sync -- MMA indicates 'Failed to save' (e.g. Secret Agent Man, Green Onions, etc.)

Debug log: 3WFB86UQEJ
MMW debug log attached as well.

Note: tested on Nexus 5x running Android 7.1.1 (internal memory)

Notes re. sync settings:
1) The initially synced playlists are:
 - 1 Nested static playlist: Party Playlists > Party Background
 - 1 Static playlist: New Downloads

Both contain a mix of tracks in different formats, some of which match the auto-conversion criteria

2) The auto-conversion criteria are set to defaults + the rule for auto-conversion of any track > 192kbps is enabled

3) 'Delete unselected content copies' is enabled
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=86898

Note: based on user reports, the issue was introduced in 664
TagsNo tags attached.
Fixed in build665

Relationships

related to 0012406 closedLudek MediaMonkey (current) Auto-Sync: Artwork isn't updated for already synced files 
related to 0013646 closedmarek MediaMonkey for Android Artworks aren't updated from MMW during wifi sync 

Activities

rusty

2017-01-18 20:45

administrator  

Tracks fail to sync.zip (287,152 bytes)

rusty

2017-01-18 20:56

administrator   ~0047006

Last edited: 2017-01-18 21:46

View 2 revisions

Upon further testing, I see that all of the tracks that failed to sync we're undergoing auto-conversion. If I add another step:
9 Sync again
--> Same error

This made me wonder whether the bug is the same as 0013837

[EDIT] It's different than 0013837 since that issue is caused by MM5 (server side) and rebooting the PC/MM solves the problem. This issue isn't solved by rebooting the PC.

rusty

2017-01-18 21:36

administrator   ~0047007

Additional steps:

10 Upgrade MMW to 4.1.15.1824
11 Wi-fi sync
--> 26 tracks fail to sync again

MMA log: DHLP6M8MQF

rusty

2017-01-18 22:29

administrator   ~0047008

Last edited: 2017-01-18 23:02

View 4 revisions

I tried another test on another device--Huewei Honor 5x running Marshmallow (CM13) this time syncing to external memory:

1 Sync 2 playlists between MMA 1.3.0.663 and MMW 4.1.5.1824
--> Success
2 Update MMA to 1.3.0.664
3 Add 1 playlist 'Mexican night' to the sync list
--> MM indicated that tracks failed to sync
4 Go to the playlists node
--> The 'Mexican night' tracks / playlist _did_ sync, however, it synced incorrectly--although the tracks seem to be their, artwork and ratings are missing.
Debug log: 6HU8SR9LHW

5 Attempt to sync again
--> The 'Mexican night' tracks / playlist 'sync' again even though they're already on the device (in a strange state as described above).

6 Add Artist > Abba to the sync list and sync
--> The tracks fail to sync, although MMA creates nodes for Artist > Abba that contain no tracks.

rusty

2017-01-19 01:32

administrator   ~0047009

I tested on another device--Huawei Y6 Running Android 5.0, sync to external:
1 Sync 2 playlists with MMA 1.2.0.624 (auto-conversion enabled as in previous tests) vs MMW 4.1.5.1824
--> Success
2 Update to MMA 1.3.0.664
3 Add an Artist 'ABBA' to the sync list and sync
--> Sync error: failed to save 12 tracks
--> As with the Honor 5x, the tracks fail to sync, although MMA creates nodes for Artist > Abba that contain no tracks.

Debug log YUL7GW39ZH

marek

2017-01-19 15:46

developer   ~0047010

Last edited: 2017-01-19 17:06

View 4 revisions

Fixed in build 665

It is regression caused by 0013646 . It occurs when track has no album and it is updated.

rusty

2017-01-20 00:28

administrator   ~0047023

Verified 665 on all three devices.