View Issue Details

IDProjectCategoryView StatusLast Update
0013837MediaMonkey 5Syncpublic2020-03-24 16:32
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Summary0013837: Tracks periodically fail to auto-convert
DescriptionWhen syncing relatively large playlists (e.g. 300 tracks) many of which need to be auto-converted, auto-conversion stops working at a certain point resulting in the failure of some of the tracks to sync.

The workaround is to restart MM5 and then resync, and most of the tracks will convert (until the error reccurs). i.e. the problem is either that certain tracks/formats cause conversion to break until mm is restarted OR that there's some sort of leak that causes conversion to break until MM is restarted).

A debug log is posted to the ftp server in which 74 tracks failed to convert, among them:
White Shadows, Talk, The hardest part: all by Coldplay
Better Now by collective soul
Love in itself, John the Revelator, Precious: all by Depeche Mode
TagsNo tags attached.
Fixed in build2058

Relationships

related to 0013871 closedmichal AV when tagging MP3 file 

Activities

rusty

2017-01-06 06:21

administrator   ~0046861

Last edited: 2017-01-06 06:22

View 2 revisions

Raising priority to Immediate since this bug sometimes results in very strange MM5 behavior e.g. once the bug occurs a blank dialog appears in MM5. Then when MM5 is restarted, it appears with a blank screen (only the home node exists) and MM5 must be force closed.

Note also: this bug almost always occurs with any reasonably large playlist sync operation (e.g. 100 tracks).

petr

2017-01-08 20:44

developer   ~0046877

Unable to reproduce in current sources (most probably fixed in 0013871)

peke

2017-01-16 02:14

developer   ~0046954

Verified 2058 Unable to reproduce

Rusty can you confirm

peke

2020-03-24 16:32

developer   ~0057311

Verified 2234

Tested on 1k track sample various types and started multiple conversion tasks to do a stress test.