View Issue Details

IDProjectCategoryView StatusLast Update
0013191MediaMonkey (current)DB/FileMonitorpublic2018-07-23 20:33
Reporterpeke 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.1.14Fixed in Version4.1.14 
Summary0013191: Scanned external HDDs in MMW should be excluded from Portable devices list
DescriptionExternal HDDs usually are detected As portable devices by WMDM which is correct unless user scan external HDDs in MMW library which should automatically exclude that HDD from Portable devices list and remove it from MMW Tree or (More complicated solution) instead of showing sync options move focus to tree location of HDD in MMW library (if Entire Library tree is enabled).

As soon as some external HDD is scanned in MMW library it should not be handled as portable device but same as any scanned HDD.

Current solution/workaround is that user manually go to Portable Devices list and untick external HDD. It is rather confusing, non intuitive and not well described in our documentation which then lead to problems and duplicate or grayed tracks.
Additional InformationLSM-222-18603
TagsNo tags attached.
Fixed in build1809

Relationships

parent of 0013546 resolvedLudek MediaMonkey (current) MediaMonkey freezes when scanning/monitoring external drive after Windows 10 anniversary update 
related to 0009913 closedLudek MediaMonkey (current) Win 8: CPU utilization goes to 70-80% when external USB drive connected 
related to 0013666 feedbackrusty MediaMonkey 5 Plugging in a drive eats up CPU resources due to automated scanning 
related to 0014982 feedbackLudek MediaMonkey (current) Issues with syncing to external HDDs 

Activities

Ludek

2016-03-24 21:00

developer   ~0044325

Last edited: 2016-03-24 22:26

View 2 revisions

Similar to 0009913

Ludek

2016-03-24 22:21

developer   ~0044327

Last edited: 2016-03-24 22:26

View 4 revisions

Peke is probably right that if user Add/Rescan the HDD then we could auto-disable the device profile (untick) in Options -> Device Sync

This would prevent the unwanted scenarios when library tracks are device tracks and vice versa.

What do you think Rusty?

Ludek

2016-03-24 22:21

developer  

IMG_24032016_230449.png (71,135 bytes)
IMG_24032016_230449.png (71,135 bytes)

peke

2016-03-24 23:21

developer   ~0044328

As talked on IM we should not forget the case if Drive is already Scanned and User Delete Device from list of portable devices on next connection new profile will be created it should be also disabled by default.

That way we should probably eliminate high CPU usage due the 0009913

peke

2016-03-24 23:22

developer   ~0044329

Reverted to feedback in order for Rusty to confirm and triage for fixing in MMW 4.1.12

peke

2016-03-30 23:22

developer   ~0044353

Another user have issues with MMW due the this bug

Ludek

2016-03-31 09:45

developer   ~0044358

Last edited: 2016-03-31 11:30

View 4 revisions

Ticket LSM-222-18603 is combination of 0013191 and 0012868 as the last file has 266 chars long path, so we should ignore scanning device files with path longer than MAX_PATH until 0012868 is resolved.
Tracked as 0013195

Ludek

2016-03-31 19:40

developer   ~0044364

Last edited: 2016-03-31 19:45

View 4 revisions

Fixed in build 1786.

i.e. if a folder is scanned from external HDD into library (via Add/Rescan) and the device profile is enabled (HDD visible also as MTP device in MMW) then it is auto-hidden after the library scan (disabled). User can re-enable the profile in Options\Portable devices.

Ludek

2016-04-04 12:24

developer   ~0044378

Last edited: 2016-04-04 12:43

View 2 revisions

Improved in 1787

Because I can distinguish between external HDD and removable medias (SD card, flash drive) then external HDD is auto-disabled as device profile on first connection (even if it wasn't scanned into library). Can be manually enabled in Options -> Portable Device Sync as suggested in 0009913

To summarize:
Eternal HDD: is auto-disabled on first connect OR if it hasn't been synced yet
Removable media: is auto-disabled once a folder is scanned to the library and the device hasn't been synced yet

peke

2016-04-08 15:02

developer   ~0044419

Verified 1787

Ludek

2016-09-12 13:11

developer   ~0045633

Last edited: 2016-09-12 14:14

View 6 revisions

Re-opened:

Michal has two external discs with the same volume label and because we added the numbered suffixes (0013408) then one of the discs fails to match and remains enabled.

Fixed in 4.1.14.1809

peke

2016-09-13 21:52

developer   ~0045646

Verified 1809