View Issue Details

IDProjectCategoryView StatusLast Update
0013546MediaMonkey (current)DB/FileMonitorpublic2016-09-30 10:14
ReporterLudek 
PriorityimmediateSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionreopened 
Product Version4.1.14 
Target Version4.1.14Fixed in Version4.1.14 
Summary0013546: MediaMonkey freezes when scanning/monitoring external drive after Windows 10 anniversary update
DescriptionThere is several reports that build 4.1.14.1809+ with combination of Windows 10 anniversary update 1607 freezes MediaMonkey.

The freeze seems to happen when monitoring/scanning external drive.

The regression was caused by this 0013191:0045633 change.

Steps To ReproduceSteps for testing:
1. Open MMW and delete all USB Devices (Flash, HDDs) you want to use in test
2. Connect Multiple USBs
3. Start MMW

In at least 5/10 times MMW will freeze
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=86089
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=86067
PQV-420-98392

KGD-561-97465 Insider preview version.
TagsNo tags attached.
Fixed in build1813

Relationships

child of 0013191 closedLudek Scanned external HDDs in MMW should be excluded from Portable devices list 

Activities

Ludek

2016-09-26 09:14

developer   ~0045766

Fixed in 4.1.14.1812

peke

2016-09-27 02:20

developer   ~0045773

Last edited: 2016-09-27 02:27

View 2 revisions

Reopen looks like we missed it somewhere.

Debug logs and ELF files are uploaded to Ticket and each log is named per version and what we tested. Disabling all non needed devices fixed teh freeze on startup

NOTE: Freeze only happen on startup now and not when devices are connected when MMW is already open.

peke

2016-09-27 02:23

developer   ~0045774

Pictures attached.

peke

2016-09-27 02:26

developer  

peke

2016-09-27 02:26

developer  

Ludek

2016-09-27 10:22

developer   ~0045775

Fixed in 4.1.14.1813

peke

2016-09-27 15:14

developer   ~0045776

Verified 1813

peke

2016-09-30 10:14

developer   ~0045800

Confirmed fix in 1813 by several users